第六届湘潭市程序设计竞赛 -Happy Number

Happy Number

Accepted : 110   Submit : 263
Time Limit : 1000 MS   Memory Limit : 65536 KB 

Problem Description

Recently, Mr. Xie learn the concept of happy number. A happy number is a number contain all digit 7 or only 1 digit other than 7. For example, 777 is a happy number because 777 contail all digit 7, 7177 and 87777 both happy number because only 1 digit other
than 7. Whereas 887,799 9807,12345, all of them are not happy number. Now Mr. xie want to know for a given integer n, how many number among [1,n] are happy numbers, but counting them one by one is slow, can you help him?

Input

First line an integer t indicate there are t testcases(1≤t≤100). Then t lines follow, each line an integer n(1≤n≤106, n don‘t have leading zero).

Output

Output case number first, then the answer.

Sample Input

5
1
7
17
20
30

Sample Output

Case 1: 1
Case 2: 7
Case 3: 10
Case 4: 10
Case 5: 11

开始不敢做,怕暴力超时,后来写了暴力,但是 调代码又出问题,日

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
const int N = 1010;
using namespace std;
int l=0;
int main()
{
   int t,n;
   scanf("%d",&t);
   for(int i = 1;i<=t;i++)
   {
       int sum = 0,p = 0,pp = 0,ppp = 0,wz,mo;
       scanf("%d",&n);
       if(n<10)
       {
           printf("Case %d: %d\n",i,n);
           continue;
       }
       else if(n>=10)
       {
           wz = 0;
           int j;
           for( j = 10;j<=n;j++)
           {
               p = j;
               pp = 0,ppp = 0;
               wz = 0;
               while(p)
               {
                   mo = p % 10;
                   wz++;
                   if(mo==7)
                        pp++;

                   else
                        ppp++;
                    if(ppp>=2)
                        break;
                    p /= 10;
               }
               if(ppp==1 && pp==wz-1)
                        sum++;
                else if(ppp==0 && pp==wz)
                        sum++;
           }
           sum += 9;
           printf("Case %d: %d\n",i,sum);
       }

   }
    return 0;
}

第六届湘潭市程序设计竞赛 -Happy Number

时间: 2024-11-02 12:35:22

第六届湘潭市程序设计竞赛 -Happy Number的相关文章

河南省第六届大学生程序设计竞赛--Card Trick

Card Trick Time Limit: 2 Seconds    Memory Limit: 64 MB Description The magician shuffles a small pack of cards, holds it face down and performs the following procedure: 1. The top card is moved to the bottom of the pack. The new top card is dealt fa

没有什么不可能—记山东省第六届ACM程序设计竞赛(退役总结帖)

大一下学期,第一次听说了ACM这个词,当时每周六也开设了培训课,但我好像一次也没有去过,当时对这个词并没有什么太大的印象.后来学院里引进了自己的OJ,那时候我连基本的输入输出格式都不懂,当经历了一堆的WA,TLE之后突然换来的一个AC竟带来了莫名的喜悦.后来学院举办了第一届ACM程序设计竞赛,我报名参加了新秀赛和团队赛.三个小时的新秀赛,当时貌似做出了三道,意外的拿到了一等奖,这也成为了我大学生活的一个重要转折点.四个小时的团队赛,做得很艰难,各种不会,最后只做出了一道,排在三等奖的末尾.比赛之

河南省第六届大学生程序设计竞赛--异形卵

异 形 卵 Time Limit: 1 Second    Memory Limit: 64 MB Description 我们探索宇宙,是想了解浩瀚星空的奥妙,但我们却很少意识到宇宙深处藏匿的危险,它们无时无刻不紧盯着我们的地球.如果外星人拜访我们,结果可能与哥伦布当年踏足美洲大陆不会有什么两样,这是历史,也是现实. 在ZDM-777星球上发现的休眠异形卵,其外表与常见的卵不同,表面被一层石墨覆盖.当人走近时,那层石墨开始消融,能看到里面的异形卵正在活动,异形卵是活物,具备一些热量或压力传感器

河南省第六届大学生程序设计竞赛--外星人的供给站

外星人的供给站 Time Limit: 2 Seconds    Memory Limit: 512 MB Description 外星人指的是地球以外的智慧生命.外星人长的是不是与地球上的人一样并不重要,但起码应该符合我们目前对生命基本形式的认识.比如,我们所知的任何生命都离不开液态水,并且都是基于化学元素碳(C)的有机分子组合成的复杂有机体. 42岁的天文学家Dr. Kong已经执著地观测ZDM-777星球十多年了,这个被称为"战神"的红色星球让他如此着迷.在过去的十多年中,他经常

最舒适的路线--河南省第六届大学生程序设计竞赛

题目描述 异形卵潜伏在某区域的一个神经网络中.其网络共有N个神经元(编号为1,2,3,…,N),这些神经元由M条通道连接着.两个神经元之间可能有多条通道.异形卵可以在这些通道上来回游动,但在神经网络中任一条通道的游动速度必须是一定的.当然异形卵不希望从一条通道游动到另一条通道速度变化太大,否则它会很不舒服. 现在异形卵聚居在神经元S点,想游动到神经元T点.它希望选择一条游动过程中通道最大速度与最小速度比尽可能小的路线,也就是所谓最舒适的路线. 输入 第一行: K     表示有多少组测试数据.

River Crossing---河南省第六届大学生程序设计竞赛

题目描述 Afandi is herding N sheep across the expanses of grassland  when he finds himself blocked by a river. A single raft is available for transportation.Afandi knows that he must ride on the raft for all crossings, but adding sheep to the raft makes

探寻宝藏--河南省第六届大学生程序设计竞赛

题目描述 传说HMH大沙漠中有一个M*N迷宫,里面藏有许多宝物.某天,Dr.Kong找到了迷宫的地图,他发现迷宫内处处有宝物,最珍贵的宝物就藏在右下角,迷宫的进出口在左上角.当然,迷宫中的通路不是平坦的,到处都是陷阱.Dr.Kong决定让他的机器人卡多去探险. 但机器人卡多从左上角走到右下角时,只会向下走或者向右走.从右下角往回走到左上角时,只会向上走或者向左走,而且卡多不走回头路.(即:一个点最多经过一次).当然卡多顺手也拿走沿路的每个宝物. Dr.Kong希望他的机器人卡多尽量多地带出宝物.

nyoj714 Card Trick(第六届河南省程序设计大赛)

题目714 题目信息 运行结果 本题排行 讨论区 Card Trick 时间限制:1000 ms  |  内存限制:65535 KB 难度:3 描述 The magician shuffles a small pack of cards, holds it face down and performs the following procedure: The top card is moved to the bottom of the pack. The new top card is deal

NYOJ - 716 - River Crossing --第六届河南省程序设计大赛 (简单DP!!)

River Crossing 时间限制:1000 ms  |  内存限制:65535 KB 难度:4 描述 Afandi is herding N sheep across the expanses of grassland  when he finds himself blocked by a river. A single raft is available for transportation. Afandi knows that he must ride on the raft for