HDU_1028_Ignatius and the Princess III_(母函数,dp)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17917    Accepted Submission(s): 12558

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

看了题解,学了两种方法。一种是母函数,一种是dp。

母函数:组合数学方法,第一次接触。

  此题构造的母函数(1+x^1+x^2+x^3...+x^n)(1+x^2+x^4+x^6...+x^2n).....

  第一项表示(0个1,1个1,2个1,3个1...),第二项表示(0个2,1个2,2个2,3个2,4个2...)以此类推。

  展开后,每一项的指数表示划分的这个数,系数表示该数的划分数。

import java.util.*;
import java.io.*;

public class Main {

    public static int cal(int n)
    {
        int c1[]=new int [n+1];
        int c2[]=new int [n+1];
        for(int i=0;i<=n;i++)
        {
            c1[i]=1;
            c2[i]=0;
        }
        for(int i=2;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
                for(int k=0;k+j<=n;k+=i)
                    c2[j+k]+=c1[j];
            for(int j=0;j<=n;j++)
            {
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        return c1[n];
    }
    public static void main(String[] args) {
        Scanner in=new Scanner(System.in);
        int n;
        while(in.hasNext())
        {
            n=in.nextInt();
            System.out.println(cal(n));
        }
    }

}

dp:

dp[i][j]表示i这个数划分为最大加数不超过j的划分数。

if(i>j)  dp[i][j]=dp[i][j-1]+dp[i-j][j];

else if(i==j)   dp[i][j]=dp[i][j-1]+1;

else if(i<j)   dp[i][j]=dp[i][i];

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

int dp[150][150];

int main()
{
    int n,m;
        //dp[1][1]=1;
        for(int i=1; i<=150; i++)
            for(int j=1; j<=150; j++)
            {
                if(j==1)
                    dp[i][j]=1;
                else if(i==j)
                    dp[i][j]=dp[i][j-1]+1;
                else if(i>j)
                    dp[i][j]=dp[i][j-1]+dp[i-j][j];
                else if(i<j)
                    dp[i][j]=dp[i][i];
            }
        while(scanf("%d",&n)!=EOF)
        {
            printf("%d\n",dp[n][n]);
        }

    return 0;
}

时间: 2024-10-11 21:14:44

HDU_1028_Ignatius and the Princess III_(母函数,dp)的相关文章

HDU1028Ignatius and the Princess III母函数入门

这个题也可以用递归加记忆化搜索来A,不过由于这题比较简单,所以用来做母函数的入门题比较合适 以展开后的x4为例,其系数为4,即4拆分成1.2.3之和的拆分数为4: 即 :4=1+1+1+1=1+1+2=1+3=2+2 这里再引出两个概念整数拆分和拆分数: #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> #include <climits> #in

hdu 1028 Ignatius and the Princess III 简单dp

题目链接:hdu 1028 Ignatius and the Princess III 题意:对于给定的n,问有多少种组成方式 思路:dp[i][j],i表示要求的数,j表示组成i的最大值,最后答案是dp[i][i].那么dp[i][j]=dp[i][j-1]+dp[i-j][i-j],dp[i][j-1]是累加1到j-1的结果,dp[i-j][i-j]表示的就是最大为j,然后i-j有多少种表达方式啦.因为i-j可能大于j,这与我们定义的j为最大值矛盾,所以要去掉大于j的那些值 /*******

HDU 1028 Ignatius and the Princess III(母函数)

Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 15794    Accepted Submission(s): 11138 Description "Well, it seems the first problem is too easy. I will let you kno

hdu1028(母函数+DP)

题目信息:求分解整数n的个数q(n);可以母函数或者DP http://acm.hdu.edu.cn/showproblem.php?pid=1028 AC代码: /****************************** 题目大意:求分解整数n的个数q(n) 例: 5 = 5; 5 = 4 + 1; 5 = 3 + 1 + 1; 5 = 3 + 2; 5 = 2 + 2 + 1; 5 = 2 + 1 + 1 + 1; 5 = 1 + 1 + 1 + 1 + 1; sum(5) = 7;不区

HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)

此题无法用JavaAC,不相信的可以去HD1029题试下! Problem Description "OK, you are not too bad, em- But you can never pass the next test." feng5166 says. "I will tell you an odd number N, and then N integers. There will be a special integer among them, you hav

Ignatius and the Princess III(母函数)

Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 16028    Accepted Submission(s): 11302 Problem Description "Well, it seems the first problem is too easy. I will let

hdoj 1028 Ignatius and the Princess III(区间dp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1028 思路分析:该问题要求求出某个整数能够被划分为多少个整数之和(如 4 = 2 + 2, 4 = 2 + 1 + 1),且划分的序列 2, 2 或者 2, 1, 1为单调非递增序列: 使用动态规划解法:假设dp[i][j]表示整数i被划分的序列中最大值不超过j的所有的可能,则使用类似于0-1背包的思考方法: (1)如果i == j,则dp[i][j] = dp[i][j-1] + 1: (2)如果

HDU Ignatius and the Princess III (母函数)

Problem Description "Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. "The second problem is, given an positive integer N, we define an equation like this:  N=a[1]+a[2]+a[3]+...+a[

HDU1028 Ignatius and the Princess III 母函数

Ignatius and the Princess III Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 25867    Accepted Submission(s): 17879 Problem Description "Well, it seems the first problem is too easy. I will let