poj 3279 Fliptile

Fliptile

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4864   Accepted: 1862

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

反转类问题.

有N*M个方格,每个上面有数字0或者1

操作一个方格,这个方格即其相邻的四个方格(有公共边)会改变状态(由0变1或者由1变0)

问至少需要多少次操作,所有的状态都为0

如果有多组,输出字典序小的那一组.

跟开关灯的那题相似.

因为每个开关灯的动作还影响其他相邻灯的状态.所以对于这种题,一般思路是,先定住一部分,再由已知定住的这部分去确定其他部分.

对于这道题而言

首先我们可以很容易发现,操作数为偶数和为0是等价的.

操作数为1和为奇数是等价的.

对于这道题而言,我们可以首先枚举第一行的状态,一共有 2<<n  种.

然后如果 a[i-1][j]为1,因为i-1行的状态已经确定,无法改变,所以能影响到a[i-1][j]的只有a[i][j]

那么a[i][j]一定要操作一次

最后判断最后一行是否都为0,如果为0,表示这种情况是合法的

然后找到操作数最小的一组.

字典序的话,只要是枚举的时候按照数的大小顺序就可以保证.

学会了用memcpy函数.

/*************************************************************************
    > File Name: code/2015summer/searching/D.cpp
    > Author: 111qqz
    > Email: [email protected]
    > Created Time: Thu 23 Jul 2015 09:28:49 PM CST
 ************************************************************************/
#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#define y0 abc111qqz
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define tm crazy111qqz
#define lr dying111qqz
using namespace std;
#define REP(i, n) for (int i=0;i<int(n);++i)
typedef long long LL;
typedef unsigned long long ULL;
const int N=20;
int a[N][N],ans[N][N],op[N][N];
int m,n;
int dirx[10]={0,0,0,-1,1};
int diry[10]={0,1,-1,0,0};
int rec[N][N];
void solve(int x,int y)
{
    for ( int i = 0 ; i < 5 ; i++ )
    {
      int newx = x + dirx[i];
      int newy = y + diry[i];
      if (newx>=1&&newx<=m&&newy>=1&&newy<=n)
      {
        a[newx][newy]=a[newx][newy]^1;
      }
    }
}
bool on (int x,int y)
{
    int res = a[x][y];
    for ( int i = 0 ; i < 5 ; i++ )
    {
      int newx = x + dirx[i];
      int newy = y + diry[i];
      if (newx>=1&&newx<=m&&newy>=1&&newy<=n)
      {
        res = res+op[newx][newy];
      }
    }
    return res&1;
}
int main()
{
    cin>>m>>n;
    int mi = 9999999;
    memset(rec,0,sizeof(rec));
    for ( int i = 1 ; i <= m ; i++ )
    {
      for (int j = 1 ; j <= n ; j++)
      {
        cin>>a[i][j];
      }
    }
    bool flag = false;
    for ( int i = 0  ; i < (1<<n); i++ )   //枚举第一行的好改变情况
    {
        int tmp=i;
      int num=0;
      memset(op,0,sizeof(op));
        memset(ans,0,sizeof(ans));
      int k = n;
      while (tmp)
      {
        op[1][k]=tmp%2;
        if (op[1][k]==1) num++;
        tmp = tmp / 2;
        k--;
      }
//      cout<<"********************"<<endl;
//      for ( int i = 1 ; i <= n ; i++)
//      {
//        cout<<op[1][i]<<" ";
//      }
//      cout<<endl;
//      cout<<"*************************"<<endl;
      for ( int j = 2 ; j <= m ; j++ )
      {
        for ( int k = 1 ; k <= n ; k++ )
        {
            if (on(j-1,k))
            {
              op[j][k]=1;
              num++;
            }
        }
      }
      bool ok = true;
      for ( int j = 1 ; j <= n ; j++ )
      {
        if (on(m,j))
        {
            ok=false;
            break;
        }
      }
      if (ok)
      {
        flag = true;
        if (num<mi)
        {
            mi = num;
            memcpy(rec,op,sizeof(op));
        }
      }
    }
    if (flag)
    {
      for ( int i = 1 ; i <= m ; i++ )
      {
        cout<<rec[i][1];
        for ( int j = 2 ; j <= n ; j++ )
        {
            cout<<" "<<rec[i][j];
        }
        cout<<endl;
      }
    }
    else
    {
      printf("IMPOSSIBLE\n");
    }
    return 0;
}
时间: 2024-12-08 17:19:28

poj 3279 Fliptile的相关文章

状态压缩+枚举 POJ 3279 Fliptile

题目传送门 1 /* 2 题意:问最少翻转几次使得棋子都变白,输出翻转的位置 3 状态压缩+枚举:和之前UVA_11464差不多,枚举第一行,可以从上一行的状态知道当前是否必须翻转 4 */ 5 #include <cstdio> 6 #include <cstring> 7 #include <algorithm> 8 using namespace std; 9 10 const int MAXN = 20; 11 const int INF = 0x3f3f3f3

POJ 3279(Fliptile)题解

以防万一,题目原文和链接均附在文末.那么先是题目分析: [一句话题意] 给定长宽的黑白棋棋盘摆满棋子,每次操作可以反转一个位置和其上下左右共五个位置的棋子的颜色,求要使用最少翻转次数将所有棋子反转为黑色所需翻转的是哪些棋子(这句话好长...). [题目分析] 盯着奇怪的题目看了半天发现和奶牛没什么卵关系..奶牛智商高了产奶高是什么鬼说法... 这题刚开始被放到搜索的分类下了..然而这和搜索有什么关系..没经验所以想了各种和搜索沾边的方法,结果没想出解法,直到看了网上的题解,压根不是搜索啊有木有.

POJ 3279 Fliptile (二进制枚举+模拟)

Fliptile Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 3992   Accepted: 1518 Description Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which

poj 3279 Fliptile (简单搜索)

Fliptile Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 16558   Accepted: 6056 Description Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in whic

【POJ 3279 Fliptile】开关问题,模拟

题目链接:http://poj.org/problem?id=3279 题意:给定一个n*m的坐标方格,每个位置为黑色或白色.现有如下翻转规则:每翻转一个位置的颜色,与其四连通的位置都会被翻转,但注意只扩散一圈,不是连锁反应. 求最少翻转几个位置能够使所有n*m个位置都变为白色.若有解,求字典序最小的翻转方案(给出每个位置的翻转次数). 数据范围:n, m 属于 [1, 15] 思路:我们把翻转方案中的翻转称为“主动翻转”,翻转过程中受邻居影响而发生的翻转称为“被动翻转”.观察例子可得出如下几个

POJ 3279 Fliptile(DFS+反转)

题目链接:http://poj.org/problem?id=3279 题目大意:有一个n*m的格子,每个格子都有黑白两面(0表示白色,1表示黑色).我们需要把所有的格子都反转成黑色,每反转一个格子,它上下左右的格子都会跟着反转.请求出用最小步数完成反转时每个格子反转的次数.有多个解时,输出字典序最小的一组. 解题思路:只要枚举第一行的2^m种情况,如果一个位置上一行是1,那这个位置一定要反转,因为只有这一行能改变上一行,所以每一行的状态都是由前一行决定的.只要最后判断最后一行是不是都是0即可,

poj 3279 Fliptile(二进制)

http://poj.org/problem?id=3279 在n*N的矩阵上,0代表白色,1代表黑色,每次选取一个点可以其颜色换过来,即白色变成黑色,黑色变成白色,而且其上下左右的点颜色也要交换,求最少交换多少点能把全部换成颜色0 输出所需要换的点,用1表示,如果有多种方案,输出字典序足最小的方案 但是这题的数据里没有字典序的情况,所以没有比较字典序也可以过,我一开始就不知道这个怎么按字典序排 用二进制枚举第一行所有的情况,第一行的情况确定了,下面的就确定了 1 #include<cstdio

POJ 3279 Fliptile 状态压缩,思路 难度:2

http://poj.org/problem?id=3279 明显,每一位上只需要是0或者1, 遍历第一行的所有取值可能,(1<<15,时间足够)对每种取值可能: 对于第0-n-2行,因为上一行和本身行都已确定,所以可以确定下一行 最后检查第n-1行是否满足条件即可 #include <cstdio> #include <cstring> #include <algorithm> #include <queue> using namespace

POJ 3279 Fliptile(翻转)

题目链接:http://poj.org/problem?id=3279 题意:n*m棋盘区域,由0和1填充,0白,1,黑,(正反两面颜色各异)通过翻转操作使棋盘全部白色朝上,每次翻转棋子,棋子周围(上下左右)都要被翻转,问是否可能翻转 翻转成功,如果翻转成功,输出最少的翻转次数下每个棋子的翻转次数. 题解:有m列,所以最多有2^m种可能性,枚举第一行.然后从第i行(i从2开始)先开始考虑第i-1行,然后依次往下推,再判断最后一行是不是都翻转成白色. 1 #include <string> 2