2015南阳CCPC D - Pick The Sticks dp

D - Pick The Sticks

Time Limit: 1 Sec

Memory Limit: 256 MB

题目连接

Description

The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he‘s clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an L length segment. And the gold sticks as segments too. There were many gold sticks with different length ai and value vi. Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.

Can you help solve the mystery by finding out what‘s the maximum value of the gold sticks Xiu Yang could have taken?

Input

The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Each test case start with two integers, N(1≤N≤1000) and L(1≤L≤2000), represents the number of gold sticks and the length of the container stick. N lines follow. Each line consist of two integers, ai(1≤ai≤2000) and vi(1≤vi≤109), represents the length and the value of the ith gold stick.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is the maximum value of the gold sticks Xiu Yang could have taken.

Sample Input

4

3 74 12 18 1

3 74 22 18 4

3 54 12 28 9

1 110 3

Sample Output

Case #1: 2Case #2: 6Case #3: 11Case #4: 3

HINT

题意

给你一个长度为l的盒子,然后里面可以放置一排金砖,只要这个金砖的重心在盒子里面就好了

然后问你放置的金砖的最大价值是多少

题解:

如果不考虑伸出去的,那就是01背包问题

但是有伸出去的肿么办?那就分开考虑辣

直接暴力转移就好了

注意存在奇数问题,乘以二就好了

代码:

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;

long long dp[2][6005][3];
struct node
{
    int x;
    long long y;
};
node p[1005];
int main()
{
    int t;scanf("%d",&t);
    for(int cas = 1 ; cas <= t; cas++)
    {
        memset(dp,0,sizeof(dp));
        memset(p,0,sizeof(p));
        int n,l;scanf("%d%d",&n,&l);
        long long ans = 0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%lld",&p[i].x,&p[i].y);
            p[i].x*=2;
            ans = max(ans,p[i].y);
        }
        l *= 2;
        int now = 1;
        for(int i=1;i<=n;i++)
        {
            now = 1-now;
            for(int j=0;j<=l;j++)
                for(int k=0;k<3;k++)
                    dp[now][j][k]=dp[1-now][j][k];
            for(int j=l;j>=p[i].x/2;j--)
            {
                for(int k=0;k<3;k++)
                {
                    if(j>=p[i].x)dp[now][j][k]=max(dp[now][j][k],dp[1-now][j-p[i].x][k]+p[i].y);
                    if(k)dp[now][j][k]=max(dp[now][j][k],dp[1-now][j-p[i].x/2][k-1]+p[i].y);
                }
            }
        }
        for(int t=0;t<2;t++)
            for(int i=0;i<=l;i++)
                for(int k=0;k<3;k++)
                    ans = max(dp[t][i][k],ans);
        printf("Case #%d: %lld\n",cas,ans);
    }
}
时间: 2024-08-23 13:59:00

2015南阳CCPC D - Pick The Sticks dp的相关文章

2015南阳CCPC D - Pick The Sticks 背包DP.

D - Pick The Sticks Description The story happened long long ago. One day, Cao Cao made a special order called "Chicken Rib" to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting

2015南阳CCPC L - Huatuo&#39;s Medicine 水题

L - Huatuo's Medicine Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Huatuo was a famous doctor. He use identical bottles to carry the medicine. There are different types of medicine. Huatuo put medicines into the bottles and chain these b

2015南阳CCPC C - The Battle of Chibi DP

C - The Battle of Chibi Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao

2015南阳CCPC A - Secrete Master Plan 水题

D. Duff in Beach Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, w

2015南阳CCPC H - Sudoku 暴力

H - Sudoku Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller. Actually, Yi Sima was playing it different. F

2015南阳CCPC H - Sudoku 数独

H - Sudoku Description Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller. Actually, Yi Sima was playing it different. First of all, he tried to generate a 4×4 board

2015南阳CCPC E - Ba Gua Zhen 高斯消元 xor最大

Ba Gua Zhen Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description During the Three-Kingdom period, there was a general named Xun Lu who belonged to Kingdom Wu. Once his troop were chasing Bei Liu, he was stuck in the Ba Gua Zhen from Liang Zhuge.

2015南阳CCPC F - The Battle of Guandu 多源多汇最短路

The Battle of Guandu Time Limit: 1 Sec Memory Limit: 256 MB 题目连接 无 Description In the year of 200, two generals whose names are Cao Cao and Shao Yuan are fighting in Guandu. The battle of Guandu was a great battle and the two armies were fighting at

hdu5543(Pick The Sticks) 01背包

Pick The Sticks Time Limit: 15000/10000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)Total Submission(s): 2540    Accepted Submission(s): 850 Problem Description The story happened long long ago. One day, Cao Cao made a special order