1038: 亲和数

1038: 亲和数

时间限制: 1 Sec  内存限制: 128 MB
提交: 254  解决: 208
[提交][状态][讨论版]

题目描述

古希腊数学家毕达哥拉斯在自然数研究中发现,220 的所有真约数(即不是自身的约数)之和为:

1+2+4+5+10+11+20+22+44+55+110=284。
而 284 的所有真约数为 1、2、4、71、 142,加起来恰好为 220。人们对这样的数感到很惊奇,并称之为亲和数。一般地讲,如果两个数中任何一个数都是另一个数的真约数之和,则这两个数就是亲和数。
你的任务就编写一个程序,判断给定的两个数是否是亲和数。

输入

输入数据第一行包含一个数 M,接下有 M 行,每行一个实例,包含两个整数A,B; 其中 0 <= A,B <= 600000 ;

输出

对于每个测试实例,如果 A 和 B 是亲和数的话输出 YES,否则输出 NO

样例输入

2
220 284
100 200

样例输出

YES
NO

提示

来源

#include <iostream>
using namespace std;
int result(int n){
 int i,s=0;
 for(i=1;i<n;i++){
  if(n%i==0){
   s=s+i;
  }
 }
 return s;
}
int main(){
 int n,i,a,b;
 cin>>n;
 for(i=0;i<n;i++){
  cin>>a>>b;
  if(result(a)==b&&result(b)==a) cout<<"YES"<<endl;
  else cout<<"NO"<<endl;
 }
 return 0;
}

时间: 2024-10-09 21:39:17

1038: 亲和数的相关文章

HDU 1038[Biker&#39;s Trip Odometer]简单计算

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1038 题目大意:给轮子直径,转数,时间.要求输出走过的距离和时速(mile为单位) 关键思想:纯算 代码如下: #include <iostream> using namespace std; #define pi 3.1415927 int main(){ double d,r,t,l; int cnt=1; while(cin>>d>>r>>t&&a

Python练习题 048:Project Euler 021:10000以内所有亲和数之和

本题来自 Project Euler 第21题:https://projecteuler.net/problem=21 ''' Project Euler: Problem 21: Amicable numbers Let d(n) be defined as the sum of proper divisors of n (numbers less than n which divide evenly into n). If d(a) = b and d(b) = a, where a ≠ b

HDU 2040:亲和数

亲和数 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 20775    Accepted Submission(s): 12590 Problem Description 古希腊数学家毕达哥拉斯在自然数研究中发现,220的全部真约数(即不是自身的约数)之和为: 1+2+4+5+10+11+20+22+44+55+110=284. 而2

杭电OJ -- 2040 亲和数

#include <iostream> using namespace std; int qh_num(int a)//该函数主要用来获得数a的亲和数 { int sum = 0; for(int i = 1; i <= (int)a / 2; ++i) { if (a % i == 0) sum += i; } return sum; } int main() { int m; int a, b; cin >> m; while (m--) { cin >> a

500万以内的亲和数

//时间复杂度为O(N*log(N))//时间复杂度准确做法://n * (1 + 1/2 + 1/3 + 1/4 + ..... + 1/n) ~~ N*InN//所以第二个for循环的时间复杂度约为O(N*log(N)) #include <iostream> #include <cstdio> #include <cstring> #include <cstdlib> #include <cmath> #include <map>

hihoCoder #1038 : 01背包

思路:直接 DP解的,方式固定. 1 #include <iostream> 2 #include <stdio.h> 3 #include <cstring> 4 #include <string> 5 using namespace std; 6 7 int dp[100005]; 8 int coms[505]; 9 int value[505]; 10 int max(int a, int b){return a>b?a:b;} 11 12 i

杭电 HDU 1038 Biker&#39;s Trip Odometer

Biker's Trip Odometer Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4745    Accepted Submission(s): 3144 Problem Description Most bicycle speedometers work by using a Hall Effect sensor faste

亲和数

Problem Description 古希腊数学家毕达哥拉斯在自然数研究中发现,220的所有真约数(即不是自身的约数)之和为: 1+2+4+5+10+11+20+22+44+55+110=284. 而284的所有真约数为1.2.4.71. 142,加起来恰好为220.人们对这样的数感到很惊奇,并称之为亲和数.一般地讲,如果两个数中任何一个数都是另一个数的真约数之和,则这两个数就是亲和数. 你的任务就编写一个程序,判断给定的两个数是否是亲和数 Input 输入数据第一行包含一个数M,接下有M行,

[hdu-2040] 亲和数

亲和数 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 20184    Accepted Submission(s): 12195 Problem Description 古希腊数学家毕达哥拉斯在自然数研究中发现,220的所有真约数(即不是自身的约数)之和为: 1+2+4+5+10+11+20+22+44+55+110=284. 而2