Problem B: 平面上的点和线——Point类、Line类 (II)

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。

根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象的构造和析构次序。

接口描述:

Point::show()方法:按格式输出Point对象。

Line::show()方法:按格式输出Line对象。

Input

输入的第一行为N,表示后面有N行测试样例。每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

Output

输出为多行,每行为一条线段,起点坐标在前终点坐标在后,每个点的X坐标在前,Y坐标在后,Y坐标前面多输出一个空格,用括号包裹起来。输出格式见sample。

Sample Input

4 0,0 1,1 1,1 2,3 2,3 4,5 0,1 1,0

Sample Output

Point : (0, 0) Line : (0, 0) to (1, 1) is created. Line : (0, 0) to (1, 1) Line : (0, 0) to (1, 1) is erased. Line : (1, 1) to (2, 3) is created. Line : (1, 1) to (2, 3) Line : (1, 1) to (2, 3) is erased. Line : (2, 3) to (4, 5) is created. Line : (2, 3) to (4, 5) Line : (2, 3) to (4, 5) is erased. Line : (0, 1) to (1, 0) is created. Line : (0, 1) to (1, 0) Line : (0, 1) to (1, 0) is erased. Line : (1, -2) to (2, -1) is created. Line : (1, -2) to (0, 0) is created. Line : (2, -1) to (0, 0) is created. Line : (0, 0) to (2, -1) is created. Line : (1, -2) to (2, -1) Line : (1, -2) to (0, 0) Line : (2, -1) to (0, 0) Line : (0, 0) to (2, -1) Line : (0, 0) to (2, -1) is erased. Line : (2, -1) to (0, 0) is erased. Line : (1, -2) to (0, 0) is erased. Line : (1, -2) to (2, -1) is erased.

HINT

Append Code

append.cc,

int main()

{

    char c;

    int num, i;

    double x1, x2, y1, y2;

    Point p(1, -2), q(2, -1), t;

    t.show();

    std::cin>>num;

    for(i = 1; i <= num; i++)

    {

        std::cin>>x1>>c>>y1>>x2>>c>>y2;

        Line line(x1, y1, x2, y2);

        line.show();

    }

    Line l1(p, q), l2(p, t), l3(q, t), l4(t, q);

    l1.show();

    l2.show();

    l3.show();

    l4.show();

}

代码

#include <iostream>

using namespace std;

class Point

{

    friend class Line;

    double x,y;

     public:

    Point():x(0),y(0){}

    Point(double a,double b):x(a),y(b){}

    void show()

    {

             cout<<"Point : ("<<x<<", "<<y<<")"<<endl;

    }

};

class Line

{

    friend class Point;

    Point p1,p2;

public:

    Line(double a,double b,double c,double d):p1(a,b),p2(c,d)

    {

        cout<<"Line : ("<<p1.x<<", "<<p1.y<<") to ("<<p2.x<<", "<<p2.y<<") is created."<<endl;

    }

    Line(Point p,Point q):p1(p),p2(q)

    {

        cout<<"Line : ("<<p1.x<<", "<<p1.y<<") to ("<<p2.x<<", "<<p2.y<<") is created."<<endl;

    }

    void show()

    {

        cout<<"Line : ("<<p1.x<<", "<<p1.y<<") to ("<<p2.x<<", "<<p2.y<<")"<<endl;

    }

    ~Line()

    {

        cout<<"Line : ("<<p1.x<<", "<<p1.y<<") to ("<<p2.x<<", "<<p2.y<<") is erased."<<endl;

    }

};

int main()

{

    char c;

    int num, i;

    double x1, x2, y1, y2;

    Point p(1, -2), q(2, -1), t;

    t.show();

    std::cin>>num;

    for(i = 1; i <= num; i++)

    {

        std::cin>>x1>>c>>y1>>x2>>c>>y2;

        Line line(x1, y1, x2, y2);

        line.show();

    }

    Line l1(p, q), l2(p, t), l3(q, t), l4(t, q);

    l1.show();

    l2.show();

    l3.show();

    l4.show();

}

时间: 2024-10-19 09:27:23

Problem B: 平面上的点和线——Point类、Line类 (II)的相关文章

Problem A: 平面上的点和线——Point类、Line类 (I)

Description 在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段.现在我们封装一个"Point类"和"Line类"来实现平面上的点的操作. 根据"append.cc",完成Point类和Line类的构造方法和show()方法. 接口描述: Point::show()方法:按格式输出Point对象. Line::show()方法:按格式输出Line对象. Input 输入的第一行为N,表示后面有N行测试样例

Problem C: 平面上的点和线——Point类、Line类 (III)

Description 在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段.现在我们封装一个"Point类"和"Line类"来实现平面上的点的操作. 根据"append.cc",完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序. 接口描述: Point::show()方法:按格式输出Point对象. Line::show()方法:按格式输出Line对象.

Problem D: 平面上的点和线——Point类、Line类 (IV)

Description 在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段.现在我们封装一个"Point类"和"Line类"来实现平面上的点的操作. 根据"append.cc",完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序. 接口描述: Point::show()方法:按格式输出Point对象. Line::show()方法:按格式输出Line对象.

Problem A: 平面上的点——Point类 (III)

Description 在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定.现在我们封装一个"Point类"来实现平面上的点的操作. 根据"append.cc",完成Point类的构造方法和show()方法,输出各Point对象的构造和析构次序.实现showPoint()函数. 接口描述: showPoint()函数按输出格式输出Point对象,调用Point::show()方法实现. Point::show()方法:按输出格式输出Point对象. I

Problem E: 平面上的点——Point类 (II)

Description 在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定.现在我们封装一个"Point类"来实现平面上的点的操作. 根据"append.cc",完成Point类的构造方法和show()方法,输出各Point对象的构造和析构次序. 接口描述: Point::show()方法:按输出格式输出Point对象. Input 输入多行,每行为一组坐标"x,y",表示点的x坐标和y坐标,x和y的值都在double数据范围内.

Problem D: 平面上的点——Point类 (I)

Description 在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定.现在我们封装一个"Point类"来实现平面上的点的操作. 根据"append.cc",完成Point类的构造方法和show()方法. 接口描述: Point::show()方法:按输出格式输出Point对象. Input 输入多行,每行为一组坐标"x,y",表示点的x坐标和y坐标,x和y的值都在double数据范围内. Output 输出为多行,每行为一个点

Problem D: 平面上的点——Point类 (IV)

Description 在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定.现在我们封装一个"Point类"来实现平面上的点的操作. 根据"append.cc",完成Point类的构造方法和show().showCounter().showSumOfPoint()方法:实现showPoint()函数. 接口描述: showPoint()函数:按输出格式输出Point对象,调用Point::show()方法实现. Point::show()方法:按输出格

Problem E: 平面上的点——Point类 (V)

Description 在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定.现在我们封装一个"Point类"来实现平面上的点的操作. 根据"append.cc",完成Point类的构造方法和接口描述中的方法. 接口描述: showPoint()函数:按输出格式输出Point对象. Point::show()方法:按输出格式输出Point对象. Point::showSumOfPoint()方法:按格式输出程序运行至当前存在过的Point对象总数. Po

Problem F: 平面上的点——Point类 (VI)

Description 在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定.现在我们封装一个"Point类"来实现平面上的点的操作. 根据"append.cc",完成Point类的构造方法和接口描述中的方法和函数. 接口描述: showPoint()函数:按输出格式输出Point对象. Point::show()方法:按输出格式输出Point对象. Point::showSumOfPoint()方法:按格式输出程序运行至当前存在过的Point对象总数.