1027. Colors in Mars (20)【进制转换】——PAT (Advanced Level) Practise

题目信息

1027. Colors in Mars (20)

时间限制400 ms

内存限制65536 kB

代码长度限制16000 B

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output “#”, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a “0” to the left.

Sample Input

15 43 71

Sample Output

#123456

解题思路

进制转换

AC代码

#include <stdio.h>
void outc(int a){
    if (a <= 9) printf("%d", a);
    else printf("%c", a-10+‘A‘);
}
void out(int a){
    if (a >= 13){
        outc(a/13);
        outc(a%13);
    }else{
        printf("0");
        outc(a);
    }
}
int main()
{
    int r, g, b;
    scanf("%d%d%d", &r, &g, &b);
    printf("#");
    out(r);
    out(g);
    out(b);
    printf("\n");
    return 0;
}
时间: 2024-08-07 16:39:01

1027. Colors in Mars (20)【进制转换】——PAT (Advanced Level) Practise的相关文章

1081. Rational Sum (20)【模拟】——PAT (Advanced Level) Practise

题目信息 1081. Rational Sum (20) 时间限制400 ms 内存限制65536 kB 代码长度限制16000 B Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum. Input Specification: Each input file contains one test case. Each case star

1069. The Black Hole of Numbers (20)【模拟】——PAT (Advanced Level) Practise

题目信息 1069. The Black Hole of Numbers (20) 时间限制100 ms 内存限制65536 kB 代码长度限制16000 B For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new n

1104. Sum of Number Segments (20)【数学题】——PAT (Advanced Level) Practise

题目信息 1104. Sum of Number Segments (20) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1)

PAT 甲级 1027 Colors in Mars (20 分)(简单,进制转换)

1027 Colors in Mars (20 分) People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the

PAT Advanced 1027 Colors in Mars (20分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The

1027. Colors in Mars (20)

主题如以下: People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Bl

PAT:1027. Colors in Mars (20) AC

#include<stdio.h> #include<stdlib.h> int main() { int a,b,c; //[思维]168以内的数字可以用两位13进制数表示,大大简化代码 scanf("%d%d%d",&a,&b,&c); char arr[13]={'0','1','2','3','4','5','6','7','8','9','A','B','C'}; //转为13进制的符号 printf("#"

1015. Reversible Primes (20) ——PAT (Advanced Level) Practise

题目信息: 1015. Reversible Primes (20) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73

PAT (Advanced Level) 1027. Colors in Mars (20)

简单题. #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> using namespace std; void pri(int a) { if (a <= 9) printf("%d", a); else printf("%c", a-10+'A'); } void print(int a){ if (a >= 13