多次访问节点的DFS POJ 3411 Paid Roads

POJ 3411 Paid Roads

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6553   Accepted: 2430

Description

A network of m roads connects N cities (numbered from 1 to N). There may be more than one road connecting one city with another. Some of the roads are paid. There are two ways to pay for travel on a paid road i from city ai to city bi:

  • in advance, in a city ci (which may or may not be the same as ai);
  • after the travel, in the city bi.

The payment is Pi in the first case and Ri in the second case.

Write a program to find a minimal-cost route from the city 1 to the city N.

Input

The first line of the input contains the values of N and m. Each of the following m lines describes one road by specifying the values of aibiciPiRi (1 ≤ ≤ m). Adjacent values on the same line are separated by one or more spaces. All values are integers, 1 ≤ m, N ≤ 10, 0 ≤ Pi , Ri ≤ 100, Pi ≤ Ri (1 ≤ ≤ m).

Output

The first and only line of the file must contain the minimal possible cost of a trip from the city 1 to the city N. If the trip is not possible for any reason, the line must contain the word ‘impossible’.

Sample Input

4 5
1 2 1 10 10
2 3 1 30 50
3 4 3 80 80
2 1 2 10 10
1 3 2 10 50

Sample Output

110

大致题意:

有n座城市和m(1<=n,m<=10)条路。现在要从城市1到城市n。有些路是要收费的,从a城市到b城市,如果之前到过c城市,那么只要付P的钱,如果没有去过就付R的钱。求的是最少要花多少钱。

注意:路径是有向的。

这题难点在于“城市与城市之间可能存在多条路径”:

1、  输入数据时可能会出现多条 从城市a到城市b的路径信息,但是费用有所差别;

2、  对于 从城市a到城市b 的同一条路径,允许重复走。

有人会问,重复走同一条路径有什么意义?单纯增加费用而已,为什么不能标记所有路径,每条路只允许走一次,这样费用不是更少么?

我开始也是陷入了这种思维,但是这种想法其实“对一半,错一半”。

先来看一组数据:

6 5

1 2 1 10 10

2 3 4 10 100

2 4 2 15 15

4 1 1 12 12

3 6 6 10 10

如果每条路只允许走一次,那么方案只有1个:

1à2à3à6 共135元

但这组数据的正确答案是67元。为什么?正确的方案如下:

1à2à4à1à2à3à6 共67元

显然1à2重复走了一次,目的是为了先到达城市4,从而使得2à3这段路的费用从100缩减到10元。

看到这里很多同学好像就恍然大悟,但是问题马上又来了。如果同一条路允许重复走,那么就不能标记了,但一旦不标记,失去了搜索的限制条件,DFS就无法结束,不是陷入死循环了?

我刚才说这种思路“对一半,错一半”,“对”是对在“重复走会增加费用”,“错”是错在“重复走的对象不是某一条路,而是某一个环路”。在同一个环路重复走才会真正增加费用。但是标记环路是很麻烦的,那么能不能根据某一条路或某一个城市重复走过的次数来判断当前所走的方案已经出现了环路? 答案是可以的。

上述的例子已经验证过了,同一条路可以重复走,但是不能无限重复走,重复的次数是有限的。那么应该重复多少次才合理?这与m值有关。题目的m值范围为<=10,那么当人一个城市被到达的次数若  >3次(不包括3),所走的方案必然出现了环路(网上的同学称之为“闸数”)。

因此只需把bool vist[] 修改为 int vist[] 进行标记,本题就能解决了。

/*这道题目的难点就是每个点会被多次访问,这样dfs的边界条件就不好写了
我做这道题目中遇到的问题:
1.我想在找到一个点时,枚举他可以处理的边,结果当有多条边的时候,很难把情况枚举全。
  正解是当走到这条边的终点的时候,检验这条边的ci有没有被走过,再比较pi与ri的大小。
2.不会处理一条边多次走,重边和一个点多次走,一开始以为每个点只走一次,结果边界条件又不一定可以得到最优值。

标准答案中是限制了每个点最多走三次,因为m《=10,如果不确定的话,把3改为10照样可以
*/
#include<iostream>
using namespace std;
#include<cstdio>
#include<cstring>
#define N 11
#include<vector>
#define inf (1<<31)-1
struct Edge{
    int bi,ci,pi,ri;
};
vector<Edge>edge[N];
int ans,n,m,a,b,c,p,r,vis[N];
inline void input()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;++i)
    {
        scanf("%d%d%d%d%d",&a,&b,&c,&p,&r);
        edge[a].push_back({b,c,p,r});
    }
}
void dfs(int k,int cost)
{
    vis[k]++;
    if(cost>=ans) return;
    if(k==n)
    {
        ans=min(ans,cost);
        return;
    }
    int size=edge[k].size();
    for(int i=0;i<size;++i)
    {
        if(vis[edge[k][i].bi]>3) continue;
        int t=inf;
        if(vis[edge[k][i].ci]&&edge[k][i].pi<t)
          t=edge[k][i].pi;
         if(edge[k][i].ri<t)
          t=edge[k][i].ri;
         dfs(edge[k][i].bi,cost+t);
         vis[edge[k][i].bi]--;
    }
}
int main()
{
    input();
    ans=inf;
    dfs(1,0);
    if(ans==inf) printf("impossible");
    else printf("%d",ans);
    return 0;
 } 
时间: 2025-01-15 08:23:10

多次访问节点的DFS POJ 3411 Paid Roads的相关文章

poj 3411 Paid Roads(dfs,可重复访问节点)

http://poj.org/problem?id=3411 大致题意:n个城市由m条公路连接,两个城市之间可能有多条公路连接.经过每条公路都需要收费,对于城市a,b,若之前经过城市c那么只需交p元钱,否则交r元钱.问从城市1到n的最小花费. 思路:由于经过每条公路的收费有两种方式,那么有的城市可能要经过多次,以便获得更小的花费,但也有可能出现有环的情况,那么该城市经过多次只会徒增花费.所以我们定义vis[]数组标记该城市访问的次数,在该题中(m <= 10)当一个城市访问超过3次(网上说这个与

POJ 3411 Paid Roads(dfs)

*注:这一题很重要的是对与数据的处理和细节的把握把! http://poj.org/problem?id=3411 题目大意: 有n个城市,m条路,(0<=n,m<=10).从a到b,如果之前已经经过c点,那么付费p,否者付费r.求最小的费用,从1-->n! 注意: There may be more than one road connecting one city with another. so:你不能用map[a][b]存a->b的距离.只能有road [ i ]了. 还有

poj 3411 Paid Roads (dfs)

题目链接 题意:有N个城市被M条道路连接起来了,每两个城市之间可能存在超过一条路,但是城市之间是单向连接的. 每条路是要花费的.每条路的花费可以选择两种方式:1:假如a城市到达b城市,如果之前经过了c城市,那么这条 路上的花费为P也可以为R.2:如果没有经过c,则这条路上的花费为R.问从城市1到城市n最小的花费是多少. 思路:存在走多次边的情况,所以vis[]数组可以多次,但是这个题目的多次的上限为3(不知道为什么). 1 #include <iostream> 2 #include <

POJ 3411 Paid Roads 题解 《挑战程序设计竞赛》

POJ 3411 Paid Roads开路:N个城市间有m条单向路,分别从a到b,可以在c处交P路费,也可以直接交R路费.那么问题来了,你的挖掘机怎么开最省钱?3.4熟练掌握动态规划状态压缩DP乍一看可以Dijkstra,实际上的确可以Dijkstra.不过多了一个预交费的c,所以在遍历的时候多了一维状态,这个维度储存当前走过的城市集合.在Dijkstra的时候,如果走过了c那么就有两个选择,选其中最省的即可:否则没得选.#include <iostream> #include&nb.

POJ 3411 Paid Roads

题目来源:http://poj.org/problem?id=3411 Paid Roads Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 5383   Accepted: 1923 Description A network of m roads connects N cities (numbered from 1 to N). There may be more than one road connecting on

poj 3411 Paid Roads(dfs)

Description A network of m roads connects N cities (numbered from 1 to N). There may be more than one road connecting one city with another. Some of the roads are paid. There are two ways to pay for travel on a paid road i from city ai to city bi: in

POJ 3411 Paid Roads(SPFA || DFS)

题目链接 题意 : 要从1城市到n城市,求最短路是多少,从a城市到达b城市的路程,如果你到过c城市,则需要走p,否则走r长. 思路 : 因为可以来回走,所以不能用单纯的最短路,可以用二维SPFA,状态压缩一下,第二维来记录状态,表示到过这个点的第几个状态.也可以用DFS,因为最多十个点,所以如果走某一个点走过三遍说明就是真的只增加费用了,也就是真正的在走环路了.DFS分析 二维SPFA 1 #include <stdio.h> 2 #include <string.h> 3 #in

广大暑假训练1 E题 Paid Roads(poj 3411) 解题报告

题目链接:http://poj.org/problem?id=3411 题目意思:N个city 由 m 条路连接,对于一条路(假设连接Cityia和 Cityb),如果从Citya 去 Cityb的途中,之前已经走过Cityc(可能会等于a),那么就可以交p的钱,否则之前未走过Cityc,就一定要交r 的路费啦. 注意,一个点可以被反复多次走,也就是可能构成环,虽然路走长了,但路费便宜了,这个问题要考虑到.还有就是剪枝啦:如果当前求得的路费比以前求得的答案要大,那就要回溯. mincost 明明

5、层次关系访问节点和创建节点

层次关系访问节点和创建节点 1 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 2 <html xmlns="http://www.w3.org/1999/xhtml"> 3 <head> 4 <meta htt