POJ 2239-Selecting Courses(二分图_最大匹配+哈希建图)

Selecting Courses

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8781   Accepted: 3922

Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more
as possible. Of course there should be no conflict among the courses he selects.

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several
times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks,
a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him?

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming‘s college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <=
7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4

题意:有n门课程可以选择,接下来n行(编号为从1-n),每行第一个数k,代表该门课程上课的时间点,接下来2*k个,每两个为一组(p,q)代表该节课在星期q的p班开始(一个12个班,一周7天)。求最多可以上几门课。

思路:如果不加上他的构图方式,就是一个纯的二分图求最大匹配。建图方式采用哈希表的方式,用p*12+q的方式存取,顺便还可以处理冲突。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
int map[510][510];
int vis[510];
int link[510];
int n;
int dfs(int u)
{
    int i;
    for(i=1;i<=510;i++){
        if(map[u][i]&&!vis[i]){
            vis[i]=1;
            if(link[i]==-1||dfs(link[i])){
                link[i]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i,j,k;
    int p,q;
    int sum;
    while(~scanf("%d",&n)){
    memset(link,-1,sizeof(link));
    memset(map,0,sizeof(map));
    for(i=1;i<=n;i++){
        scanf("%d",&k);
        while(k--){
            scanf("%d %d",&p,&q);
            //map[p*12+q][i]=1;
            map[i][p*12+q]=1;
        }
    }
    sum=0;
    for(i=1;i<=n;i++){
        memset(vis,0,sizeof(vis));
        if(dfs(i))
            {
                //printf("%d---->",dfs(i));
                sum++;
            }
    }
    printf("%d\n",sum);
    }
    return 0;
}
时间: 2024-08-03 01:53:16

POJ 2239-Selecting Courses(二分图_最大匹配+哈希建图)的相关文章

[POJ] 2239 Selecting Courses(二分图最大匹配)

题目地址:http://poj.org/problem?id=2239 Li Ming大学选课,每天12节课,每周7天,每种同样的课可能有多节分布在不同天的不同节.问Li Ming最多可以选多少节课.把n种课划分为X集合,把一周的84节课划分为Y集合, 从Xi向Yi连边,那么就转化成了求二分图的最大匹配数,然后匈牙利算法就可以了. 1 #include<cstdio> 2 #include<iostream> 3 #include<string.h> 4 #includ

POJ 2239 Selecting Courses【最大匹配】

大意: 有一些课程,每个课程的上课时间在每周可能会有多节,你可以从中任选一个时间去听课, 每周七天一天12节课  告诉你每节课的上课时间问在不冲突的情况下最多上几节课? 分析: 左集合课程 右集合时间 边为该节课对应的上课时间 求最大匹配就行了 代码: 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <vector> 5 using namespace std

poj——2239 Selecting Courses

poj——2239   Selecting Courses Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10656   Accepted: 4814 Description It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the c

POJ 2239 Selecting Courses(二分匹配)

题目链接:http://poj.org/problem?id=2239 Description It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning

POJ 2239 Selecting Course 二分图匹配(水)

http://poj.org/problem?id=2239 题意:总共7天,每天有12个教室使用,每门课有(t,pi,qi) 表示该门课每周开t次在第qi天,第pi间教室i=1..t 总共n门课 n<=300,问最多能选多少种不同的课程? 左边点为课程 右边点为(p,q) 把(p,q)看成排列中的序数 化成整数(p-1)*12+q.求二分图的最大匹配即可 复杂度为O(nm) #include <iostream> #include <cstring> #include &l

Poj 2239 Selecting Courses 【二分匹配】

Selecting Courses Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 9007 Accepted: 4010 Description It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming i

POJ 2239 Selecting Courses

二分图的最大匹配.课程和时间可以看做二分图. #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> using namespace std; const int MAXN=505; int nx,ny; int g[MAXN][MAXN]; int cx[MAXN],cy[MAXN]; int mk[MAXN]; int n; int ZH[10000]; int pat

POJ 2226-Muddy Fields(二分图_最小点覆盖+神建图orz)

Muddy Fields Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8434   Accepted: 3124 Description Rain has pummeled the cows' field, a rectangular grid of R rows and C columns (1 <= R <= 50, 1 <= C <= 50). While good for the grass, t

poj 2239 Selecting Courses(二分匹配简单模板)

http://poj.org/problem?id=2239 这里要处理的是构图问题p (1 <= p <= 7), q (1 <= q <= 12)分别表示第i门课在一周的第p天的第q节课上 其中二分图的X集合里表示课程i,那么我们要解决的就是Y集合了 将第i门课在一周的第p天的第q节课上进行编号,这样Y集合就是 上课时间的编号了 #include<stdio.h> #include<string.h> #include<math.h> #in