FZU 2140 Forever 0.5 (几何构造)

Forever 0.5

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

Sample Input

3

2

3

5

Sample Output

No

No

Yes

0.000000 0.525731

-0.500000 0.162460

-0.309017 -0.425325

0.309017 -0.425325

0.500000 0.162460

Hint

This problem is special judge.

题意:找n个点满足上述五个条件。

题解:n=1和n=2的时候不能构成多边形输出No,n=3的时候最大是边长为1的等边三角形,面积为4分之根号3小于0.5不符合条件输出No。当n=4的时候,在等边三角形的一个顶点的高的方向加一个点,距离该顶点的距离为1即可满足五个条件,如图所示。

AC=AB=BC=BD=1。多边形外侧是一个以(0,0)为圆心半径为1的圆。

当n>=5时,在BC弧上加点即可,Smax=S扇形ABC+S三角形ACD=pi/6+1*(1-sqrt(3)/2)/2=0.59058。符合条件。

角bac是60度也就是pi/3,新加入的点的弧度f为pi/3-0.01*(n-4)即可,n最大100,最多加入96个点不会溢出。

新加入点的横坐标就是cos(f),纵坐标就是sin(f)。用y=sqrt(1-x*x)算也行。

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
#define pi 3.1415926535897931
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        if(n<=3)
        {
            printf("No\n");
        }
        else
        {
            printf("Yes\n"); //开始的时候忘了输出Yes错了三遍
            double a=sqrt(3)/2.0;
            printf("0 0\n");
            printf("1 0\n");
            printf("0.5 %.6lf\n",a);
            printf("0.5 %.6lf\n",a-1);
            double b=pi/3.0;
            for(int i=0;i<n-4;i++)
            {
                b=b-0.01;
                printf("%.6lf %.6lf\n",cos(b),sin(b));
            }
        }
    }
    return 0;
}
时间: 2024-10-11 17:00:01

FZU 2140 Forever 0.5 (几何构造)的相关文章

ACM学习历程—FZU 2140 Forever 0.5(计算几何 &amp;&amp; 构造)

Description Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions: 1. The distance between any two points is no greater than 1.0. 2. The distance between any point and the origi

【构造】 FZU 2140 Forever 0.5

点击打开链接 题意:输入N,表示有N个点, 要求: 1.任意两点的距离≤ 1.0 2.每个点与原点的距离≤1.0 3.有N对点间的距离=1.0 4.N个点形成的面积≥0.5 ≤0.75 可以先取一个以原点为顶点,另外两个点在单位圆上的正三角形 其他的点就在圆弧BC上 将BC等分 而且N==4时 第四个点必须要在BC中点上 #include <cstdio> #include <cstdlib> #include <cstring> #include <climit

FZU OJ 2140 Forever 0.5 (几何)

Problem 2140 Forever 0.5 Accept: 269    Submit: 934    Special Judge Time Limit: 1000 mSec    Memory Limit : 32768 KB  Problem Description Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the follo

【cocos2d-js官方文档】十八、Cocos2d-js v3.0的对象构造和类继承

在Cocos2d-JS中,对象的构造方式和Cocos2d-x一样,使用各个类的create函数来构造.在Cocos2d-JS v3.0我们还将为你带来一种传统的方式,即使用new操作符.另外,在v3.0 alpha1版本中,因为我们还没有找到较好的解决办法,所以不能继承JSB中的引擎类.但是在v3.0 alpha2中,这个问题已经解决了.由于使用new操作符,编写继承代码也更加容易了. 在这篇文档中,我们将会介绍如何使用它们,以及简要的实现原理. 1. 弃用的create函数 由于Cocos2d

SDL2.0的几何图行绘画

SDL2.0的几何图形绘画 通过SDL_Window.SDL_Renderer.SDL_Texture三者实现了简单的几何图形绘画. 包括了SDL_RenderDrawPoint.SDL_RenderFillRect.SDL_RenderDrawLine.SDL_SetRenderDrawColor等. 具体看代码吧(VS2012运行): 1 #include <stdio.h> 2 #include <string.h> 3 #include <time.h> 4 #

FZU 2148 Moon Game (枚举+几何)

 Problem 2148 Moon Game Accept: 403    Submit: 1126Time Limit: 1000 mSec    Memory Limit : 32768 KB  Problem Description Fat brother and Maze are playing a kind of special (hentai) game in the clearly blue sky which we can just consider as a kind of

百度云BAE3.0 的ssh构造(本机ssh项目迁移到BAE3.0)

依据百度云的java部署文档进行部署 http://developer.baidu.com/wiki/index.php?title=docs/cplat/bae/java 做例如以下改动,然后把项目打包成ROOT上传 1.使用Spring时在原来基础上改动application.xml.包含数据库名.username和password 2.改动hibernate的全部.hbm.xml文件中的catalog,比如,把catalog属性改动为你的数据库名 http://blog.csdn.net/

Swift 的类、结构体、枚举等的构造过程Initialization(上)

构造过程是为了使用某个类.结构体或枚举类型的实例而进行的准备过程.这个过程包含了为实例中的每个属性设置初始值和为其执行必要的准备和初始化任务. 构造过程是通过定义构造器(Initializers)来实现的,这些构造器可以看做是用来创建特定类型实例的特殊方法.与 Objective-C 中的构造器不同,Swift 的构造器无需返回值,它们的主要任务是保证新实例在第一次使用前完成正确的初始化. 类实例也可以通过定义析构器(deinitializer)在类实例释放之前执行特定的清除工作.想了解更多关于

OpenGL1.0 线段

OpenGL1.0线段 DionysosLai2014-06-16 本篇作为我学习Opengl第一篇文档.希望自己能在图形学路上走得远一点,达到能够渲染游戏画质目的,现阶段是Box2D对物理世界模拟很好,但自己无法做到材质渲染很好,致使许多效果差强人意. 谈到,画线,相信很多游戏引擎都很好的完美支持了,只需要给出起点和终点,就能够很好的帮你实现画线问题.我们今天来分析底层是如何实现的.(ps:知识是网上视频学到,这里只是起到一个学习记录作用,顺便分享出来,没有盗取他人成果意思).这里先做两点假设