lab 3 EIGRP Route Summarization

EIGRP Route Summarization: Manual

  • Summarization is configurable on a per-interface basis in any router within a network.
  • When summarization is configured on an interface, the router immediately creates a route pointing to null0.

    –Loop-prevention mechanism

  • When the last specific route of the summary goes away, the summary is deleted.
  • The minimum metric of the specific routes is used as the metric of the summary route.

Configuring Manual Route Summarization

(config-if)#ip summary-address eigrp as-number address mask [admin-distance]
  • Creates a summary address that this interface will generate

基本网络配置

R1#
interface Loopback0
 ip address 172.16.1.1 255.255.255.0

interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0

router eigrp 100
 network 10.1.1.1 0.0.0.0
 network 172.16.1.1 0.0.0.0
R2#
interface Loopback0
 ip address 172.16.2.1 255.255.255.0

interface FastEthernet0/0
 ip address 10.1.1.2 255.255.255.0

router eigrp 100
 network 10.1.1.2 0.0.0.0
 network 172.16.2.1 0.0.0.0
R3#
interface Loopback0
 ip address 172.16.3.1 255.255.255.0

interface FastEthernet0/0
 ip address 202.100.1.3 255.255.255.0

interface FastEthernet1/0
 ip address 10.1.1.3 255.255.255.0

router eigrp 100
 network 10.1.1.3 0.0.0.0
 network 172.16.3.1 0.0.0.0
 network 202.100.1.3 0.0.0.0
#R4#
interface FastEthernet0/0
 ip address 202.100.1.4 255.255.255.0

router eigrp 100
 network 202.100.1.4 0.0.0.0

Configuring Manual Route Summarization配置

R3#
interface FastEthernet0/0
 ip address 202.100.1.3 255.255.255.0
 

ip summary-address eigrp 100 172.16.0.0 255.255.0.0

验证

R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.1.0/24 is directly connected, FastEthernet1/0
L        10.1.1.3/32 is directly connected, FastEthernet1/0
      172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks

D 172.16.0.0/16 is a summary, 00:00:11, Null0

D        172.16.1.0/24 [90/156160] via 10.1.1.1, 00:08:59, FastEthernet1/0
D        172.16.2.0/24 [90/156160] via 10.1.1.2, 00:08:59, FastEthernet1/0
C        172.16.3.0/24 is directly connected, Loopback0
L        172.16.3.1/32 is directly connected, Loopback0
      202.100.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        202.100.1.0/24 is directly connected, FastEthernet0/0
L        202.100.1.3/32 is directly connected, FastEthernet0/0
R4#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 1 subnets
D        10.1.1.0 [90/30720] via 202.100.1.3, 00:09:41, FastEthernet0/0

D 172.16.0.0/16 [90/156160] via 202.100.1.3, 00:02:03, FastEthernet0/0

      202.100.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        202.100.1.0/24 is directly connected, FastEthernet0/0
L        202.100.1.4/32 is directly connected, FastEthernet0/0

来自为知笔记(Wiz)

原文地址:https://www.cnblogs.com/faerl/p/8253755.html

时间: 2024-08-04 22:06:20

lab 3 EIGRP Route Summarization的相关文章

CCNP - LAB BGP Route Reflectors and Route Filters

Topology Objectives Configure iBGP routers to use a route reflector and simple router filter. Background The International Travel Agency maintains a full-mesh iBGP network that has quickly scaled beyond 100 routers. The company wants to implement rou

Lab - IPv6 Challenge Lab

Topology Objectives Implement the topology diagram using the instructions in the Requirements section.Change the IPv6 IGP from OSPFv3 to RIPng. Background In the first part of this lab (Steps 1 through 7), you configure IPv4 with EIGRP on routers R1,

CCIE学习笔记之MPLS与MPLS VPN

配置: 接口下启用:mpls ip mpls label protocol ldp | tdp | both 配置LDP RID(全局):mpls ldp route-id interface [force] 如mpls ldp route-idloopback0 force 注:force强制命令立即生效,注意对方的LDP RID可达才能和对方建立LDP邻居关系 修改MPLS MTU(接口):mpls mtu [override] 1516       //因为加上4字节的标签,这条命令可以用

IP寻址技术简介

1969年仅有四节点的ARPA网在美国实验成功,有谁能想到由此演化的互联网会成为世界 最大的数据网呢.随着计算机的普及,上网人数的不断增加,越来越多的企业把目光投 向互联网.支撑Internet运转的关键是IP技术,在此详细讲解其基本概念及IP的寻址过 程. MAC地址(位于数据链路层) 介质访问控制(Media Access Control)地址一般位于网卡中,用于标识网络设备,控制 对网络介质的访问.例如,网络设备要访问传输电缆(网线,位于物理层),必须具备一 个MAC地址,发送的数据要到达

OSPF的高级应用之地址汇总与虚链路的配置

在大型网络中,要使路由器发挥最好的性能,需要做一些优化.而由于一些原因,造成了OSPF区域骨干区域没有和非骨干区域相连.骨干区域不连续等问题.如要更改区域所有路由器配置,工作量较大,这时可使用虚链路连接没有连接在一起的区域,还有助于提供逻辑冗余. OSPF路由协议地址汇总 前面已经介绍了IP子网划分的原理,而IP地址汇总就是将多个网段汇总成一个网段,和子网划分相反.如何将多个地址汇总成一个地址呢? 具体步骤如下: (1)确定需要汇总网段的地址 (2)将各网段的地址以二进制形式写出 (3)比较各网

MPLS VPN原理及配置思路

VPN中的角色: CE/PE/P overlay vpn:隧道建立在CE上 在ce和ce之间建立隧道,并直接传递路由信息.典型代表是GRE.IPSEC overlay vpn:隧道建立在pe上 在pe上为每一个vpn用户建立相应的GRE隧道,路由信息在pe和pe之间传递. 不同的vpn用户不能共享相同的地址空间,并且需要大量的ACL和策略路由,在实际中不具备可行性 overlay vpn的本质是一种静态vpn 1,所有的配置与部署都需要手工完成 2,由于是静态vpn,则无法反应网络的实时变化 p

OSPF高级配置

OSPF高级配置 n 路由重分发 路由重分发通常在那些负责从一个自治系统学习路由,然后向另一个自治系统广播的路由器上进行配置.例如:一台路由器既运行OSPF又运行RIP,如果OSPF进程被配置为通告由RIP学到的路由到OSPF自治系统中,那么这种做法就可以叫"重分发RIP". 一个单一的IP路由协议是管理网络中IP路由的首选方案.无论是从配置管理的角度还是容错管理的角度,每台路由器都被期望运行单种路由协议而不是多种路由协议.然而,显示网络的情况是存在多种路由协议的,并且这些网络要互相连

计算机网络常用英文缩写与专有名词总结

本文章是对<计算机网络自顶向下方法>原书第五版学习过程中遇到的常用英文缩写和专有名词的总结. Part one 常见缩写: ISPs:Internet Service Providers 网络服务提供者 RFC:Requests for comments 请求注解 DSL:Digital Subscribe line 数字用户线 ADSL:Asymmetrical Digital Subscribe loop 非对称数字用户线 FTTH:Fiber to the home 光纤到户 HFC:h

[实例]H&M SH office 2 IP地址段扩容

[实例]H&M SH office 2 IP地址段扩容 环境如图: SH office 2以前使用10.200.4.0网段,现需求扩大IP 地址段. 方法1:更改mask,但这个会影响到目前所有设备的更改及地址规划等问题 方法2: 添加一个新的IP地址段给sh office 2使用 现在我们就来实现方法2 1-构建MPLS网络 SH office 2与 SH office1 通过 MPLS 连接,R6有环回口6.6.6.6 R1-R4跑的是静态路由 <模拟现状> R6-R5 跑得是OS