poj 1703 Find them, Catch them(带权并查集和一种巧妙的方法)

Find them, Catch them

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 36176   Accepted: 11090

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.

In the same gang.

题意:是一个城市有两个帮派,A 1 2是询问1和2这两个人是不是一个帮派,D 1 2是这两个人不在一个帮派
	每一次A就输出一次
思路: 带权并查集,加一个数组re[]表示子节点和其父节点的关系,是一个门派就是0,不是就是1
2015,7,27
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
#define M 100100
int x[M],re[M];
void init()
{
	for(int i=0;i<M;i++){
		x[i]=i;
		re[i]=0;
	}
}
int find(int k)
{
	int temp=x[k];
	if(x[k]==k) return k;
	x[k]=find(x[k]);
	if(re[k]==re[temp])//如果和父节点是同类就存0
		re[k]=0;
	else re[k]=1;
	return x[k];
}
void merge(int a,int b,int fa,int fb)
{
	x[fa]=fb;
	if(re[a]==re[b]) re[fa]=1;
	else re[fb]=0;
}
int main()
{
	int t,n,m,i,a,b,fa,fb;
	char ch;
	scanf("%d",&t);
	while(t--){
		init();
		scanf("%d%d",&n,&m);
		while(m--){
			cin>>ch;
			scanf("%d%d",&a,&b);
			fa=find(a);
			fb=find(b);
			if(ch=='A'){
				if(fa!=fb){
					printf("Not sure yet.\n");
					continue;
				}
				if(re[a]==re[b]){
					printf("In the same gang.\n");
					continue;
				}
				else{
					printf("In different gangs.\n");
				}
			}
			else{
				if(fa!=fb)
					merge(a,b,fa,fb);
			}
		}
	}
	return 0;
}
/* 另一种巧妙方法:大神的解析,是poj食物链那道题的弱化。
可见所有元素个数为2 * N,如果i表示属于帮派A,那么i + N表示属于帮派B,
每次输入两个家伙不在同一帮派的时候,就合并他们分属两个帮派的元素。*/
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
#define M 200200
int x[M];
void init()
{
	for(int i=0;i<M;i++)
		x[i]=i;
}
int find(int k)
{
	if(x[k]==k) return k;
	x[k]=find(x[k]);//压缩路径
	return x[k];
}
void merge(int a,int b)
{
	int fa=find(a);
	int fb=find(b);
	if(x[a]!=x[b]) x[fa]=fb;
}
bool same(int a,int b)
{
	return find(a)==find(b);
}
int main()
{
	int t,n,m,i,a,b,fa,fb;
	char ch;
	scanf("%d",&t);
	while(t--){
		init();
		scanf("%d%d",&n,&m);
		while(m--){
			cin>>ch;
			scanf("%d%d",&a,&b);
			if(ch=='A'){
				if(same(a,b)){
					printf("In the same gang.\n");
					continue;
				}
				if(same(a,b+n)){
					printf("In different gangs.\n");
				}
				else{
					printf("Not sure yet.\n");
					continue;
				}
			}
			else{
				merge(a,b+n);//a和b一定不在一个门派,就把a和b+n合并
				merge(a+n,b);//同理
			}
		}
	}
	return 0;
} 

时间: 2024-11-14 12:04:41

poj 1703 Find them, Catch them(带权并查集和一种巧妙的方法)的相关文章

poj 1703 Find them, Catch them(种类并查集和一种巧妙的方法)

Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 36176   Accepted: 11090 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Drago

POJ 1984 Navigation Nightmare 二维带权并查集

题目来源:POJ 1984 Navigation Nightmare 题意:给你一颗树 k次询问 求2点之间的曼哈顿距离 并且要在只有开始k条边的情况下 思路:按照方向 我是以左上角为根 左上角为原点 dx[i]为i点距离根的x坐标 dy[]是y坐标 这两个可以通过路径压缩求出 只不过是二维而已 #include <cstdio> #include <cstdlib> #include <cstring> using namespace std; const int m

POJ 2492 A Bug&#39;s Life (带权并查集 &amp;&amp; 向量偏移)

题意 : 给你 n 只虫且性别只有公母, 接下来给出 m 个关系, 这 m 个关系中都是代表这两只虫能够交配, 就是默认异性, 问你在给出的关系中有没有与异性交配这一事实相反的, 即同性之间给出了交配关系. 分析 : 本题雷同POJ 1182 食物链, 如果会了那一题, 那现在这题便简单多了, 建议先了解食物链的偏移向量做法.这里也是使用向量的思考方式来进行relation的变化, 这里我令 relation = 0为同性, relation = 1为异性, 接下来的步骤就和食物链的雷同了. 优

POJ 1703 Find them, Catch them(数据结构-并查集)

Find them, Catch them Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal b

【POJ 1984】Navigation Nightmare(带权并查集)

Navigation Nightmare Description Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 100

POJ 1984 Navigation Nightmare 【经典带权并查集】

任意门:http://poj.org/problem?id=1984 Navigation Nightmare Time Limit: 2000MS   Memory Limit: 30000K Total Submissions: 7783   Accepted: 2801 Case Time Limit: 1000MS Description Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usuall

POJ 1703 Find them, Catch them (数据结构-并查集)

Find them, Catch them Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 31102   Accepted: 9583 Description The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon

POJ 1703 - Find them, Catch them(加权并查集) 题解

此文为博主原创题解,转载时请通知博主,并把原文链接放在正文醒目位置. 题目链接:http://poj.org/problem?id=1703 题目大意: N个人分属两个黑帮.给出M条信息.(M,N <= 10^5) D x y表示已知x和y不在同一个黑帮中. A x y表示询问x和y是否在一个黑帮中.如果是,输出In different gangs. 如果不是,输出In the same gang.如果未知,输出Not sure yet. 输入一个数字t表示数据组数(1 <= T <=

POJ - 3728:The merchant (Tarjan 带权并查集)

题意:给定一个N个节点的树,1<=N<=50000 每个节点都有一个权值,代表商品在这个节点的价格.商人从某个节点a移动到节点b,且只能购买并出售一次商品,问最多可以产生多大的利润. 思路:路径压缩,得到每个点到当前根的信息,然后更新即可. 有可以用倍增做. 很久前抄的代码. #include<cstdio> #define min(a,b) (a<b?a:b) #define max(a,b) (a>b?a:b) #define swap(a,b) (a^=b,b^=