1065 A+B and C (64bit) (20 分)大数 溢出

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [?2?63??,2?63??], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false思路:  a、b、c都是long long 范围内的,但是它们相加之后可能会超过范围。
#include<iostream>
#include<vector>
#include<algorithm>
#include<map>
#include<set>
#include<cmath>
#include<climits>
using namespace std;

int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        long long a,b,c,x;
        cin>>a>>b>>c;
        x=a+b;
        if(a<0&&b<0&&x>=0)
            printf("Case #%d: false\n",i+1);
        else if(a>0&&b>0&&x<0)
            printf("Case #%d: true\n",i+1);
        else if(x>c)
            printf("Case #%d: true\n",i+1);
        else
            printf("Case #%d: false\n",i+1);
    }
    return 0;
}
 

原文地址:https://www.cnblogs.com/zhanghaijie/p/10335415.html

时间: 2024-10-08 08:00:16

1065 A+B and C (64bit) (20 分)大数 溢出的相关文章

1065 A+B and C (64bit) (20分)(水)

Given three integers A, B and C in [−], you are supposed to tell whether A+B>C. Input Specification: The first line of the input gives the positive number of test cases, T (≤). Then T test cases follow, each consists of a single line containing three

PAT Advanced 1065 A+B and C (64bit) (20分)

Given three integers A, B and C in [−], you are supposed to tell whether A+B>C. Input Specification: The first line of the input gives the positive number of test cases, T (≤). Then T test cases follow, each consists of a single line containing three

PAT 1065 A+B and C (64bit) (20)

1065. A+B and C (64bit) (20) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 HOU, Qiming Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C. Input Specification: The first line of the input gives the po

1065. A+B and C (64bit) (20)

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C. Input Specification: The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line co

PAT (Advanced Level) 1065. A+B and C (64bit) (20)

因为会溢出,因此判断条件需要转化.变成b>c-a #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<queue> #include<algorithm> using namespace std; long long a,b,c; int main() { int T; scanf("%d",&T);

PAT甲题题解-1065. A+B and C (64bit) (20)-大数溢出

第一眼以为是大数据,想套个大数据模板,后来发现不需要.因为A.B.C的大小为[-2^63, 2^63],用long long 存储他们的值和sum. 接下来就是分类讨论:如果A > 0, B < 0 或者 A < 0, B > 0,sum不会溢出,直接和C判断比较即可.如果A > 0, B > 0,sum可能会溢出, 溢出的话为负数,所以sum < 0时候说明溢出了,那么肯定是大于C的.如果A < 0, B < 0,sum可能会溢出,同理,sum &g

PAT:1065. A+B and C (64bit) (20) AC

#include<stdio.h> #include<stdlib.h> int main() { int n; scanf("%d",&n); for(int i=1 ; i<=n ; ++i) { long long a,b,c; scanf("%lld%lld%lld",&a,&b,&c); long long sum=a+b; //[思维]:判断sum是否正负溢出,溢出的话不能直接按计算判断! i

1065 A+B and C (64bit) (20)(大数相加、正溢出、负溢出)

正溢出:两个正数相加超过了该数据类型能表示的最大范围,结果为负数 负溢出:两个负数相加超过了该数据类型能表示的最小范围,结果为正数包括零 #include <algorithm> #include <iostream> #include <cstdio> #include <queue> #include <cstring> #include <vector> using namespace std; const int maxn =

PAT 1065. A+B and C (64bit)

1 #include <stdio.h> 2 3 int main() { 4 long n, a, b, c; 5 long i; 6 int ga, gb, gc, r; 7 scanf("%ld", &n); 8 for (i=0; i<n; i++) { 9 scanf("%ld%ld%ld", &a, &b, &c); 10 ga = a >= 0; 11 gb = b >= 0; 12 gc