Pat(Advanced Level)Practice--1016(Phone Bills)

Pat1016代码

题目描述:

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone.
Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record
are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour
clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers‘ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning
and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

AC代码:map的简单应用

#include<cstdio>
#include<iostream>
#include<string>
#include<map>
#include<vector>
#include<algorithm>

using namespace std;

typedef struct Calls
{
	int month;
	int day;
	int hour;
	int minute;
	string word;
}Calls;

bool cmp(const Calls &l,const Calls &r)
{
	if(l.day<r.day)
		return true;
	else if(l.day==r.day&&l.hour<r.hour)
		return true;
	else if(l.day==r.day&&l.hour==r.hour&&l.minute<r.minute)
		return true;
	else
		return false;
}

map<string,vector<Calls> > m;//存储名字对应的通话记录
int Rate[24];

float ComputeFee(Calls l,Calls r,int *totaltime)//计算通话费用
{
	float fee=0;
	*totaltime=0;
	while(l.day<r.day||l.hour<r.hour||l.minute<r.minute)
	{
		fee+=Rate[l.hour];
		(*totaltime)++;
		l.minute++;
		if(l.minute==60)
		{
			l.minute=0;
			l.hour++;
			if(l.hour==24)
			{
				l.hour=0;
				l.day++;
			}
		}
	}
	return fee;
}

int main(int argc,char *argv[])
{
	int i,j;
	int n;
	for(i=0;i<24;i++)
		cin>>Rate[i];
	cin>>n;
	for(i=0;i<n;i++)
	{
		string name;
		Calls temp;
		cin>>name;
		scanf("%d:%d:%d:%d",&temp.month,&temp.day,&temp.hour,&temp.minute);
		cin>>temp.word;
		m[name].push_back(temp);
	}
	map<string,vector<Calls> >::iterator it;
	vector<Calls>::iterator p;
	for(it=m.begin();it!=m.end();it++)
	{
		sort((it->second).begin(),(it->second).end(),cmp);
	}
	for(it=m.begin();it!=m.end();it++)
	{
		int FindPair=false;
		int totaltime=0;
		float total=0;
		for(p=(it->second).begin();p!=(it->second).end();p++)
		{                     //扫描通话记录,查看是否有符合条件的一对记录
			Calls temp=*p;
			if(temp.word[1]==‘n‘)
			{
				if((p+1)!=(it->second).end())
				{
					Calls next=*(p+1);
					if(next.word[1]==‘f‘)
					{
						if(!FindPair)
						{
							cout<<it->first;
							printf(" %02d\n",p->month);
							FindPair=true;
						}
		            printf("%02d:%02d:%02d %02d:%02d:%02d",temp.day,
					temp.hour,temp.minute,next.day,next.hour,next.minute);
                    float fee=ComputeFee(temp,next,&totaltime);
					printf(" %d $%.2f\n",totaltime,fee/100);
					total+=fee;
					}
				}
			}
		}
		if(FindPair)
	    	printf("Total amount: $%.2f\n",total/100);
	}

	return 0;
}

Pat(Advanced Level)Practice--1016(Phone Bills)

时间: 2024-10-20 23:37:58

Pat(Advanced Level)Practice--1016(Phone Bills)的相关文章

1002 A+B for Polynomials (PAT (Advanced Level) Practice)

This time, you are supposed to find A+B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N?1?? a?N?1???? N?2?? a?N?2?

PAT (Advanced Level) Practice 1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their

PAT (Advanced Level) Practice 1068 Find More Coins

题解 01背包板子 + 记录路径.这次的记录路径比较特殊,要从多组解中找到一组由尽量小价值的硬币组成的解.所以不能利用一维数组记录路径,path[目前重量] = 物品序号,因为这样最后只能记录一个可能符合或不符合要求解.所以应该利用二维数组记录路径,path[ 物品序号 ][ 目前重量 ] = 1,这样可以记录多组解.因为要求为找到最小的一组解,所以先将拥有的硬币从大到小排序,以便于进行01背包时,可以从大到小更新解. 代码 #include<bits/stdc++.h> using name

Pat(Advanced Level)Practice--1043(Is It a Binary Search Tree)

Pat1043代码 题目描述: A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes

Pat(Advanced Level)Practice--1044(Shopping in Mars)

Pat1044代码 题目描述: Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diam

PAT (Advanced Level) 1093. Count PAT&#39;s (25)

预处理每个位置之前有多少个P,每个位置之后有多少个T. 对于每个A,贡献的答案是这个A之前的P个数*这个A之后T个数. #include<cstdio> #include<cstring> long long MOD=1e9+7; const int maxn=1e5+10; long long dp1[maxn],dp2[maxn]; char s[maxn]; int main() { scanf("%s",s); memset(dp1,0,sizeof d

PAT (Advanced Level) 1055. The World&#39;s Richest (25)

排序.随便加点优化就能过. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> #include<map> #include<queue> #include<string> #include<stack> #include<vector> using names

Pat(Advanced Level)Practice--1018(Public Bike Management)

Pat1018代码 题目描述: There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city. The Public Bike Management C

Pat(Advanced Level)Practice--1076(Forwards on Weibo)

Pat1076代码 题目描述: Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all hi