find the most comfortable road
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4022 Accepted Submission(s): 1732
Problem Description
XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam
Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对
Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服
,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),
但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。
Input
输入包括多个测试实例,每个实例包括:
第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。
接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000
然后是一个正整数Q(Q<11),表示寻路的个数。
接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。
Output
每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。
Sample Input
4 4
1 2 2
2 3 4
1 4 1
3 4 2
2
1 3
1 2
Sample Output
1
0
分析:先按照速度从小到大排序,然后从当前i开始到n建立并查集,直到初始和目的形成连接,然后与ans比较
代码:
[cpp] view plaincopy
- /*hdoj 1598*/
- #include <stdio.h>
- #include <string.h>
- #include <algorithm>
- #define M 1005
- #define INF 0x3f3f3f3f
- using namespace std;
- struct node{
- int from, to, sp;
- }s[M];
- int fat[M], n, m;
- int f(int x){
- if(fat[x] != x) fat[x] = f(fat[x]);
- return fat[x];
- }
- int cmp(node a, node b){
- return a.sp<b.sp;
- }
- int main(){
- int i, a, b, c, j, q;
- while(scanf("%d%d", &n, &m) == 2){
- for(i = 0; i < m; i ++)
- scanf("%d%d%d", &s[i].from, &s[i].to, &s[i].sp);
- sort(s, s+m, cmp);
- scanf("%d", &q);
- while(q --){
- int ans = INF;
- scanf("%d%d", &a, &b);
- for(i = 0; i < m; i ++){
- for(j = 1; j <= n; j ++) fat[j] = j;
- for(j = i; j < m; j ++){
- int x = f(s[j].from);
- int y = f(s[j].to);
- if(x!=y) fat[x] = y;
- if(f(a) == f(b)){
- ans = min(ans, s[j].sp-s[i].sp); break;
- }
- }
- }
- if(ans == INF) printf("-1\n");
- else printf("%d\n", ans);
- }
- }
- return 0;
- }