poj3083 Children of the Candy Corn BFS&&DFS

Children of the Candy Corn

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11215   Accepted: 4841

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will
eventually find the exit. Simply choose either the right or left wall,
and follow it. Of course, there‘s no guarantee which strategy (left or
right) will be better, and the path taken is seldom the most efficient.
(It also doesn‘t work on mazes with exits that are not on the edge;
those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a
maze, you‘d like to have a computer program that can determine the left
and right-hand paths along with the shortest path so that you can
figure out which layout has the best chance of confounding visitors.

Input

Input
to this problem will begin with a line containing a single integer n
indicating the number of mazes. Each maze will consist of one line with a
width, w, and height, h (3 <= w, h <= 40), followed by h lines of
w characters each that represent the maze layout. Walls are represented
by hash marks (‘#‘), empty space by periods (‘.‘), the start by an ‘S‘
and the exit by an ‘E‘.

Exactly one ‘S‘ and one ‘E‘ will be present in the maze, and they
will always be located along one of the maze edges and never in a
corner. The maze will be fully enclosed by walls (‘#‘), with the only
openings being the ‘S‘ and ‘E‘. The ‘S‘ and ‘E‘ will also be separated
by at least one wall (‘#‘).

You may assume that the maze exit is always reachable from the start point.

Output

For
each maze in the input, output on a single line the number of (not
necessarily unique) squares that a person would visit (including the ‘S‘
and ‘E‘) for (in order) the left, right, and shortest paths, separated
by a single space each. Movement from one square to another is only
allowed in the horizontal or vertical direction; movement along the
diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9

Source

题目大意:从入口S进到出口E,如果一直按照走左边的路(碰到墙后返回来继续),或一直选择向右走,各自需要多少步;和求最短路(简单BFS)

这道题虽说是一道题,却同时考察了DFS和BFS

当然,这道题的困难之处不在于DFS有多复杂,而在于如何一直向左走或向右走却不受位置的影响,解决办法是设置两个数组顺时针与逆时针,方法如下:

设左上右下为 0, 1, 2, 3
顺时针时,假设当前的前进方向为d, 那么从(d+2)%4,也就是相反方向开始循环,每次
(d+1)%4,遇到第一个能走的就前进。
逆时针时同理,不同的是每次(d-1+4)%4。下面附上本人比较挫代码
#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=100;
char str[maxn][maxn];
bool vis[maxn][maxn];
int stepl=0,stepr=0,stepm=0;
int n,m;
 int sx,sy,sd;
int dirl[4][2]={-1,0,0,1,1,0,0,-1};
int dirr[4][2]={1,0,0,1,-1,0,0,-1};
struct node{
  int x,y,dis;
};
node u,v;
int step;
int dfs(int x,int y,int dir,int a[][2]){
    if(str[x][y]==‘E‘)
        return 1;//特别注意,返回1
    for(int i=0;i<4;i++){
       int  tdir=(dir+i+3)%4;//tdir需要重新定义
        int tx=x+a[tdir][0];
        int ty=y+a[tdir][1];
        if(tx>=0&&tx<n&&ty>=0&&ty<m&&str[tx][ty]!=‘#‘&&!vis[tx][ty]){
              step =dfs(tx,ty,tdir,a)+1;//+1
                break;
        }
    }
    return step;
}

int  bfs(){
    memset(vis,false,sizeof(vis));
    u.x=sx,u.y=sy,u.dis=1;
    vis[sx][sy]=true;
    queue<node>q;
    q.push(u);
    while(!q.empty()){
        u=q.front();
        q.pop();
        if(str[u.x][u.y]==‘E‘)
            return u.dis;
        for(int i=0;i<4;i++){
            v.x=u.x+dirl[i][0];
            v.y=u.y+dirl[i][1];
            if(v.x>=0&&v.x<n&&v.y>=0&&v.y<m&&
               !vis[v.x][v.y]&&str[v.x][v.y]!=‘#‘){
                vis[v.x][v.y]=true;
                v.dis=u.dis+1;
                q.push(v);
               }
        }
    }
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){

        memset(str,0,sizeof(str));
        memset(vis,false,sizeof(vis));
        scanf("%d%d",&m,&n);
        for(int i=0;i<n;i++){
                scanf("%s",str[i]);
            for(int j=0;j<m;j++){
                if(str[i][j]==‘S‘)
                    sx=i,sy=j;
            }
        }
        int tx,ty;

        for(int i=0;i<4;i++){//判断左走方向
            tx=sx+dirl[i][0];
            ty=sy+dirl[i][1];
            if(str[tx][ty]==‘.‘){
                sd=i;
                break;
                }
        }
        step=0;//每次向左或向右需要重新赋值为9
        stepl=dfs(sx,sy,sd,dirl);//对于左走进行dfs

           for(int i=0;i<4;i++){//判断左走方向
            tx=sx+dirr[i][0];
            ty=sy+dirr[i][1];
            if(str[tx][ty]==‘.‘){
                sd=i;
                break;
                }
        }
        step=0;
        stepr=dfs(sx,sy,sd,dirr);//对于左走进行dfs

        stepm=bfs();//最短路进行bfs
        printf("%d %d %d\n",stepl,stepr,stepm);
    }
    return 0;
}
时间: 2024-10-26 16:27:22

poj3083 Children of the Candy Corn BFS&&DFS的相关文章

poj 3083 Children of the Candy Corn(bfs+dfs)

Children of the Candy Corn Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10739   Accepted: 4626 Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombie

POJ 3083:Children of the Candy Corn(DFS+BFS)

Children of the Candy Corn Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 9311 Accepted: 4039 Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, ch

POJ 3083 -- Children of the Candy Corn(DFS+BFS)TLE

POJ 3083 -- Children of the Candy Corn(DFS+BFS) 题意: 给定一个迷宫,S是起点,E是终点,#是墙不可走,.可以走 1)先输出左转优先时,从S到E的步数 2)再输出右转优先时,从S到E的步数 3)最后输出S到E的最短步数 解题思路: 前两问DFS,转向只要控制一下旋转方向就可以 首先设置前进方向对应的数字 向上--N--0 向右--E--1 向下--S--2 向左--W--3 比如说右转优先,即为向右,向前,向左,向后,即逆时针方向for(int i

POJ3083——Children of the Candy Corn

Children of the Candy Corn DescriptionThe cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find t

POJ-3083 Children of the Candy Corn (BFS+DFS)

Description The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit. One popular maze-

dfs/poj3083 Children of the Candy Corn

1 #include<cstdio> 2 #include<cstring> 3 #include<queue> 4 5 using namespace std; 6 typedef pair<int,int>P; 7 const int dx[4]={1,0,-1,0}; 8 const int dy[4]={0,1,0,-1}; 9 const int INF=1e9; 10 int sx,sy,ex,ey,n,m; 11 char a[50][50];

POJ 3083 Children of the Candy Corn (DFS+BFS)

题目链接:http://poj.org/problem?id=3083 题目大意:给你一个迷宫,S是起点,E是终点,#是墙,.是路,S.E在迷宫的边界,并且有唯一解:求优先左转S到E的步数,优先右转S到E的步数,以及S到E的最短步数. 题解: 1.本题的难点在于左转优先以及右转优先,下一步的方向取决于当前位置的方向,用DFS不断的按优先方向遍历一遍迷宫即可:我定义如图:   前(0)   左(1) 当前位置方向(dir) 右(3)   后(2)   以左转优先为例,便利迷宫的方向依次为:左.前.

poj3083 Children of the Candy Corn

这道题有深搜和广搜.深搜还有要求,靠左或靠右.下面以靠左为例,可以把简单分为上北,下南,左西,右东四个方向.向东就是横坐标i不变,纵坐标j加1(i与j其实就是下标).其他方向也可以这样确定.通过上一步方向可以确定下一步应该从哪个方向开始搜.比如说,是向北走的,就必须先搜西,西不可以走,再搜北,如果北还不可以走,再搜东,最后才是南.其他方向的情况也可以这样推出来.最后走到E点完成了.广搜就是最基础的广搜.这道题做了将近10个小时.中途曾几次准备放弃,但最后还是坚持做完了. #include<ios

POJ 3083 Children of the Candy Corn(顺时针DFS+逆时针DFS+BFS)

题目链接:POJ 3083 Children of the Candy Corn [题意]给出一个迷宫,不超过40*40,'#'代表墙,'.'代表能走,'S'是起点,'E'是终点.分别求出从起点一直沿左走,一直沿右走,走到终点所需要的步数.以及走出迷宫的最小步数. [思路]首先最小步数很简单,一个普通BFS搞定,这道题重点是一直向左走和一直向右走的DFS的方向问题,方向还和游客当时朝向有关.开始一直认为是每次都向左(右)转,直到可以走,然后就一直不对,在google了之后才知道向左走要遵循左上右