UVA 401-Palindromes(模拟)

Palindromes

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld
& %llu

Submit Status

Description

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right
as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is
a mirrored string because "A" and "I"are their own reverses, and "3" and "E" are each others‘ reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string"ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the
original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string.

Of course,"A","T", "O",
and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

Character Reverse Character Reverse Character Reverse
A A M M Y Y
B   N   Z 5
C   O O 1 1
D   P   2 S
E 3 Q   3 E
F   R   4  
G   S 2 5 Z
H H T T 6  
I I U U 7  
J L V V 8 8
K   W W 9  
L J X X    

Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRING CRITERIA
" -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
" -- is a mirrored string." if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string

Note that the output line is to include the -‘s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA

Sample Output

NOTAPALINDROME -- is not a palindrome.

ISAPALINILAPASI -- is a regular palindrome.

2A3MEAS -- is a mirrored string.

ATOYOTA -- is a mirrored palindrome.

Hint

use the C++‘s class of string will be convenient, but not a must

此题涉及到两种串,一种是回文串,一种是镜像串,回文串是从前向后和从后向前都是一样的,镜像串是经过上图的代换后能像回文串的串。一共有四种情况:(1)是回文串也是镜像串(2)是回文串不是镜像串(3)是镜像串不是回文串(4)不是镜像串也不是回文串。给你一个串让你判断是哪种情况。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
char a[]="ABCDEFGHIJKLMNOPQRSTUVWXYZ123456789";
char b[]="A   3  HIL JM O   2TUVWXY51SE Z  8 ";
char str[1010];
int is_p(char str[])
{
    int i;
    int len=strlen(str);
    for(i=0; i<(len/2); i++)
    {
        if(str[i]!=str[len-i-1])
            return 0;
    }
    return 1;
}
int is_m(char str[])
{
    int i,j;
    int len=strlen(str);
    if(len==1)
    {
        for(i=0; i<35; i++)
        {
            if(str[0]==a[i])
                break;
        }
        if(i==35||str[0]!=b[i])
            return 0;
        else
            return 1;
    }
    else if(len>1)
    {
        for(i=0; i<(len/2+1); i++)
        {
            for(j=0; j<35; j++)
            {
                if(str[i]==a[j])
                    break;
            }
            if(j==35||str[len-i-1]!=b[j])
                return 0;
        }
        return 1;
    }
}
int main()
{
    int flag1,flag2;
    while(~scanf("%s",str))
    {
        flag1=is_p(str);
        flag2=is_m(str);
        //printf("%d %d<<<<<<<",flag1,flag2);
        if(flag1&&flag2)
        {
            printf("%s -- is a mirrored palindrome.\n\n",str);
        }
        else if(flag1&&!flag2)
        {
            printf("%s -- is a regular palindrome.\n\n",str);
        }
        else if(flag2&&!flag1)
        {
            printf("%s -- is a mirrored string.\n\n",str);
        }
        else if(!flag2&&!flag1)
        {
            printf("%s -- is not a palindrome.\n\n",str);
        }
    }
    return 0;
}
时间: 2024-08-01 06:28:32

UVA 401-Palindromes(模拟)的相关文章

UVa 401 Palindromes(字符串,回文)

 Palindromes  A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string i

UVa 401 Palindromes(简单字符串)

简单的判断是否是回文串.镜像串,然后自己写的真费劲,没逃掉刘汝佳的书,这里的代码很有技巧性,特别值得学习,额,其实他书上的代码都很精简 Character Reverse Character Reverse Character Reverse A A M M Y Y B   N   Z 5 C   O O 1 1 D   P   2 S E 3 Q   3 E F   R   4   G   S 2 5 Z H H T T 6   I I U U 7   J L V V 8 8 K   W W

UVA 401 Palindromes(回文词)

 回文词 Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Practice UVA 401 Appoint description:  acmparand  (2013-07-07)Luke  (2014-01-20) System Crawler  (2015-05-10) Description A regular palindrome is a string of

uva 401.Palindromes

题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=342 题目意思:给出一段字符串(大写字母+数字组成).判断是否为回文串 or 镜像串 or 回文镜像串 or 什么都不是.每个字母的镜像表格如下 Character Reverse Character Reverse Character Reverse A A M M Y Y B

UVa 401 Palindromes(镜像回文字符串)

 题意  给一个字符串 判定其是否为回文串和镜像串  回文串很好判断  镜像串对于每一个字符用数组保存它的镜像字符就行了  没有的就是空格 注意若字符串长度为奇数  中间那个字母必须是对称的才是镜像串 #include<cstdio> #include<cctype> #include<cstring> const int N = 35; int l; char s[N], mc[] = "A 3 HIL JM O 2TUVWXY5", mn[]

uvaoj 401 Palindromes

************************************************题目描述*************************************************** UVA - 401 Palindromes Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu Submit Status Description A regular palindrome is

UVA 之401 - Palindromes

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from ri

UVA 712(二叉树模拟)

L - S-Trees Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Appoint description:  System Crawler  (2014-04-01) Description  S-Trees  A Strange Tree (S-tree) over the variable set  is a binary tree representing a B

回文词(Palindromes, UVa 401)

输入一个字符串,判断它是否为回文串以及镜像串.输入字符串保证不含数字0.所谓回文串,就是反转以后与原串相同,如abba和madam.所谓镜像串,就是左右镜像之后和原串相同,如2S和3AIAE.注意,并不是每个字符在镜像之后都能得到一个合法字符.(空白项表示该字符镜像后不能得到一个合法字符.) Character Reverse Character Reverse Character Reverse A A M M Y Y B N Z 5 C O O 1 1 D P 2 S E 3 Q 3 E F

Palindromes UVA - 401

题意参见紫书 #include<bits/stdc++.h> using namespace std; #define me(s) memset(s,0,sizeof(s)) #define _for(i,a,b) for(int i=(a);i<(b);++i) #define _rep(i,a,b) for(int i=(a);i<=(b);++i) #define mp make_pair #define pb push_back #define all(x) (x).beg