hdoj 5112 A Curious Matt

A Curious Matt

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1338    Accepted Submission(s):
735

Problem Description

There is a curious man called Matt.

One day,
Matt‘s best friend Ted is wandering on the non-negative half of the number line.
Matt finds it interesting to know the maximal speed Ted may reach. In order to
do so, Matt takes records of Ted’s position. Now Matt has a great deal of
records. Please help him to find out the maximal speed Ted may reach, assuming
Ted moves with a constant speed between two consecutive records.

Input

The first line contains only one integer T, which
indicates the number of test cases.

For each test case, the first line
contains an integer N (2 ≤ N ≤ 10000),indicating the number of
records.

Each of the following N lines contains two integers
ti and xi (0 ≤ ti, xi
106), indicating the time when this record is taken and Ted’s
corresponding position. Note that records may be unsorted by time. It’s
guaranteed that all ti would be distinct.

Output

For each test case, output a single line “Case #x: y”,
where x is the case number (starting from 1), and y is the maximal speed Ted may
reach. The result should be rounded to two decimal places.

Sample Input

2

3

2 2

1 1

3 4

3

0 3

1 5

2 0

Sample Output

Case #1: 2.00

Case #2: 5.00

Hint

In the ?rst sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal.
In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.

时间长不编题真的不行了  一道水题花好长时间..........................

题意:给你一个人 在一些时刻的位置,让你求出这个人所能达到的最大速度。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#define MAX 10100
#define DD double
using namespace std;
struct node
{
	int time,pos;
}s[MAX];
bool cmp(node a,node b)
{
	return a.time<b.time;
}
int main()
{
	int t,n,m,i,j,k;
	scanf("%d",&t);
	k=0;
	while(t--)
	{
		scanf("%d",&n);
		DD sum=0,ans=0;
		for(i=0;i<n;i++)
		    scanf("%d%d",&s[i].time,&s[i].pos);
		sort(s,s+n,cmp);
		for(i=0;i<n-1;i++)
		{
		    DD sum=(s[i+1].pos-s[i].pos)*1.0/(s[i+1].time-s[i].time);
			ans=max(fabs(sum),ans);
		}
		printf("Case #%d: %.2lf\n",++k,ans);
	}
	return 0;
}

  

时间: 2024-08-25 22:02:01

hdoj 5112 A Curious Matt的相关文章

HDOJ 5112 A Curious Matt 水题

A Curious Matt Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 64    Accepted Submission(s): 49 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wand

HDU 5112 A Curious Matt (2014ACM/ICPC亚洲区北京站-重现赛)

A Curious Matt Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)Total Submission(s): 3058    Accepted Submission(s): 1716 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is w

水题:HDU 5112 A Curious Matt

Description There is a curious man called Matt. One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’

hdu 5112 A Curious Matt (水题)

Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records

hdu 5112 A Curious Matt

http://acm.hdu.edu.cn/showproblem.php?pid=5112 1 #include <cstdio> 2 #include <cstring> 3 #include <algorithm> 4 using namespace std; 5 6 int t; 7 int n; 8 struct node 9 { 10 int t,x; 11 bool operator<(const node &a)const 12 { 13

HDU5112 A Curious Matt

A Curious Matt Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 25    Accepted Submission(s): 25 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wand

A Curious Matt(2014ACM/ICPC亚洲区北京站)

A Curious Matt Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 0    Accepted Submission(s): 0 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wander

A Curious Matt(2014ACM/ICPC亚洲区北京站-A)

A Curious Matt Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 0    Accepted Submission(s): 0 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wander

2014ACM/ICPC亚洲区北京站-A Curious Matt

A Curious Matt Time Limit: 2000/2000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 0 Accepted Submission(s): 0 Problem Description There is a curious man called Matt. One day, Matt's best friend Ted is wandering on