hihocoder 在线测试(Google)

题目1 : 补提交卡

时间限制:2000ms

单点时限:1000ms

内存限制:256MB

描述

小Ho给自己定了一个宏伟的目标:连续100天每天坚持在hihoCoder上提交一个程序。100天过去 了,小Ho查看自己的提交记录发现有N天因为贪玩忘记提交了。于是小Ho软磨硬泡、强忍着小Hi鄙视的眼神从小Hi那里要来M张"补提交卡"。每张"补提 交卡"都可以补回一天的提交,将原本没有提交程序的一天变成有提交程序的一天。小Ho想知道通过利用这M张补提交卡,可以使自己的"最长连续提交天数"最 多变成多少天。

输入

第一行是一个整数T(1 <= T <= 10),代表测试数据的组数。

每 个测试数据第一行是2个整数N和M(0 <= N, M <= 100)。第二行包含N个整数a1, a2, ... aN(1 <= a1 < a2 < ... < aN <= 100),表示第a1, a2, ...  aN天小Ho没有提交程序。

输出

对于每组数据,输出通过使用补提交卡小Ho的最长连续提交天数最多变成多少。

样例输入
3
5 1
34 77 82 83 84
5 2
10 30 55 56 90
5 10
10 30 55 56 90
样例输出
76
59
100
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;

int a[101];

int main()
{
    int t;
    int n, m;
    int max;
    int i, j;

    scanf("%d", &t);
    while(t--)
    {
        scanf("%d %d", &n, &m);
        if(n<=m)
        {
            for(i=0; i<n; i++)
            {
               scanf("%d", &a[i]);
            }
           printf("100\n");
           continue;
        }

        for(i=1; i<=n; i++ )
        {
           scanf("%d", &a[i] );
        }
        a[0]=0;

        int cnt;
        max=0;

        for(j=m+1; j<=n; j++ )
        {
            cnt = a[j]-a[j-m-1]-1 ;
            if(cnt > max )
            max = cnt ;
        }
        printf("%d\n", max );
    }
    return 0;
}

时间: 2024-10-11 06:10:03

hihocoder 在线测试(Google)的相关文章

Redis内存存储结构分析

五竹,20110418 Redis: A persistent key-value database with built-in net interface written in ANSI-C for Posix systems 1 Redis 内存存储结构 本文是基于 Redis-v2.2.4 版本进行分析. 1.1 Redis 内存存储总体结构 Redis 是支持多key-value数据库(表)的,并用 RedisDb 来表示一个key-value数据库(表). redisServer 中有

Google Code Jam在线测试题目--Alien Language

Problem After years of study, scientists at Google Labs have discovered an alien language transmitted from a faraway planet. The alien language is very unique in that every word consists of exactly L lowercase letters. Also, there are exactly D words

hihoCoder #1053 : 居民迁移(贪心,二分搜索,google在线技术笔试模拟)

#1053 : 居民迁移 时间限制:3000ms 单点时限:1000ms 内存限制:256MB 描述 公元2411年,人类开始在地球以外的行星建立居住点.在第1326号殖民星上,N个居住点分布在一条直线上.为了方便描述,我们设第i个居住点的位置是Xi,其中居住着Yi位居民.随着冬季的到来,一些人口较多的居住点的生态循环系统已经开始超负荷运转.为了顺利度过严冬,殖民星上的居民一致同意通过转移到人口较少的居住点来减轻人口众多的居住点的负荷. 遗憾的是,1326殖民星的环境非常恶劣.在冬季到来前,每个

google在线测试练习2

Problem Given a list of space separated words, reverse the order of the words. Each line of text contains L letters and W words. A line will only consist of letters and space characters. There will be exactly one space character between each pair of

google在线测试练习题1

Problem You receive a credit C at a local store and would like to buy two items. You first walk through the store and create a list L of all available items. From this list you would like to buy two items that add up to the entire value of the credit

google在线测试练习题3

Problem The Latin alphabet contains 26 characters and telephones only have ten digits on the keypad. We would like to make it easier to write a message to your friend using a sequence of keypresses to indicate the desired characters. The letters are

google在线测试练习题2

Problem Given a list of space separated words, reverse the order of the words. Each line of text contains L letters and W words. A line will only consist of letters and space characters. There will be exactly one space character between each pair of

为Google每年带来100亿美元增长的A/B测试是什么?

最近,前Facebook工程师覃超一篇关于2010年到2015年Facebook改版网站首页历程的文章受到极大关注.按照他的记录,2012年,当时的Facebook产品副总裁带领一支公司内部顶尖高手组成的团队,历时大半年开发了新的网站首页,进行了重大的改版与更新.随后,Facebook对该首页进行了A/B测试:当测试到5%用户群的时候,各项数据指标都在下滑:当测试到12%用户群的时候,下滑趋势依旧明显.于是,Facebook不得不放弃了这支30余人团队近一年努力的结果. A/B测试是个什么鬼?

google 2015最新的校招测试题与思路

快6点才想起来今个有google的在线测试.... 那么老长的英文的题目我都能看懂,说明英语跟六级没有直接关系.. 尼玛为毛国企银行移动联通小灵通神马的还要六级!!!!! 六级求过 Problem A. Seven-segment Display This contest is open for practice. You can try every problem as many times as you like, though we won't keep track of which pr