UVA 297 Quadtrees(四叉树建树、合并与遍历)

<span style="font-size: 18pt; font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">K - </span><span style="color: blue; font-size: 18pt; font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">Quadtrees</span>

Time
Limit:
3000MS     Memory
Limit:
0KB     64bit IO
Format:
%lld & %llu

Submit Status

Appoint
description: System Crawler  (2014-01-02)

Description





 Quadtrees 

A quadtree is a representation
format used to encode images. The fundamental idea behind the quadtree is that
any image can be split into four quadrants. Each quadrant may again be split in
four sub quadrants, etc. In the quadtree, the image is represented by a parent
node, while the four quadrants are represented by four child nodes, in a
predetermined order.

Of course, if the whole image is
a single color, it can be represented by a quadtree consisting of a single node.
In general, a quadrant needs only to be subdivided if it consists of pixels of
different colors. As a result, the quadtree need not be of uniform depth.

A modern computer artist works
with black-and-white images of  units, for a total of 1024 pixels per image. One of the
operations he performs is adding two images together, to form a new image. In
the resulting image a pixel is black if it was black in at least one of the
component images, otherwise it is white.

This particular artist believes
in what he calls the preferred fullness: for an image to be
interesting (i.e. to sell for big bucks) the most important property is the
number of filled (black) pixels in the image. So, before adding two images
together, he would like to know how many pixels will be black in the resulting
image. Your job is to write a program that, given the quadtree representation of
two images, calculates the number of pixels that are black in the image, which
is the result of adding the two images together.

In the figure, the first example
is shown (from top to bottom) as image, quadtree, pre-order string (defined
below) and number of pixels. The quadrant numbering is shown at the top of the
figure.


Input Specification


The first line of input
specifies the number of test cases (N) your program has to process.

The input for each test case is
two strings, each string on its own line. The string is the pre-order
representation of a quadtree, in which the letter ‘p‘ indicates a
parent node, the letter ‘f‘ (full) a black quadrant and the letter
e‘ (empty) a white quadrant. It is guaranteed that each string
represents a valid quadtree, while the depth of the tree is not more than 5
(because each pixel has only one color).

Output Specification


For each test case, print on one
line the text ‘There are X black pixels.‘,
where X is the number of black pixels in the resulting
image.

Example Input


3
ppeeefpffeefe
pefepeefe
peeef
peefe
peeef
peepefefe

Example Output


There are 640 black pixels.
There are 512 black pixels.
There are 384 black pixels.

题意:有一个用四叉树表示的图,该图用P,E,F来表示,P表示父节点,F表示黑色,E表示白色,整个图的大小为1024。每个子图都能分成四个部分(当颜色不同的时候才须要划分),如今要把两个图合并成一个图,求合并后图有多少黑色像素。

#include<stdio.h>
#include<cstring>
#include<algorithm>
int T;
char s1[2049],s2[2049];
struct quadtree
{
int num;
quadtree *next[4];
quadtree()
{
num=0;
for(int i=0; i<4; i++)next[i]=0;
}
};
quadtree *build(char *s)///建树
{
quadtree *now=new quadtree;
int len=strlen(s);
if(s[0]!=‘p‘)
{
now->num=1;
if(s[0]!=‘f‘)
{
delete now;
now=NULL;
}
return now;
}
int up=4;///子树数目
int d=1;
for(int i=1; d<=up&&i<len; i++)
{
if(s[i]==‘p‘)
{
now->next[d-1]=build(s+i);
int dx=0,dy=4;
while(dx<dy)
{
dx++;
if(s[i+dx]==‘p‘)dy+=4;
}
i+=dx;///i变到下一颗子树的起始位置
}
else
{
now->next[d-1]=build(s+i);
}
d++;
}
return now;
}
quadtree *merge_(quadtree *p,quadtree *q)///合并
{
if(p||q)
{
quadtree *root=new quadtree;
if(p&&q)for(int i=0; i<4; i++)
{
if(p->num||q->num)
{
root->num=1; ///子树已经全为黑色,不须要继续递归
continue;
}
root->next[i]=merge_(p->next[i],q->next[i]);
}
else if(p==NULL&&q)for(int i=0; i<4; i++)
{
if(q->num)
{
root->num=1;; ///子树已经全为黑色,不须要继续递归
continue;
}
root->next[i]=merge_(NULL,q->next[i]);
}
else for(int i=0; i<4; i++)
{
if(p->num)
{
root->num=1;; ///子树已经全为黑色,不须要继续递归
continue;
}
root->next[i]=merge_(p->next[i],NULL);
}
return root;
}
return NULL;
}
int dfs(quadtree *p,int num)
{
if(p==NULL)return 0;
int sum=0;
if(p->num)sum+=num;
for(int i=0; i<4; i++)
{
sum+=dfs(p->next[i],num/4);
}
return sum;
}
int main()
{
//freopen("in.txt","r",stdin);
quadtree *root1,*root2,*root;
scanf("%d",&T);
while(T--)
{
scanf("%s%s",s1,s2);
root=root1=root2=NULL;
root1=build(s1);
root2=build(s2);
root=merge_(root1,root2);
printf("There are %d black pixels.\n",dfs(root,1024));
}
return 0;
}

UVA 297 Quadtrees(四叉树建树、合并与遍历),布布扣,bubuko.com

时间: 2024-08-01 07:44:44

UVA 297 Quadtrees(四叉树建树、合并与遍历)的相关文章

uva 297 - Quadtrees

 Quadtrees  A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the im

UVA - 297 Quadtrees (四分树)

题意:求两棵四分树合并之后黑色像素的个数. 分析:边建树边统计. #include<cstdio> #include<cstring> #include<cstdlib> #include<cctype> #include<cmath> #include<iostream> #include<sstream> #include<iterator> #include<algorithm> #inclu

UVa 297.Quadtrees【非二叉树之四分树】【7月31】

Quadtrees A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the imag

UVa 297 Quadtrees(四分树)

题意  可以用一个四分图表示一32*32的黑白图像   求两个四分树对应图像相加所得图形黑色部分有多少像素 直接用一个32*32的矩阵表示图  黑色为非0白色为0  递归建图   最后有多少个非零就是答案了 #include<cstdio> #include<cstring> using namespace std; const int L = 32, N = 1050; char s[N]; int ans[L][L], cnt; void draw(char *s, int &

uva 297 quadtrees——yhx

Quadtrees  A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the ima

UVa 297 Quadtrees -SilverN

A quadtree is a representation format used to encode images. The fundamental idea behind the quadtree is that any image can be split into four quadrants. Each quadrant may again be split in four sub quadrants, etc. In the quadtree, the image is repre

UVA 699(二叉树建树与遍历)

M - The Falling Leaves Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu Submit Status Appoint description:  System Crawler  (2014-02-08) Description  The Falling Leaves  Each year, fall in the North Central region is accompanied

UVa 122 Trees on the level(建树,层次遍历)

题意  建树并层次遍历输出  (data,pos)  pos表示改节点位置  L代表左儿子  R代表右儿子 建树很简单  开始在根节点  遇到L往左走遇到R往右走 节点不存在就新建   走完了就保存改节点的值  输出直接bfs就行了了 #include<cstdio> #include<cctype> #include<cstring> using namespace std; const int maxn = 300; char s[maxn][maxn]; int

uva 297(传递闭包 WF 1996)

题意:在一张有向图中输出所有的环. 思路:先用Floyd求传递闭包,然后通过传递闭包建图若是Map[i][j] && Map[j][i]则建一条无向边.然后图中所有的连通分支即为一个环. 代码如下: 1 /************************************************** 2 * Author : xiaohao Z 3 * Blog : http://www.cnblogs.com/shu-xiaohao/ 4 * Last modified : 201