pat advanced level1022 digital library

1022 Digital Library (30)(30 分)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID‘s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user‘s search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID‘s in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
/**********************
author: yomi
date: 18.8.14
ps: 不难的题 可是 却 出了错 原来我的答案只是没有控制%7d啊
最后还是改成了答案的样子。。。
**********************/
#include <iostream>
#include <algorithm>
#include <sstream>
#include <string>
#include <set>
#include <map>
#include <cstdio>
using namespace std;
void print(map<string, set<int> > &mmap, string &query)
{
    map<string, set<int> >::iterator iter = mmap.find(query);
    if(iter == mmap.end()){
        cout << "Not Found" << endl;
        return;
    }
    set<int> s = iter->second;
    for(set<int>::iterator iter1=s.begin(); iter1!=s.end(); ++iter1){
        //cout << *iter1 << endl;
        printf("%07d\n", *iter1);
    }
}
int main()
{
    int n, m, id, tt;
    map<string, set<int> >title;
    map<string, set<int> >author;
    map<string, set<int> >word;
    map<string, set<int> >publisher;
    map<string, set<int> >year;
    cin >> n;
    string t, au, wo, pub, y;
    char ch;
    for(int i=0; i<n; i++){
        cin >> id;
        getchar();
        getline(cin, t);
        title[t].insert(id);
        //getchar();
        getline(cin, au);
        author[au].insert(id);
        ///test code debug sort keywords

        while(cin >> wo){
            char c = getchar();
//            if(c == ‘\n‘){
//                break;
//            }

            //cin >> ch;
            word[wo].insert(id);
            if(c == ‘\n‘){
                break;
            }
        }

        getline(cin, pub);
        publisher[pub].insert(id);

        getline(cin, y);
        year[y].insert(id);
    }
    cin >> m;
    char ch1;
    string query;
    int flag = 1;
    for(int i=0; i<m; i++){
        flag = 1;
        cin >> tt >> ch1;
        getchar();
        getline(cin, query);
        cout << tt << ch1 << " " << query << endl;
        if(tt == 1){
            print(title, query);
        }
        if(tt == 2){
            print(author, query);
        }
        if(tt == 3){
            print(word, query);
        }
        if(tt == 4){
            print(publisher, query);
        }
        if(tt == 5){
            print(year, query);
        }
    }
    return 0;
}
/**
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
**/

原文地址:https://www.cnblogs.com/AbsolutelyPerfect/p/9477410.html

时间: 2024-07-30 01:11:54

pat advanced level1022 digital library的相关文章

PAT Advanced 1022 Digital Library (30分)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are s

PAT 甲级 1022 Digital Library

https://pintia.cn/problem-sets/994805342720868352/problems/994805480801550336 A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigne

PAT甲级——A1022 Digital Library

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are s

PAT:1022. Digital Library (30) (部分正确,错最后两个)

1 #include<stdio.h> 2 #include<string.h> 3 #include<map> 4 #include<string> 5 #include<set> 6 #include<iostream> 7 using namespace std; 8 int n; //n本书 9 //标题.作者.关键字.出版社.出版年份与ID的映射 10 map<string,set<int>> mpT

PAT A 1022. Digital Library (30)【结构体排序检索】

https://www.patest.cn/contests/pat-a-practise/1022 直接模拟, 输入,按id排序,检索 #include <iostream> #include <string> #include <algorithm> using namespace std; struct book //图书结构 { string id; string title; string author; int k; //关键词数量 string key[5

PAT甲级1022 Digital Library

题目:https://pintia.cn/problem-sets/994805342720868352/problems/994805480801550336 题意: 每一本书有一个id, 书名,作者,至多五个关键字,一个出版社名,出版社年份. 现在根据给定的书名或作者或关键字或出版社名或年份,按照id字典序大小输出符合条件的书. 思路: 对每一个属性都用map维护. 一个坑点是,前面说书的年份一定在1000-3000之间,但是查询的时候的年份不一定满足,而且这里输出的时候也要满足4位.测试点

PTA (Advanced Level)1022 Digital Library

Digital Library A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a r

Pat(Advanced Level)Practice--1043(Is It a Binary Search Tree)

Pat1043代码 题目描述: A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node's key. The right subtree of a node contains only nodes

A1022. Digital Library (30)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are s