nyoj 803-A/B Problem

803-A/B Problem

内存限制:64MB
时间限制:1000ms
特判: No

通过数:2
提交数:4
难度:3

题目描述:

做了A+B Problem,A/B Problem不是什么问题了吧!

输入描述:

每组测试样例一行,首先一个号码A,中间一个或多个空格,然后一个符号( / 或者 % ),然后又是空格,后面又是一个号码B,A可能会很长,B是一个int范围的数。

输出描述:

输出结果。

样例输入:

复制

110 / 100
99 % 10
2147483647 / 2147483647
2147483646 % 2147483647

样例输出:

1
9
1
2147483646

python   未AC:

try:
    while True:
        a, b, c = input().split()
        a = int(a)
        c = int(c)

        if b == "/":
            print("%d" % (a / c))
        else:
            print("%d" % (a % c))
except EOFError:
    pass

C/C++ AC:(引之runbicheng)

#include<stdio.h>
#include<string.h>
char str[1000],ch[5];
int main()
{
    int b,s,i,n,f;
    while(~scanf("%s%s%d",str,&ch,&b))
    {
        s=i=0,f=0;
        n = strlen(str);
        if(*ch==‘%‘)
        {
            for(i=0; i<n; i++)
            {
                s=s*10+str[i]-48;
                s%=b;
            }
            printf("%d\n",s);
        }
        else
        {
            for(i=0; i<n; i++)
            {
                s=s*10+str[i]-48;
                if(s>=b)
                {
                    printf("%d",s/b);
                    f=1;
                }
                else if(f)
                {
                    putchar(48);
                }
                s%=b;
            }
            printf(!f?"0\n":"\n");
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/GetcharZp/p/9354033.html

时间: 2024-10-15 00:44:46

nyoj 803-A/B Problem的相关文章

nyoj 803 A/B Problem 【Java大数】

 先用字符串将字符串接收,然后在用BigInteger就好了 代码: import java.util.Scanner; import java.math.*; public class Main{ public static void main(String[] args){ Scanner cin = new Scanner(System.in); while(cin.hasNextBigInteger()){ BigInteger aa, bb; //a = cin.nextBigDeci

nyoj 803 A/B Problem(大数除小数&amp;&amp;大数求余小数)

这道题 也就是大数除或者求模小数,不过听说java处理大数很方便,可是java学的一塌糊涂..有心人用java做吧 奉上c语言代码: #include <stdio.h> #include <string.h> int main() { char a[1000],c[1000],ch; int b,i,j,r; while(scanf("%s %c %d",a,&ch,&b)!=EOF)//a是存贮大数,ch存贮运算符,b是小数 { r=0; i

NYOJ 179 LK&#39;s problem (排序模拟)

链接:click here~~ 题意: 描述 LK has a question.Coule you help her? It is the beginning of the day at a bank, and a crowd  of clients is already waiting for the entrance door to  open. Once the bank opens, no more clients arrive, and  tellerCount tellers be

NYOJ 698 A Coin Problem (斐波那契)

链接:click here 题意: 描述 One day,Jiameier is tidying up the room,and find some coins. Then she throws the coin to play.Suddenly,she thinks of a problem ,that if throw n times coin ,how many situations of no-continuous up of the coin. Hey,Let's solve the

NYOJ 707 A Simple Problem(结构体排序) 睡前一水~~

链接:click here 题意: A Simple Problem 时间限制:3000 ms  |  内存限制:65535 KB 难度:2 描述 You know, just as the title imply, this is a simple problem. In a contest, given the team-id, solved, penalty of all the teams, tell me the champion.If the numbers of solved pr

nyoj 513 A+B Problem IV 【Java大数】

这道题有点小坑.. 特殊数据 输入 0.0 0.0 输出 0 代码: import java.util.Scanner; import java.math.*; public class Main{ public static void main(String[] args){ Scanner cin = new Scanner(System.in); BigDecimal a, b, temp; temp = new BigDecimal("0.0"); while(cin.hasN

nyoj 1235 A/B Problem

A/B Problem 时间限制:1000 ms  |  内存限制:65535 KB 难度:3 描述 已知: 1. n = (A % 9973); 2. gcd(B, 9973) = 1; 计算: (A / B) % 9973 输入 数据的第一行是一个T,表示有T组数据.每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9). 输出 对应每组数据输出(A / B) % 9973. 样例输入 2 1000 53 87 123456789 样例输出 792

NYOJ 477 A+B Problem III(认识fabs函数)

 A+B Problem III 时间限制:1000 ms  |  内存限制:65535 KB 难度:1 描述 求A+B是否与C相等. 输入 T组测试数据. 每组数据中有三个实数A,B,C(-10000.0<=A,B<=10000.0,-20000.0<=C<=20000.0) 数据保证小数点后不超过4位. 输出 如果相等则输出Yes 不相等则输出No 样例输入 3 -11.1 +11.1 0 11 -11.25 -0.25 1 2 +4 样例输出 Yes Yes No 刚开始

NYoj The partial sum problem(简单深搜+优化)

题目链接:http://acm.nyist.edu.cn/JudgeOnline/problem.php?pid=927 代码: 1 #include <stdio.h> 2 #include <stdlib.h> 3 #include <string.h> 4 #include <math.h> 5 #include <algorithm> 6 #include <iostream> 7 using namespace std; 8

nyoj 623 A*B Problem II

A*B Problem II 时间限制:1000 ms  |  内存限制:65535 KB 难度:1 描述 ACM的C++同学有好多作业要做,最头痛莫过于线性代数了,因为每次做到矩阵相乘的时候,大量的乘法都会把他搞乱,所以他想请你写个程序帮他检验一下计算结果是否正确. 输入 有多组测试数据,每行给出一组m,n,k(0<m,n,k<=50).m,n,k表示两个矩阵的大小,其中: 矩阵A:m行n列. 矩阵B:n行k列. 接下来给出m*n个数表示矩阵A和n*k个数表示矩阵B,对于每个数s,0<