1058 A+B in Hogwarts (20分)

1058 A+B in Hogwarts (20分)

题目:

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it‘s easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27 

### Sample Output:

14.1.28

题意:

17 Sickle = 1 Galleon ; 29 Knuts = 1 Sickle

例子:

3.2.1 + 10.16.27 = 13.18.28 = 14.1.28

题解:

#include <cstdio>
int main() {
    int ag,as,ak,bg,bs,bk,g,s,k;
    scanf("%d.%d.%d %d.%d.%d",&ag,&as,&ak,&bg,&bs,&bk);
    g = ag + bg;
    s = as + bs;
    k = ak + bk;
    if(k >= 29) s += (k / 29), k %= 29;
    if(s >= 17) g += (s / 17), s %= 17;
    printf("%d.%d.%d",g,s,k);
    return 0;
}

原文地址:https://www.cnblogs.com/F4lc0n/p/12235188.html

时间: 2024-10-08 08:00:10

1058 A+B in Hogwarts (20分)的相关文章

PAT 甲级 1058 A+B in Hogwarts (20 分) (简单题)

1058 A+B in Hogwarts (20 分)   If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enou

1058 A+B in Hogwarts (20分)(水)

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write

1058 A+B in Hogwarts (20)

1 #include <stdio.h> 2 int main() 3 { 4 int ans1[3]; 5 int ans2[3]; 6 while(scanf("%d.%d.%d %d.%d.%d",&ans1[0],&ans1[1],&ans1[2],&ans2[0],&ans2[1],&ans2[2])!=EOF) 7 { 8 ans1[0]+=ans2[0]; 9 ans1[1]+=ans2[1]; 10 ans1[

PAT:1058. A+B in Hogwarts (20) AC

#include<stdio.h> #include<stdlib.h> int main() { int a1,b1,c1,a2,b2,c2; //[思维]168以内的数字可以用两位13进制数表示,大大简化代码 scanf("%d.%d.%d",&a1,&b1,&c1); scanf("%d.%d.%d",&a2,&b2,&c2); int ra,rb,rc,tmp; //ra,rb,rc存放

PAT (Advanced Level) 1058. A+B in Hogwarts (20)

简单题. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<queue> #include<algorithm> using namespace std; int a1,b1,c1; int a2,b2,c2; int ans1,ans2,ans3; int main() { scanf("%d.%d.%d",&

pat1058. A+B in Hogwarts (20)

1058. A+B in Hogwarts (20) 时间限制 50 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickle

1058. A+B in Hogwarts

1058. A+B in Hogwarts (20) 时间限制 50 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickle

pat 1058 A+B in Hogwarts(20 分)

1058 A+B in Hogwarts(20 分) If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough.

1058 A+B in Hogwarts (20 分)

1058 A+B in Hogwarts (20 分) If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough