Gold Coins(闲来无事水一发)

Gold Coins

Time Limit: 1000MS Memory Limit: 30000K

Total Submissions: 21155 Accepted: 13265

Description

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth,
fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after
receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer.

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

Input

The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing
the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given
number of days, starting with Day 1.

Sample Input

10
6
7
11
15
16
100
10000
1000
21
22
0

Sample Output
10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int main()
{
    int T,n;
    int sum=0;// 在n天内得到的钱;
    int cnt;//控制每一天钱的多少的次数;
    int zf;//每天需要支付的钱;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
           sum=0;
           cnt=0;
           zf=1;
           for(int i=1;i<=n;i++)
           {
               sum+=zf;
               cnt++;
               if(cnt==zf)
               {
                   cnt=0;
                   zf+=1;
               }
           }
           printf("%d %d\n",n,sum);

    }
    return 0;
}



时间: 2024-08-04 11:43:55

Gold Coins(闲来无事水一发)的相关文章

HDU2401 Baskets of Gold Coins【水题】【推理】

Baskets of Gold Coins Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1648    Accepted Submission(s): 966 Problem Description You are given N baskets of gold coins. The baskets are numbered fro

HDOJ(HDU) 2401 Baskets of Gold Coins(数列、)

Problem Description You are given N baskets of gold coins. The baskets are numbered from 1 to N. In all except one of the baskets, each gold coin weighs w grams. In the one exceptional basket, each gold coin weighs w-d grams. A wizard appears on the

hust 1170 - Baskets of Gold Coins

题目描述 You are given N baskets of gold coins. The baskets are numbered from 1 to N. In all except one of the baskets, each gold coin weighs w grams. In the one exceptional basket, each gold coin weighs w-d grams. A wizard appears on the scene and takes

H - Gold Coins(2.4.1)

H - Gold Coins(2.4.1) Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u Submit Status Description The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of

codechef - Bytelandian gold coins 题解

In Byteland they have a very strange monetary system. Each Bytelandian gold coin has an integer number written on it. A coin n can be exchanged in a bank into three coins: n/2, n/3 and n/4. But these numbers are all rounded down (the banks have to ma

UVALive3045 POJ2000 ZOJ2345 Gold Coins

Regionals 2004 >> North America - Rocky Mountain 问题链接:UVALive3045 POJ2000 ZOJ2345 Gold Coins.基础练习题,用C语言编写. 题意简述:骑士第1天获得1个金币,之后的2天获得2个金币,之后的3天获得3个金币,......,之后的i天获得i个金币,.......问到第n天总共获得多少个金币. 问题分析:这是一个数列求和问题,用程序解决比用数学解决方便很多. 程序中,用数组ans[]存储金币之和,即ans[i]

Baskets of Gold Coins

Baskets of Gold Coins Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1862    Accepted Submission(s): 1108 Problem Description You are given N baskets of gold coins. The baskets are numbered fro

[ACM] POJ 2000 Gold Coins

Gold Coins Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 20913   Accepted: 13098 Description The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days

hdoj 2401 Baskets of Gold Coins

Baskets of Gold Coins Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1855    Accepted Submission(s): 1104 Problem Description You are given N baskets of gold coins. The baskets are numbered fro