hdu 1102 Constructing Roads 最小生成树Prim算法AC 水~~~

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15230    Accepted Submission(s): 5826

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source

kicc

只要把已经建好的路的权值设置为0就可以了。

水题,没什么好说的

代码:

#include <stdio.h>
#include <string.h>
#define INF 100000000
#define MAX 110

int graph[MAX][MAX] ;

int prim(int n)
{
	int lowCost[MAX],closest[MAX];
	bool visited[MAX];
	memset(visited,false,sizeof(visited)) ;
	for(int i = 1 ; i <= n ; ++i)
	{
		lowCost[i] = graph[1][i] ;
		closest[i] = 1 ;
	}
	visited[1] = true ;
	int sum = 0 ;
	for(int i = 0 ; i < n-1 ; ++i)
	{
		int min = INF , index = -1 ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && min>lowCost[j])
			{
				index = j ;
				min = lowCost[j] ;
			}
		}
		if(index == -1)
		{
			break ;
		}
		sum += lowCost[index] ;
		visited[index] = true ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && lowCost[j]>graph[index][j])
			{
				lowCost[j] = graph[index][j] ;
				closest[j] = index ;
			}
		}
	}
	return sum ;
}

int main()
{
	int n ;
	while(~scanf("%d",&n))
	{
		for(int i = 1 ; i <= n ; ++i)
		{
			for(int j = 1 ; j <= n ; ++j)
			{
				int w ;
				scanf("%d",&w) ;
				graph[i][j] = w ;
			}
		}
		int q ;
		scanf("%d",&q);
		for(int i = 0 ; i < q ; ++i)
		{
			int x , y ;
			scanf("%d%d",&x,&y);
			graph[x][y] = graph[y][x] = 0 ;
		}
		int sum = prim(n) ;
		printf("%d\n",sum) ;
	}
	return 0 ;
}

与君共勉

时间: 2024-08-08 05:36:31

hdu 1102 Constructing Roads 最小生成树Prim算法AC 水~~~的相关文章

hdu 1102 Constructing Roads (Prim算法)

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 21947    Accepted Submission(s): 8448 Problem Description There are N villa

hdu 1102 Constructing Roads(最小生成树 Prim)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 Problem Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are conne

HDU 1102 Constructing Roads, Prim+优先队列

题目链接:HDU 1102 Constructing Roads Constructing Roads Problem Description There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are conne

HDU 1102 Constructing Roads (最小生成树)

最小生成树模板(嗯……在kuangbin模板里面抄的……) 最小生成树(prim) /** Prim求MST * 耗费矩阵cost[][],标号从0开始,0~n-1 * 返回最小生成树的权值,返回-1表示原图不连通 */ const int INF = 0x3f3f3f3f; const int MAXN = 110; bool vis[MAXN]; int lowc[MAXN]; int map[MAXN][MAXN]; int Prim(int cost[][MAXN], int n) {

hdu 1102 Constructing Roads(kruskal || prim)

求最小生成树,有一点点的变化,就是有的边已经给出来了,所以,最小生成树里面必须有这些边,kruskal和prim算法都可以,prim更简单一些,有一点需要注意,用克鲁斯卡尔算法的时候需要将已经存在的边预处理一下,并查集转化为同一个祖先,记得要找他们的祖先再转化.普里姆算法只需要将那些已经存在的边都初始化为0就可以了. kruskal: #include<iostream> #include<cstdlib> #include<cstring> #include<a

HDU 1102 Constructing Roads (裸的并查集)

Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13210    Accepted Submission(s): 4995 Problem Description There are N villages, which are numbered from 1 to N, and you should

hdu 1102 Constructing Roads (最小生成树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102 Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14172    Accepted Submission(s): 5402 Problem Description There are N villa

HDU - 1102 - Constructing Roads (最小生成树--prim算法!!)

Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14890    Accepted Submission(s): 5674 Problem Description There are N villages, which are numbered from 1 to N, and you should

HDU 1102 Constructing Roads【简单最小生成树,Prime算法+Kruskal算法】

Constructing Roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 20765    Accepted Submission(s): 7934 Problem Description There are N villages, which are numbered from 1 to N, and you should