poj 3352 Road Construction【边双连通求最少加多少条边使图双连通&&缩点】

Road Construction

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10141   Accepted: 5031

Description

It‘s almost summer time, and that means that it‘s almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 ton. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0

题意:有n个旅游景点和r条路,任意两个景点之间都间接或直接的连在一起,但是有时候道路施工时我们无法走这条路,也就是说两个景点之间的道路断了,问现在最少添加多少条通道,使任意两个景点之间都不止一条通道

题解:显而易见此题是让求最少添加多少条路使图双连通,因为所有的点都是相连的,只是不是双连通,我们可以把原始数据看做是一个双连通图去掉了几条边所变成的图形,现在我们需要将这几条边加上去,一个双连通图其度数至少为2,所以当我们遇见度数为1的点时记录下来,最后度数为1的点的总数(sum+1)/2就是最后结果

注意:输入输出真坑,本来以为每组输入和输出前都要输出字符串的  结果一直wa
#include<stdio.h>
#include<string.h>
#include<stack>
#include<algorithm>
#define MAX 21000
#include<vector>
#define MAXM 2001000
#define INF 0x7ffffff
using namespace std;
int n,m,num,bridge;
int head[MAX],ans;
int in[MAX];
int low[MAX],dfn[MAX];
int instack[MAX],iscut[MAX];
int addbcc[MAX];
int dfsclock,bccno[MAX];
int bcccnt;
stack<int>s;
vector<int>newmap[MAX];
vector<int>bcc[MAX];
struct node
{
	int beg,end,next;
}edge[MAXM];
void init()
{
	ans=0;
	memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
	edge[ans].beg=u;
	edge[ans].end=v;
	edge[ans].next=head[u];
	head[u]=ans++;
}
void getmap()
{
	int a,b,i;
	while(m--)
	{
		scanf("%d%d",&a,&b);
		add(a,b);
		add(b,a);
	}
}
void tarjan(int u,int fa)
{
	int i,j,v;
	s.push(u);
	instack[u]=1;
	low[u]=dfn[u]=++dfsclock;
	int son=0;
	int flag=1;
	for(i=head[u];i!=-1;i=edge[i].next)
	{
		v=edge[i].end;
		if(v==fa&&flag)//去重边
		{
			flag=0;
			continue;
		}
		if(!dfn[v])
		{
			tarjan(v,u);
			low[u]=min(low[u],low[v]);
			if(low[v]>dfn[u])//是桥
			    bridge++;
		}
		else
		    low[u]=min(low[u],dfn[v]);
	}
    if(low[u]==dfn[u])
    {
    	bcccnt++;
    	while(1)
    	{
    		v=s.top();
    		s.pop();
    		instack[v]=0;
    		bccno[v]=bcccnt;
    		if(v==u)
    		    break;
    	}
    }
}
void find(int l,int r)
{
	int i;
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	memset(instack,0,sizeof(instack));
	memset(iscut,0,sizeof(iscut));
	dfsclock=bcccnt=0;
	for(i=l;i<=r;i++)
	{
		if(!dfn[i])
		    tarjan(i,-1);
	}
}
void suodian()
{
	int u,v,i;
	memset(in,0,sizeof(in));
	for(i=0;i<ans;i+=2)
	{
		u=bccno[edge[i].beg];
		v=bccno[edge[i].end];
		if(v!=u)
		{
			newmap[u].push_back(v);
			newmap[v].push_back(u);
			in[u]++;
			in[v]++;
		}
	}
}
void solve()
{
	int sum,i,j;
	sum=0;
	for(i=1;i<=bcccnt;i++)
	{
		if(in[i]==1)
			sum++;
	}
	printf("%d\n",(sum+1)/2);
}
int main()
{
	int i,j,k,t;
	k=1;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		init();
		getmap();
		find(1,n);
		suodian();
		solve();
	}
	return 0;
}

  

时间: 2024-12-14 18:43:34

poj 3352 Road Construction【边双连通求最少加多少条边使图双连通&&缩点】的相关文章

POJ 1236--Network of Schools【scc缩点构图 &amp;&amp; 求scc入度为0的个数 &amp;&amp; 求最少加几条边使图变成强联通】

Network of Schools Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 13325   Accepted: 5328 Description A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a li

hdoj 3836 Equivalent Sets【scc&amp;&amp;缩点】【求最少加多少条边使图强连通】

Equivalent Sets Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 104857/104857 K (Java/Others)Total Submission(s): 3568    Accepted Submission(s): 1235 Problem Description To prove two sets A and B are equivalent, we can first prove A is a su

POJ 3177 Redundant Paths POJ 3352 Road Construction(双连通)

POJ 3177 Redundant Paths POJ 3352 Road Construction 题目链接 题意:两题一样的,一份代码能交,给定一个连通无向图,问加几条边能使得图变成一个双连通图 思路:先求双连通,缩点后,计算入度为1的个数,然后(个数 + 1) / 2 就是答案(这题由于是只有一个连通块所以可以这么搞,如果有多个,就不能这样搞了) 代码: #include <cstdio> #include <cstring> #include <algorithm&

POJ 3352 Road Construction 使得无向图边变双连通图

点击打开链接 Road Construction Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 8168   Accepted: 4106 Description It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of

POJ 3352 Road Construction POJ 3177 Redundant Paths(边双连通图 Tarjan+缩点)

POJ 3352 Road Construction POJ 3177 Redundant Paths(边双连通图 Tarjan+缩点) ACM 题目地址: POJ 3352 Road Construction POJ 3177 Redundant Paths 题意: 问要添加几条边才能使所给无向图图变成边双连通图. 分析: 边连通度:使无向图G不连通的最少删边数量为其边连通度. 边双连通图:边连通度大于1的无向图. 首先缩点,让图变成一个DAG. 现在问题转化为:在树中至少添加多少条边能使图变

POJ 3352 Road Construction(图论-tarjan)

Road Construction Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 8647   Accepted: 4318 Description It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the ro

POJ 3352 Road Construction(无向连通图)

题目地址:POJ 3352 这题就是求最少加多少条边可以使得图为无向双连通图.方法是找度数为1的连通分量,可以只用low来找.然后根据公式(叶子结点数+1)/2即可得到答案.原因是在图中将每两个度数为1的都连起来,度数为2的显然已经可以形成双联通了,因为是无向边,只要加一条,就相当于加了两条有向边,很显然,结果数就是那个公式. 代码如下: #include <iostream> #include <cstdio> #include <string> #include &

POJ 3352 Road Construction(边—双连通分量)

http://poj.org/problem?id=3352 题意: 给出一个图,求最少要加多少条边,能把该图变成边—双连通. 思路:双连通分量是没有桥的,dfs一遍,计算出每个结点的low值,如果相等,说明属于同一个双连通分量. 接下来把连通分量缩点,然后把这些点连边. 对于一棵无向树,我们要使得其变成边双连通图,需要添加的边数 == (树中度数为1的点的个数+1)/2. 1 #include<iostream> 2 #include<algorithm> 3 #include&

Poj 3352 Road Construction &amp; Poj 3177 Redundant Paths(边双连通分量+缩点)

Road Construction Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 9465   Accepted: 4699 Description It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the ro