HDU2988 Dark roads【Kruskal】

Dark roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 679    Accepted Submission(s): 286

Problem Description

Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day.
To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some
streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?

Input

The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000.
Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less
than 231.

Output

For each test case print one line containing the maximum daily amount the government can save.

Sample Input

7 11

0 1 7

0 3 5

1 2 8

1 3 9

1 4 7

2 4 5

3 4 15

3 5 6

4 5 8

4 6 9

5 6 11

0 0

Sample Output

51

题目大意:给你N个点M条路的图,点的变化由0~N-1,求最小生成树。

思路:裸的Kruskal算法,直接求就可以。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

struct Edge
{
    int from;
    int to;
    int w;
};

Edge Edges[200200];

int father[200200],N,M;

int find(int x)
{
    if(x != father[x])
        father[x] = find(father[x]);
    return father[x];
}

int cmp(Edge a,Edge b)
{
    return a.w < b.w;
}

int Kruskal()
{
    int a,b,ans = 0,k = 0;
    for(int i = 0; i < M; i++)
    {
        a = find(Edges[i].from);
        b = find(Edges[i].to);
        if(a != b)
        {
            ans += Edges[i].w;
            father[b] = a;
            k++;
            if(k == N-1)
                break;
        }
    }
    return ans;
}
int main()
{
    int x,y,w,Sum;
    while(scanf("%d%d",&N,&M) && (N||M))
    {
        if(M==0 && N==0)
            break;
        for(int i = 0; i < N; i++)
            father[i] = i;
        Sum = 0;
        for(int i = 0; i < M; i++)
        {
            scanf("%d%d%d",&x,&y,&w);
            Edges[i].from = x;
            Edges[i].to = y;
            Edges[i].w = w;
            Sum += w;
        }
        sort(Edges,Edges+M,cmp);
        int ans = Kruskal();
        printf("%d\n",Sum-ans);
    }

    return 0;
}
时间: 2024-11-05 06:26:11

HDU2988 Dark roads【Kruskal】的相关文章

HDU2988 Dark roads 【最小生成树Kruskal】

Dark roads Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 583    Accepted Submission(s): 253 Problem Description Economic times these days are tough, even in Byteland. To reduce the operating

POJ--2421--Constructing Roads【最小生成树】

链接:http://poj.org/problem?id=2421 题意:n个村庄,告诉你任两个村庄间距离,要建一些路使得任两个村庄都可以互相到达,需要使花费最小,其中有q条路已经建了,求最小花费. 把已经建的路的权值改为0,再prim就行了.kruskal做的话,把建好的路用并查集合并,再kruskal就行了 #include<cstring> #include<string> #include<fstream> #include<iostream> #i

hdoj 1863 畅通工程 【最小生成树】+【kruskal】

题意:... 难点:如何判断是不是信息不全:在输入的时候建立并查集,之后判断有几个节点就可以了,剩下的就是kruskal算法. 代码: #include<stdio.h> #include<string.h> #include<algorithm> #define MAXN 105 #define INF 0x3f3f3f3f using std::sort; struct node{ int from; int to; int w; }edges[MAXN*MAXN]

Dark roads(kruskal)

Dark roads Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other) Total Submission(s) : 7   Accepted Submission(s) : 2 Problem Description Economic times these days are tough, even in Byteland. To reduce the operating costs,

HDU2122 Ice_cream’s world III【Kruskal】

Ice_cream's world III Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 997    Accepted Submission(s): 321 Problem Description ice_cream's world becomes stronger and stronger; every road is built

POJ2395 Out of Hay【Kruskal】

Out of Hay Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 11656Accepted: 4562 Description The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situat

HDU3371 Connect the Cities【Kruskal】

Connect the Cities Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11152    Accepted Submission(s): 3155 Problem Description In 2100, since the sea level rise, most of the cities disappear. Tho

hdoj-1301-Jungle Roads【最小生成树】

Jungle Roads Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5203 Accepted Submission(s): 3766 Problem Description The Head Elder of the tropical island of Lagrishan has a problem. A burst of fore

hdoj-1102-Constructing Roads【最小生成树】

Constructing Roads Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16579 Accepted Submission(s): 6312 Problem Description There are N villages, which are numbered from 1 to N, and you should build