hdu 5318 The Goddess Of The Moon

The Goddess Of The Moon

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1487    Accepted Submission(s): 650

Problem Description

Chang’e (嫦娥) is a well-known character in Chinese ancient mythology. She’s the goddess of the Moon. There are many tales about Chang‘e, but there‘s a well-known story regarding the origin of the Mid-Autumn Moon Festival. In a very distant past, ten suns had risen together to the heavens, thus causing hardship for the people. The archer Yi shot down nine of them and was given the elixir of immortality as a reward, but he did not consume it as he did not want to gain immortality without his beloved wife Chang‘e.

However, while Yi went out hunting, Fengmeng broke into his house and forced Chang‘e to give up the elixir of immortality to him, but she refused to do so. Instead, Chang‘e drank it and flew upwards towards the heavens, choosing the moon as residence to be nearby her beloved husband.

Yi discovered what had transpired and felt sad, so he displayed the fruits and cakes that his wife Chang‘e had liked, and gave sacrifices to her. Now, let’s help Yi to the moon so that he can see his beloved wife. Imagine the earth is a point and the moon is also a point, there are n kinds of short chains in the earth, each chain is described as a number, we can also take it as a string, the quantity of each kind of chain is infinite. The only condition that a string A connect another string B is there is a suffix of A , equals a prefix of B, and the length of the suffix(prefix) must bigger than one(just make the joint more stable for security concern), Yi can connect some of the chains to make a long chain so that he can reach the moon, but before he connect the chains, he wonders that how many different long chains he can make if he choose m chains from the original chains.

Input

The first line is an integer T represent the number of test cases.
Each of the test case begins with two integers n, m. 
(n <= 50, m <= 1e9)
The following line contains n integer numbers describe the n kinds of chains.
All the Integers are less or equal than 1e9.

Output

Output the answer mod 1000000007.

Sample Input

2
10 50
12 1213 1212 1313231 12312413 12312 4123 1231 3 131
5 50
121 123 213 132 321

Sample Output

86814837
797922656

Hint

11 111 is different with 111 11

Author

ZSTU

Source

2015 Multi-University Training Contest 3

Recommend

wange2014   |   We have carefully selected several similar problems for you:  6022 6021 6020 6019 6018

#include<set>
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
typedef long long ll;
const int N=60;
const ll mod=1e9+7;
struct matrix{
    ll s[N][N];
    matrix(){
        memset(s,0,sizeof s);
    }
};
int n,m,T,cnt,len[N];ll ans;
matrix operator *(const matrix &a,const matrix &b){
    matrix c;
    for(int i=0;i<n;i++){
        for(int j=0;j<n;j++){
            for(int k=0;k<n;k++){
                c.s[i][j]+=a.s[i][k]*b.s[k][j];
            }
            c.s[i][j]%=mod;
        }
    }
    return c;
}
matrix fpow(matrix a,ll p){
    matrix res;
    for(int i=0;i<n;i++) res.s[i][i]=1;
    for(;p;p>>=1,a=a*a) if(p&1) res=res*a;
    return res;
}
set<string>ag;
string s[N],str;
int main(){
    for(scanf("%d",&T);T--;){
        scanf("%d%d",&n,&m);
        matrix A,F;
        ag.clear();cnt=0;
        for(int i=1;i<=n;i++){
            cin>>str;
            if(ag.find(str)==ag.end()){
                ag.insert(str);
                s[cnt]=str;
                len[cnt++]=str.length();
            }
        }
        n=cnt;
        for(int i=0,f,L;i<n;i++){
            for(int j=0;j<n;j++){
                L=min(len[i],len[j]);
                for(int l=2;l<=L;l++){
                    f=0;
                    for(int k=0;k<l;k++){
                        if(s[i][k]!=s[j][len[j]-(l-k)]){
                            f=1;
                            break;
                        }
                    }
                    if(!f){
                        A.s[j][i]=1;
                        break;
                    }
                }

            }
        }
        for(int i=0;i<n;i++) F.s[0][i]=1;
        A=fpow(A,m-1);
        F=F*A;
        ll ans=0;
        for(int i=0;i<n;i++) ans=(ans+F.s[0][i])%mod;
        cout<<ans<<‘\n‘;
    }
    return 0;
}
时间: 2024-07-28 16:54:50

hdu 5318 The Goddess Of The Moon的相关文章

hdu 5318 The Goddess Of The Moon(矩阵快速幂)

题目链接:hdu 5318 The Goddess Of The Moon 将50个串处理成50*50的矩阵,注意重复串. #include <cstdio> #include <cstring> #include <cstdlib> #include <algorithm> using namespace std; const int maxn = 55; const int mod = 1e9+7; int N, M, A[maxn]; struct M

HDU 5318 The Goddess Of The Moon (矩阵快速幂)

题目链接:HDU 5318 The Goddess Of The Moon 题意:给出N串字符串,若是一个字符串的后缀与另一个字符串的前缀相同并且长度大于1,就表示这两个字符串是可以相连的,问M个字符串相连不同方案数为多少. 思路: 1.将输入的字符串预处理存入一个矩阵中,mp[i][j]=1说明str[i]与str[j]能相连,反之,则不能相连. 2.str[i]与str[j]能相连 转化为 i点到j点可达,那么就可以得到一个有向图,长度为M的意思就是 两点之间所走的步数为M的不同走法有多少种

hdu 5318 The Goddess Of The Moon 矩阵高速幂

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5318 The Goddess Of The Moon Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 438    Accepted Submission(s): 150 Problem Description Chang'e (嫦娥) is

HDU 5318 The Goddess Of The Moon(矩阵快速幂详解)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5318 题面: The Goddess Of The Moon Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 800    Accepted Submission(s): 349 Problem Description Chang'e (嫦

【矩阵快速幂】HDU 5318 The Goddess Of The Moon

通道 题意:n个数,A后缀和B的前缀相同,建边,问长度为m的有多少个. 思路:建图,完了 代码: 1 #include<cstdio> 2 #include<cstring> 3 #include <vector> 4 5 using namespace std; 6 7 typedef long long ll; 8 9 const int MAX_N = 57; 10 const ll MOD = 1000000007; 11 12 typedef vector&l

HDU 5318 The Goddess Of The Moon(递推+矩阵优化)

题目链接:传送门 题意: 相当于有一个长度为m的路,我们有n种砖,每种砖被表示为一个字符串,一个长度大于等于2的后缀等于 另一个字符串的前缀那么那一块砖就可以放在这块砖的后面. 分析: 这个就是常见的铺砖的那个模型变化而来的,但是这题的递推关系需要根据题目给定的字符串的结构来决 定,由于m比较大,我们需要用矩阵来优化,根据题目给定的字符串来确定状态转移矩阵A,初始的矩阵为单 位矩阵I,然后ans = A^(m-1)*I.在确定A的时候注意给字符串去重. 代码如下: #include <iostr

矩阵快速幂 HDOJ 5318 The Goddess Of The Moon

题目传送门 1 /* 2 DP::dp[i][k] 表示选择i个字符串,最后一次是k类型的字符串,它由sum (dp[i-1][j]) (a[j], a[k] is ok)累加而来 3 矩阵快速幂:将n个字符串看成n*n的矩阵,如果匹配,矩阵对应位置为1.矩阵缩短递推dp时间,然后乘m-1次(dp[m][i])累加即可 4 注意去重 5 详细解释:http://blog.csdn.net/keshuai19940722/article/details/47111215 6 */ 7 #inclu

HDOJ 5318 The Goddess Of The Moon 矩阵快速幂

The Goddess Of The Moon Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 540    Accepted Submission(s): 215 Problem Description Chang'e (嫦娥) is a well-known character in Chinese ancient mytholog

HDU 5318(The Goddess Of The Moon-矩阵乘法)[Template:矩阵]

The Goddess Of The Moon Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1086    Accepted Submission(s): 489 Problem Description Chang'e (嫦娥) is a well-known character in Chinese ancient mytholo