HDU1887 ZOJ2982 UVALive3958 Weird Numbers【进制】

Weird Numbers

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 594 Accepted Submission(s): 185

Problem Description
Binary numbers form the principal basis of computer science. Most of you have heard of other systems, such as ternary, octal, or hexadecimal. You probably know how to use these systems and how to convert numbers between them. But did you know that the system base (radix) could also be negative? One assistant professor at the Czech Technical University has recently met negabinary numbers and other systems with a negative base. Will you help him to convert numbers to and from these systems?

A number N written in the system with a positive base R will always appear as a string of digits between 0 and R - 1, inclusive. A digit at the position P (positions are counted from right to left and starting with zero) represents a value of R^P . This means the value of the digit is multiplied by R^P and values of all positions are summed together. For example, if we use the octal system (radix R = 8), a number written as 17024 has the following value:

1.8^4 + 7.8^3 + 0.8^2 + 2.8^1 + 4.8^0 = 1.4096 + 7.512 + 2.8 + 4.1 = 7700

With a negative radix -R, the principle remains the same: each digit will have a value of (-R)^P .
For example, a negaoctal (radix R = -8) number 17024 counts as:

1.(-8)^4 + 7.(-8)^3 + 0.(-8)^2 + 2.(-8)^1 + 4.(-8)^0 = 1.4096 - 7.512 - 2.8 + 4.1 = 500

One big advantage of systems with a negative base is that we do not need a minus sign to express negative numbers. A couple of examples for the negabinary system (R = -2):


You may notice that the negabinary representation of any integer number is unique, if no “leading zeros” are allowed. The only number that can start with the digit “0”, is the zero itself.

Input
The input will contain several conversions, each of them specified on one line. A conversion from the decimal system to some negative-base system will start with a lowercase word “to” followed by a minus sign (with no space before it), the requested base (radix) R, one space, and a decimal number N .

A conversion to the decimal system will start with a lowercase word “from”, followed by a minus sign, radix R, one space, and a number written in the system with a base of -R.

The input will be terminated by a line containing a lowercase word “end”. All numbers will satisfy the following conditions: 2 ≤ R ≤ 10, -1000000≤N≤1000000 (decimal).

Output
For each conversion, print one number on a separate line. If the input used a decimal format,output the same number written in the system with a base -R. If the input contained such a number, output its decimal value.

Both input and output numbers must not contain any leading zeros. The minus sign "-" may only be present with negative numbers written in the decimal system. Any non-negative number or a number written in a negative-base system must not start with it.

Sample Input
to-2 10
from-2 1010
to-10 10
to-10 -10
from-10 10
end

Sample Output
11110
-10
190
10
-10

Source
2008 “Shun Yu Cup” Zhejiang Collegiate Programming Contest - Warm Up(2)

Regionals 2007 >> Europe - Central

问题链接HDU1887 ZOJ2982 UVALive3958 Weird Numbers
问题简述:(略)
问题分析
????进制问题,简单题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HDU1887 ZOJ2982 UVALive3958 Weird Numbers */

#include <iostream>
#include <cstdio>

using namespace std;

const int N = 64;
char s[N], s2[N];

int main()
{
    int radix, n, ans, cnt;
    while(scanf("%s", s) != EOF && s[0] != 'e') {
        if(s[0] == 'f') {
            sscanf(s + 4, "%d", &radix);
            scanf("%s", s2);
            ans = 0;
            for(int i = 0; s2[i]; i++)
                ans = ans * radix + s2[i] - '0';
            printf("%d\n", ans);
        } else {
            sscanf(s + 2, "%d", &radix);
            scanf("%d", &n);
            cnt = 0;
            do {
                int digit = n % radix;
                n /= radix;
                if(digit < 0)
                    digit -= radix, n++;
                s2[cnt++] = digit;
            } while(n);
            for(int i = cnt - 1; i >= 0; i--)
                printf("%d", s2[i]);
            printf("\n");
        }
    }

    return 0;
}

原文地址:https://www.cnblogs.com/tigerisland45/p/10385488.html

时间: 2024-11-05 20:45:32

HDU1887 ZOJ2982 UVALive3958 Weird Numbers【进制】的相关文章

HDOJ 1390 Binary Numbers(进制问题)

Problem Description Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0. Example The positions of 1's in the binary representation of 13 are 0, 2, 3. Task Write a prog

【HDU 1887】Weird Numbers(负进制转换)

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1887 题意:有两种操作,from-r n代表把一个-r进制下的数字n转换成10进制,to-r n代表把一个10进制下的数字n转化成-r进制. 分析:两种操作中from操作很容易实现,和转换成正进制一样,没什么好说的,而to操作我们首先可以像正常转化一样进行短除法,举个例子: 把15转化为-3进制.短除法并且倒序之后结果为1,-2,0.而我们的进制中是不能出现-2的,所以我们可以这样考虑,-2这位代表的

ZOJ1154 Niven Numbers【进制】

Niven Numbers Time Limit: 2 Seconds Memory Limit: 65536 KB A Niven number is a number such that the sum of its digits divides itself. For example, 111 is a Niven number because the sum of its digits is 3, which divides 111. We can also specify a numb

HDU 1197 Specialized Four-Digit Numbers (枚举+进制转化,简单)

题意:让求从2992-9999中所有数字,满足10进制各位之和和12进制和16进制各位数字之和相等. 析:没啥可说的,只能枚举从2992-9999,每个进制都算一下. 代码如下: #include <iostream> #include <cstdio> #include <algorithm> #include <queue> #include <vector> #include <cstring> #include <map

ZOJ 2405 Specialized Four-Digit Numbers(写个进制求和函数)

原题:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1405 注:看到网上的一些写法,10进制/12进制/16进制 都写了个字函数,其实统一写个进制求和子函数很简单 #include<iostream> using namespace std; int base_sum(int num,int base) { int sum=0; while(num) { sum+=num%base; num/=base; } retur

NUMBER BASE CONVERSION(进制转换)

Description Write a program to convert numbers in one base to numbers in a second base. There are 62 different digits: { 0-9,A-Z,a-z } HINT: If you make a sequence of base conversions using the output of one conversion as the input to the next, when

[ACM] ZOJ Martian Addition (20进制的两个大数相加)

Martian Addition Time Limit: 2 Seconds      Memory Limit: 65536 KB   In the 22nd Century, scientists have discovered intelligent residents live on the Mars. Martians are very fond of mathematics. Every year, they would hold an Arithmetic Contest on M

Python内置函数进制转换的用法

使用Python内置函数:bin().oct().int().hex()可实现进制转换. 先看Python官方文档中对这几个内置函数的描述: bin(x)Convert an integer number to a binary string. The result is a valid Python expression. If x is not a Python int object, it has to define an __index__() method that returns a

______________________________贴一个进制转换的题吧________________________1197________

Specialized Four-Digit Numbers Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5291 Accepted Submission(s): 3823 Problem Description Find and list all four-digit numbers in decimal notation that h