Y2K
Accounting Bug
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 9691 | Accepted: 4838 |
Description
Accounting for Computer Machinists (ACM) has
sufferred from the Y2K bug and lost some vital data for preparing annual report
for MS Inc.
All what they remember is that MS Inc. posted a surplus or a
deficit each month of 1999 and each month when MS Inc. posted surplus, the
amount of surplus was s and each month when MS Inc. posted deficit, the
deficit was d. They do not remember which or how many months posted surplus or
deficit. MS Inc., unlike other companies, posts their earnings for each
consecutive 5 months during a year. ACM knows that each of these 8 postings
reported a deficit but they do not know how much. The chief accountant is
almost sure that MS Inc. was about to post surplus for the entire year of 1999.
Almost but not quite.
Write a program, which decides whether MS Inc.
suffered a deficit during 1999, or if a surplus for 1999 was possible, what is
the maximum amount of surplus that they can post.
Input
Input is a sequence of lines, each containing two
positive integers s and d.
Output
For each line of input, output one line containing
either a single integer giving the amount of surplus for the entire year, or
output Deficit if it is impossible.
Sample Input
59 237
375 743
200000 849694
2500000 8000000
Sample Output
116
28
300612
Deficit
【题目来源】
【题目大意】
有一家公司,每5个月的营销额总是亏损的,现在给你两个数字,分别表示这个公司每个月可能的盈利额或亏损额,现在要你求这个公司满足每5个月总是亏损的
条件,一年下来这个公司可能盈利的最大值,若为负,则输出"Deficit".
【题目分析】
一个简单的贪心,只要我们在判断的时候首先考虑盈利额最大的,按照盈利额减少的情况来判断,这就满足了贪心的求解方法。
#include<cstdio>
int main()
{
int s,d,t;
while(~scanf("%d%d",&s,&d))
{
if(4*s-d<0) t=10*s-2*d;
else if(3*s-2*d<0) t=8*s-4*d;
else if(2*s-3*d<0) t=6*s-6*d;
else if(s-4*d<0) t=3*s-9*d;
else t=-1;
if(t<0)
printf("Deficit\n");
else printf("%d\n",t);
}
return 0;
}
贪心 --- Y2K Accounting Bug,布布扣,bubuko.com