HDU5233

Gunner II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1244    Accepted Submission(s): 486

Problem Description

Long long ago, there was a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i-th bird stands on the top of the i-th tree. The trees stand in straight line from left to the right. Every
tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the nearest bird which stands in the tree with height H will falls.

Jack will shot many times, he wants to know which bird will fall during each shot.

Input

There are multiple test cases (about 5), every case gives n, m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times.

In the second line, there are n numbers h[1],h[2],h[3],…,h[n] which describes the height of the trees.

In the third line, there are m numbers q[1],q[2],q[3],…,q[m] which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

All input items are integers.

1<=n,m<=100000(10^5)

1<=h[i],q[i]<=1000000000(10^9)

Output

For each q[i], output an integer in a single line indicates the id of bird Jack shots down. If Jack can’t shot any bird, just output -1.

The id starts from 1.

Sample Input

5 5

1 2 3 4 1

1 3 1 4 2

Sample Output

1

3

5

4

2

//这题主要思路就是利用一个结构体将高度与序号记录下来
//再利用一个数组将高度排序并且标记高度出现的顺序

#include <stdio.h>
#include <algorithm>
using namespace std;
int flag[100010],h[100010];

struct bird
{
    int n,num;
}p[100010];

bool cmp(const bird &a,const bird &b)
{
    return a.n!=b.n?a.n<b.n:a.num<b.num;
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++ )
        {
            scanf("%d",&p[i].n);
            p[i].num=i+1;
        }
        sort(p,p+n,cmp);
        for(int i=0;i<n;i++)
        {
            flag[i]=i;   //此时的flag数组是标记高度第一次出现的位置
            h[i]=p[i].n;
        }
        while(m--)
        {
            int x;
            scanf("%d",&x);
            int q=lower_bound(h,h+n,x)-h;  //查询到的也是第一次出现的次数
            if(h[flag[q]]!=x)
            {
                printf("-1\n");
                continue;
            }
            else
                printf("%d\n",p[flag[q]].num);
            flag[q]++;  //由于查询过一次了 所以递增到下一个高度
        }
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-10 20:39:52

HDU5233的相关文章

HDU5233——离散化——Gunner II

http://acm.hdu.edu.cn/showproblem.php?pid=5233 /* 用map和set进行离散化,离散化就是对于大数据进行重新编号 */ /************************************************ * Author :Powatr * Created Time :2015-8-12 18:27:42 * File Name :HDU5233 Gunner II.cpp *****************************

HDU5233 Gunner II 离散化的各种方法

题目链接: HDU5233 题意: n棵树依次排好,每棵树都有一个高度,树的顶端有一只鸟. 猎人会打M枪,每一枪都能从高度为X的树上打下一只鸟,问每一枪打下的鸟是从  编号多少的树 上掉下来的 题解思路: 因为树的高度能达到(10^9)  而树的数量最多10^5  所以离散化   将所有高度为X的树离散化为 高度为第X高的树 有多种方法. 1  stl去重+set版: #include<iostream> #include<cstdio> #include<cstring&g

hdu5233 Gunner II

Problem Description Long long ago, there was a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i-th bird stands on the top of the i-th tree. The trees stand in straight line

[STL]hdu5233

题意: 给出一组数据n个数,m个询问q,问最近的q的输入下标是多少? 分析: 首先数据量比较大100000,查询的话肯定要用些技巧,刚开始想的是二分查询,用set,可是不知道set里放数据结构struct如何按照关键字lower_bound().后来看了官方题解,先把数据离散话,然后利用set[]来存储下标.那么输出的时候就直接输出begin,删除也可以erase(). 这里有个trick,刚开始用的vector q[],然后T...后来换set就A了,原来vector<>的push_back