PAT 甲级1002 A+B for Polynomials (25)

1002. A+B for Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

题意:合并多项式思路:简单的水题,不过注意细节,譬如合并之后某一项的系数为0,那么这一项不作考虑,需要去除。若合并之后多项式值为0,直接输出0就行了(题目貌似也没特别说明这个情况该输出什么,坑)。AC代码:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<set>
#include<queue>
#include<cmath>
#include<vector>
#include<bitset>
#include<string>
using namespace std;
const int N_MAX = 10+5;
struct poly {
  int exp;
  double coe;
  bool operator <(const poly&b) const{
    return exp < b.exp;
  }
};
poly P1[N_MAX],P2[N_MAX],P[N_MAX];
int k1, k2;
int main() {
  scanf("%d",&k1);
  for (int i = 0; i < k1;i++) {
    scanf("%d%lf",&P1[i].exp,&P1[i].coe);
  }
  scanf("%d",&k2);
  for (int i = 0; i < k2;i++) {
    scanf("%d%lf",&P2[i].exp,&P2[i].coe);
  }

  sort(P1, P1 + k1);
  sort(P2, P2 + k2);

  int t1 = 0, t2 = 0,t=0;
  while (t1<k1&&t2<k2) {
    double tmp=1;//不为0即可
    if (P1[t1].exp == P2[t2].exp) {
       tmp= P1[t1].coe + P2[t2].coe;
      if (tmp) {//系数不为0,则要算进去
        P[t].exp = P1[t1].exp;
        P[t].coe = P1[t1].coe + P2[t2].coe;
      }
      t1++;
      t2++;
    }
    else if (P1[t1].exp<P2[t2].exp) {//那个指数小用哪个
      P[t].exp = P1[t1].exp;
      P[t].coe = P1[t1].coe;
      t1++;
    }
    else if (P1[t1].exp>P2[t2].exp) {//那个指数小用哪个
      P[t].exp = P2[t2].exp;
      P[t].coe = P2[t2].coe;
      t2++;
    }
    if(tmp)t++;
  }

  while (t1 < k1) {
    P[t].exp = P1[t1].exp;
    P[t].coe = P1[t1].coe;
    t1++;
    t++;
  }
  while (t2 < k2) {
    P[t].exp = P2[t2].exp;
    P[t].coe = P2[t2].coe;
    t2++;
    t++;
  }

  if (t) {
    printf("%d ", t);
    for (int i = 0; i < t; i++) {
      printf("%d %.1f%c", P[t - i - 1].exp, P[t - i - 1].coe, i + 1 == t ? ‘\n‘ : ‘ ‘);
    }
  }
  else printf("%d\n",t);

}
时间: 2024-11-05 09:40:04

PAT 甲级1002 A+B for Polynomials (25)的相关文章

PAT甲级1002.A+B for Polynomials (25)

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805526272000000 解题思路: 由于是求两个多项式之和,并且多项式的指数是从大到小进行排列的,相加时有合并和消除的操作 因此选用了较为灵活的链表结构,将输入的第一个多项式使用链表存储起来,将第二个多项式的项依次输入, 对于加数每个项和被加数的每项的指数进行比较,如果大于其指数则插入在其前面,如果小于其指数,则比较 被加数的后一项,如果等于其指数,则将两

甲级1002 A+B for Polynomials (25)

题目描述: This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is

PAT Advanced 1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N?1?? a?N?1???? N?2?? a?N?2?

PAT:1002. A+B for Polynomials (25) 部分错误

#include<stdio.h> #include<stdlib.h> #include<string.h> //[warning]double 输入%lf,输出%f struct arr { int tag; double data; }arr[1005]; int main() { memset(arr,0,sizeof(arr)); int t1,t2,tmp,maxI=0; //maxI记录最多多少项 double tdata; for(int I=0 ; I

1002. A+B for Polynomials (25)——PAT (Advanced Level) Practise

题目信息: 1002. A+B for Polynomials (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lin

1002. A+B for Polynomials (25)

题目: 1002. A+B for Polynomials (25) #include<stdio.h> #define N 1000 int main() { double poly[N+1]={0}; int n,m,i; int exp; double coef; scanf("%d",&n); m=n; for(i=0;i<n;i++) { scanf(" %d %lf",&exp,&coef); poly[exp]

PAT甲级1002 链表实现方法

题目: 1002. A+B for Polynomials (25) 时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lines

1002 A+B for Polynomials (25)(25 point(s))

problem 1002 A+B for Polynomials (25)(25 point(s)) This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polyno

PAT (Advanced Level) 1002. A+B for Polynomials (25)

为0的不要输出. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> using namespace std; double a[1500],b[1500]; int k; int main() { for(int i=0;i<=1000;i++) a[i]=b[i]=0; int Max=-1; scanf(&q