hdu 2028 Lowest Common Multiple Plus

Problem Description

求n个数的最小公倍数。

Input

输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。

Output

为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。

Sample Input

2 4 6
3 2 5 7

Sample Output

12
70

思路:水题。题目要求32位整数,所以使用unsigned int。

代码:

#include <iostream>
#include <string.h>
#include <stack>

using namespace std;

unsigned int gcd(unsigned int a, unsigned int b)
{
    if (a == b)
    {
        return a;
    }
    if (a < b)
    {
        swap(a, b);
    }
    while (b != 0)
    {
        a %= b;
        swap(a, b);
    }
    return a;
}

int main()
{
    stack<unsigned int> s;
    int n;
    while (scanf("%d", &n) != EOF)
    {
        while (!s.empty())
        {
            s.pop();
        }
        while (n--)
        {
            unsigned int t;
            scanf("%d", &t);
            s.push(t);
        }
        while (s.size() > 1)
        {
            unsigned int a = s.top();
            s.pop();
            unsigned int b = s.top();
            s.pop();
            s.push(a*b / gcd(a, b));
        }
        printf("%d\n", s.top());
    }

    system("pause");
    return 0;
}
时间: 2024-10-05 10:06:34

hdu 2028 Lowest Common Multiple Plus的相关文章

hdu 2028 Lowest Common Multiple Plus(最小公倍数)

Lowest Common Multiple Plus Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 34980    Accepted Submission(s): 14272 Problem Description 求n个数的最小公倍数. Input 输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数. Out

杭电 HDU ACM 2028 Lowest Common Multiple Plus

Lowest Common Multiple Plus Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 39183    Accepted Submission(s): 16144 Problem Description 求n个数的最小公倍数. Input 输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数. Ou

HDOJ 2028 Lowest Common Multiple Plus

Lowest Common Multiple Plus Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 33702    Accepted Submission(s): 13766 Problem Description 求n个数的最小公倍数. Input 输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数. Ou

#2028 Lowest Common Multiple Plus

http://acm.hdu.edu.cn/showproblem.php?pid=2028 应该是比较简单的一道题啊...求输入的数的最小公倍数. 先用百度来的(老师教的已经不知道跑哪去了)辗转相除法求出两数的最大公因数,再将两数相乘并除以最大公因数即得到最小公倍数. 一开始我写的代码如下 1 #include<stdio.h> 2 3 int gcd(int a, int b) 4 { 5 if (b == 0) 6 { 7 return a; 8 } 9 return gcd(b, a%

杭电 2028 ( Lowest Common Multiple Plus )

链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=2028 题目要求:就是求最大公倍数,我百度了一下,最好实现的算法就是: 公式法 由于两个数的乘积等于这两个数的最大公约数与最小公倍数的积.即(a,b)×[a,b]=a×b.所以,求两个数的最小公倍数,就可以先求出它们的最大公约数,然后用上述公式求出它们的最小公倍数. 例如,求[18,20],即得[18,20]=18×20÷(18,20)=18×20÷2=180.求几个自然数的最小公倍数,可以先

Lowest Common Multiple Plus(杭电2028)

/*Lowest Common Multiple Plus Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 33241    Accepted Submission(s): 13578 Problem Description 求n个数的最小公倍数. Input 输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数.

HDU 1019 Least Common Multiple (最小公倍数)

Least Common Multiple Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 30285    Accepted Submission(s): 11455 Problem Description The least common multiple (LCM) of a set of positive integers is

HDU 1019 Least Common Multiple 数学题解

求一组数据的最小公倍数. 先求公约数在求公倍数,利用公倍数,连续求所有数的公倍数就可以了. #include <stdio.h> int GCD(int a, int b) { return b? GCD(b, a%b) : a; } inline int LCM(int a, int b) { return a / GCD(a, b) * b; } int main() { int T, m, a, b; scanf("%d", &T); while (T--)

HDU2028 Lowest Common Multiple Plus【stein算法】【水题】

Lowest Common Multiple Plus Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 36800    Accepted Submission(s): 15116 Problem Description 求n个数的最小公倍数. Input 输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数. Ou