【POJ 2891】Strange Way to Express Integers(扩展欧几里得)

【POJ 2891】Strange Way to Express Integers(扩展欧几里得)

Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 12934   Accepted: 4130

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1, a2,
…, ak. For some non-negative m, divide it by every
ai (1 ≤ ik) to find the remainder ri. If
a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai,
ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find
m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers ai,
    ri (1 ≤ ik).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output
-1.

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

Source

POJ Monthly--2006.07.30, Static

对于ax ≡ b(mod m) 很熟练的一套扩欧板子拍上去,。

这题有点麻烦,给了n对数ai ri 让求出一个数x 对于n组数都存在mi使 x ≡ ai*mi+ri 找出最小的x 找不出输出-1

首先考虑n = 1的情况 x = a*m+r(m = 1,2,3......)

对于n = 2时,即要求上面的x同时要满足x = a1*m1+r1

从第一个式子得出 x = a0+r0

这样对于第二个式子,其实也就是找一个c满足 x+c*a0 ≡ r1(mod a2)

以此类推,第三个式子,也就是找对于上面求出来的x(实则为x+c*a0) 找一个c满足 x+c*LCM(a0,a1) ≡ r2(mod a2)

这样按顺序递推着用扩欧即可一步步求得最终答案。

需要注意的是LCM(a0,a1) 其实就是a0*a1/gcd(a0,a1) 但是直接乘可能爆 先除再乘 a0/gcd(a0,a1)*a1

其次,每一步求扩欧的过程中其实就能得到gcd

其次次。WA了好久,最后发现对于答案,最重要对LCM(a0,a1,a2,...,an-)取余。。谁让找的是最小值。。。。

代码如下:

1#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e9+7;
const double eps = 1e-8;

LL extend_gcd(LL a,LL b,LL &x,LL &y)
{
	if(a == 0 && b == 0) return -1;
	if(!b)
	{
		x = 1;
		y = 0;
		return a;
	}
	LL d = extend_gcd(b,a%b,y,x);
	y -= a/b*x;
	return d;
}

LL d;
LL gcd(LL a,LL m,LL c)
{
	LL x,y;
	d = extend_gcd(a,m,x,y);
	if(c%d) return -1;
	x = ((x%m)*(c/d))%m;
	return (x%(m/d)+m/d)%(m/d);
}

int main()
{
	//fread();
	//fwrite();

	int n;
	LL a,r;
	while(~scanf("%d",&n))
	{
		LL tmp = 1;
		LL ans = 0;
		LL c;
		bool f = 1;
		scanf("%lld%lld",&a,&r);
		tmp = a;
		ans = a+r;
		n--;
		while(n--)
		{
			scanf("%lld%lld",&a,&r);
			//if(r >= a) f = 0;
			if(!f) continue;
			c = gcd(tmp,a,((r-ans)%a+a)%a);
		//	printf("%lld ans:%lld LCM:%lld mod:%lld =%lld\n",d,ans,tmp,a,((r-ans)%a+a)%a);
			if(c == -1) f = 0;
			ans += tmp*c;
			tmp = tmp/d*a;
			ans %= tmp;
		}
		if(!f) puts("-1");
		else printf("%lld\n",ans);
	}

	return 0;
}

时间: 2025-01-05 23:11:33

【POJ 2891】Strange Way to Express Integers(扩展欧几里得)的相关文章

poj 2891 Strange Way to Express Integers (扩展gcd)

题目链接 题意:给k对数,每对ai, ri.求一个最小的m值,令m%ai = ri; 分析:由于ai并不是两两互质的, 所以不能用中国剩余定理. 只能两个两个的求. a1*x+r1=m=a2*y+r2联立得:a1*x-a2*y=r2-r1;设r=r2-r2; 互质的模线性方程组m=r[i](mod a[i]).两个方程可以合并为一个,新的a1为lcm(a1,a2), 新的r为关于当前两个方程的解m,然后再和下一个方程合并--.(r2-r1)不能被gcd(a1,a2)整除时无解. 怎么推出的看了好

POJ.2891.Strange Way to Express Integers(扩展CRT)

题目链接 扩展中国剩余定理:1(直观的).2(详细证明). #include <cstdio> #include <cctype> #define gc() getchar() typedef long long LL; const int N=1e6+5; LL n,m[N],r[N]; inline LL read() { LL now=0,f=1;register char c=gc(); for(;!isdigit(c);c=gc()) if(c=='-') f=-1; f

poj 2891 Strange Way to Express Integers

http://poj.org/problem?id=2891 这道题的题意是:给你多个模性方程组:m mod ai=ri 求最小的m: 中国剩余定理 1 #include <cstdio> 2 #include <cstring> 3 #include <algorithm> 4 #define ll long long 5 using namespace std; 6 7 ll gcd(ll a,ll b,ll &x,ll &y) 8 { 9 if(!

poj 2891 Strange Way to Express Integers (非互质的中国剩余定理)

Strange Way to Express Integers Time Limit: 1000MS   Memory Limit: 131072K Total Submissions: 9472   Accepted: 2873 Description Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is

poj——2891 Strange Way to Express Integers

Strange Way to Express Integers Time Limit: 1000MS   Memory Limit: 131072K Total Submissions: 16839   Accepted: 5625 Description Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is

poj 2891 Strange Way to Express Integers (解模线性方程组)

链接:poj 2891 题意:有一个数x,给定k组ai和ri,使得x%ai=ri 求x最小为多少 分析:求解模线性方程组 x = a1(mod m1) x = a2(mod m2) x = a3(mod m3) 先求解方程组前两项. x=m1*k1+a1=m2*k2+a2 -> m1*k1+m2*(-k2)=a2-a1 这个方程可以通过欧几里得求解出最小正整数的k1 则x=m1*k1+a1 显然x为两个方程的最小正整数解. 则这两个方程的通解为 X=x+k*LCM(m1,m2) -> X=x(

POJ 2891 Strange Way to Express Integers【扩展欧几里德】【模线性方程组】

求解方程组 X%m1=r1 X%m2=r2 .... X%mn=rn 首先看下两个式子的情况 X%m1=r1 X%m2=r2 联立可得 m1*x+m2*y=r2-r1 用ex_gcd求得一个特解x' 得到X=x'*m1+r2 X的通解X'=X+k*LCM(m1,m2) 上式可化为:X'%LCM(m1,m2)=X 到此即完成了两个式子的合并,再将此式子与后边的式子合并,最后的得到的X'即为答案的通解,求最小整数解即可. #include<stdio.h> #include<string.h

POJ 2891 Strange Way to Express Integers 中国剩余定理MOD不互质数字方法

http://poj.org/problem?id=2891 711323 97935537 475421538 1090116118 2032082 120922929 951016541 15898 418373 161478614 149488440 1748022751 21618619576 810918992 241779667 1772616743 1953316358 125248280 2273149397 3849022001 2509433771 3885219405 35

poj 2891 Strange Way to Express Integers(中国剩余定理)

http://poj.org/problem?id=2891 题意:求解一个数x使得 x%8 = 7,x%11 = 9; 若x存在,输出最小整数解.否则输出-1: ps: 思路:这不是简单的中国剩余定理问题,由于输入的ai不一定两两互质,而中国剩余定理的条件是除数两两互质. 这是一般的模线性方程组,对于 X mod m1=r1 X mod m2=r2 ... ... ... X mod mn=rn 首先,我们看两个式子的情况 X mod m1=r1-----------------------(

poj 2891 Strange Way to Express Integers 2012-09-05

http://poj.org/problem?id=2891 解线性模方程组. 比较坑爹,数据比较大,很容易溢出. 1 Program poj2891; 2 3 var m:int64; 4 5 a,r:array[1..30000000]of int64; 6 7 ans,x,y,lcm:int64; 8 9 10 Procedure init; 11 12 var i,j:longint; 13 14 begin 15 16 m:=0; 17 18 readln(m); 19 20 for