POJ2449 Remmarguts' Date 【k短路】

Remmarguts‘ Date

Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 21064   Accepted: 5736

Description

"Good man never makes girls wait or breaks an appointment!" said the mandarin duck father. Softly touching his little ducks‘ head, he told them a story.

"Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One day their neighboring country sent them Princess Uyuw on a diplomatic mission."

"Erenow, the princess sent Remmarguts a letter, informing him that she would come to the hall and hold commercial talks with UDF if and only if the prince go and meet her via the K-th shortest path. (in fact, Uyuw does not want to come at all)"

Being interested in the trade development and such a lovely girl, Prince Remmarguts really became enamored. He needs you - the prime minister‘s help!

DETAILS: UDF‘s capital consists of N stations. The hall is numbered S, while the station numbered T denotes prince‘ current place. M muddy directed sideways connect some of the stations. Remmarguts‘ path to welcome the princess might include the same station
twice or more than twice, even it is the station with number S or T. Different paths with same length will be considered disparate.

Input

The first line contains two integer numbers N and M (1 <= N <= 1000, 0 <= M <= 100000). Stations are numbered from 1 to N. Each of the following M lines contains three integer numbers A, B and T (1 <= A, B <= N, 1 <= T <= 100). It shows that there is a directed
sideway from A-th station to B-th station with time T.

The last line consists of three integer numbers S, T and K (1 <= S, T <= N, 1 <= K <= 1000).

Output

A single line consisting of a single integer number: the length (time required) to welcome Princess Uyuw using the K-th shortest path. If K-th shortest path does not exist, you should output "-1" (without quotes) instead.

Sample Input

2 2
1 2 5
2 1 4
1 2 2

Sample Output

14

第一次做k短路的题,大致总结下这个算法:

1、首先将有向图的每条边倒置构成一个新图,然后求终点到每个顶点的最短距离(SPFA或Dijkstra都行);

2、定义结构体类型,变量包括链接的终点,已走路径长度g和估价函数值f,f在优先队列的队首开始升序排列;

3、定义cnt,表示当前已到达终点的次数,若cnt==k,算法完成,另外若起点跟终点重合的话应该++k。

#include <stdio.h>
#include <string.h>
#include <queue>
#define maxn 1002
#define maxm 100002
#define inf 0x7fffffff
using std::priority_queue;
using std::queue;

int head[maxn], Rhead[maxn]; //Rhead[] save the reverse Graph
struct Node{
	int to, dist, next;
} E[maxm], RE[maxm];
int dist[maxn]; //reverse
struct  Node2{
	int to, f, g; //估价函数和已走路径长度
	bool operator<(const Node2& a) const{
		return a.f < f;
	}
};
bool vis[maxn];

void addEdge(int u, int v, int d, int i)
{
	E[i].to = v; E[i].dist = d;
	E[i].next = head[u]; head[u] = i;
	RE[i].to = u; RE[i].dist = d;
	RE[i].next = Rhead[v]; Rhead[v] = i;
}

void SPFA(int s, int n, int dist[], int head[], Node E[])
{
	int i, u, v, tmp;
	for(i = 0; i <= n; ++i){
		dist[i] = inf; vis[i] = false;
	}
	u = s; vis[u] = true; dist[u] = 0;
	queue<int> Q; Q.push(s);
	while(!Q.empty()){
		u = Q.front(); Q.pop(); vis[u] = 0;
		for(i = head[u]; i != -1; i = E[i].next){
			v = E[i].to;
			tmp = dist[u] + E[i].dist;
			if(tmp < dist[v]){
				dist[v] = tmp;
				if(!vis[v]){
					vis[v] = 1;
					Q.push(v);
				}
			}
		}
	}
}

int A_star(int s, int t, int k, int n)
{
	priority_queue<Node2> Q;
	int i, u, v, cnt = 0;
	Node2 tmp, now;
	if(s == t) ++k; //起点跟终点相同
	now.to = s; now.g = 0;
	now.f = now.g + dist[now.to];
	Q.push(now);
	while(!Q.empty()){
		now = Q.top(); Q.pop();
		if(now.to == t && ++cnt == k)
			return now.g;
		for(i = head[now.to]; i != -1; i = E[i].next){
			tmp.to = E[i].to; tmp.g = now.g + E[i].dist;
			tmp.f = tmp.g + dist[tmp.to]; Q.push(tmp);
		}
	}
	return -1;
}

int main()
{
	int n, m, s, t, k, u, v, d, i;
	while(scanf("%d%d", &n, &m) == 2){
		for(i = 0; i <= n; ++i)
			head[i] = Rhead[i] = -1;
		for(i = 0; i < m; ++i){
			scanf("%d%d%d", &u, &v, &d);
			addEdge(u, v, d, i);
		}
		scanf("%d%d%d", &s, &t, &k);
		//SPFA(s, n, dist, head, E);
		SPFA(t, n, dist, Rhead, RE);
		printf("%d\n", A_star(s, t, k, n));
	}

	return 0;
}

POJ2449 Remmarguts' Date 【k短路】

时间: 2024-11-10 07:36:59

POJ2449 Remmarguts' Date 【k短路】的相关文章

[poj2449]Remmarguts&#39; Date(K短路模板题,A*算法)

解题关键:k短路模板题,A*算法解决. #include<cstdio> #include<cstring> #include<algorithm> #include<cstdlib> #include<iostream> #include<cmath> #include<queue> using namespace std; typedef long long ll; const int N=1e3+10; const

POJ 2449 Remmarguts&#39; Date(k短路模板)

link:https://vjudge.net/problem/POJ-2449 前面输入与大多最短路题相同 最后一行输入s,t,k 求从s到t的第K短路 #include <iostream> #include <cstring> #include <queue> using namespace std; const int MAXN=1010; struct node { int p,g,h; bool operator < (node a) const {

poj 2449 Remmarguts&#39; Date k短路

/*poj 2449 k短路 A* 估价函数是 s到i的距离+i到t的距离 */ #include<cstdio> #include<queue> #include<vector> #define inf 1e7 #define maxn 100010 using namespace std; int n,m,S,T,K,num1,num2,head1[maxn],head2[maxn],dis[maxn]; int q[maxn],hea,tai,f[maxn],cn

poj2449 Remmarguts&#39; Date,第K短路

点击打开链接 SPFA  + A* #include <cstdio> #include <queue> #include <cstring> #include <algorithm> using namespace std; struct node { int v, dis, f, next; friend bool operator <(node a, node b){ return a.f>b.f; } }; const int INF =

POJ2449 Remmarguts&#39; Date 第K短路

POJ2449 比较裸的K短路问题 K短路听起来高大上 实际思路并不复杂 首先对终点t到其他所有点求最短路 即为dist[] 然后由起点s 根据当前走过的距离+dist[]进行A*搜索 第k次到达t即为第K短路 代码也很简单 //数组开的不够 不一定是运行时错误! 可能也会WA #include<iostream> #include<cstdio> #include<cstdlib> #include<cstring> #include<cmath&g

POJ2449 Remmarguts&#39; Date

题目链接:http://poj.org/problem?id=2449 题目描述: 其实题目的大意就是求 第k短路, 存在就输出, 不存在就输出-1. 注意当起点和终点一致的时候,需要k++, 因为在OUTPUT时提到the length (time required) to welcome Princess Uyuw using the K-th shortest path. 可以看出是需要时间的,并且并没有描述相同点直接的时间为0这一条件,因此在计算路径的时候,为0的路径是不能够算到里面的:

[poj2449]Remmarguts&#39; Date(spfa+A*)

转载请注明出处: http://www.cnblogs.com/fraud/          ——by fraud Remmarguts' Date Time Limit: 4000MS   Memory Limit: 65536K Total Submissions: 21855   Accepted: 5958 Description "Good man never makes girls wait or breaks an appointment!" said the mand

POJ 2449Remmarguts&#39; Date K短路模板 A*+SPFA

太水了我不想说了,模板在这里 14312K 313MS 1 #include<queue> 2 #include<cstdio> 3 #include<cstring> 4 #include<algorithm> 5 using namespace std; 6 int v[100010],v2[100010],c[100010],c2[100010],s,t,k,duin; 7 int n,m,point[1010],next[100010],cnt=0,

poj2449:第k短路问题

Description "Good man never makes girls wait or breaks an appointment!" said the mandarin duck father. Softly touching his little ducks' head, he told them a story. "Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One