注意n的值很大的时候不能使用两层嵌套算法,这样执行时间将会很长
时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print "None" instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
来源: <http://www.patest.cn/contests/pat-a-practise/1041>
#pragma warning(disable:4996)
#include <stdio.h>
using namespace std;
int main(void) {
int n = 0;
int num[100001] = { 0 };
int num2[100001] = { 0 };
int i = 0, j = 0;
int flag = 0,count=0;
int temp = 0;
scanf("%d", &n);
for (i = 0; i < n; i++) {
scanf("%d", &temp);
num[i] = temp;
num2[temp]++;
}
for (i = 0; i < n; i++) {
if (num2[num[i]] == 1) {
printf("%d", num[i]);
flag = 1;
break;
}
}
if(flag==0)
printf("None");
return 0;
}