NYOJ 66 分数拆分【数学题】

题目链接

#include<stdio.h>
int main()
{
	int i,s,k,x;
	scanf("%d",&s);
	while(s--)
	{
		scanf("%d",&k);
		for(i=k+1;i<=2*k;i++)
		{
			x=(k*i)/(i-k);
			if(k == i*x/(x+i))
			printf("1/%d=1/%d+1/%d\n",k,x,i);
		}
	}
	return 0;
} 
时间: 2024-10-14 20:43:11

NYOJ 66 分数拆分【数学题】的相关文章

NYOJ 66 分数拆分

分数拆分 时间限制:3000 ms  |  内存限制:65535 KB 难度:1 描述 现在输入一个正整数k,找到所有的正整数x>=y,使得1/k=1/x+1/y. 输入 第一行输入一个整数n,代表有n组测试数据.接下来n行每行输入一个正整数k 输出 按顺序输出对应每行的k找到所有满足条件1/k=1/x+1/y的组合 样例输入 2 2 12 样例输出 1/2=1/6+1/3 1/2=1/4+1/4 1/12=1/156+1/13 1/12=1/84+1/14 1/12=1/60+1/15 1/1

rwkj 1394 分数拆分

#include<stdio.h> main(){ int k,x,y,n; scanf("%d",&n); while(n--) { scanf("%d",&k); for(x=k+1;x<=2*k;x++) for(y=2*k;;y++) { if(x*y>k*(x+y))break; if(x*y==k*(x+y)) printf("1/%d=1/%d+1/%d\n",k,y,x); } }} #in

7_3 分数拆分(UVa10976)&lt;缩小枚举范围&gt;

每一个(k>0)这种形式的分数我们总是可以找到2个正整数x和y(x >= y),使得:现在我们的问题是:给你k,请你写一个程序找出所有的x和y.Input输入含有多组测试数据(不会超过100组).每组测试数据一列,有1个正整数k(0 < k <= 10000).Output对每一组测试数据输出一列,输出共有多少组(x,y),然后输出这些解答.输出格式请参考Sample Output. Sample Input212 Sample Output 2 1/2 = 1/6 + 1/3 1

NYOJ 111 分数加减法

分数加减法 时间限制:3000 ms  |  内存限制:65535 KB 难度:2 描述 编写一个C程序,实现两个分数的加减法 输入 输入包含多行数据 每行数据是一个字符串,格式是"a/boc/d". 其中a, b, c, d是一个0-9的整数.o是运算符"+"或者"-". 数据以EOF结束 输入数据保证合法 输出 对于输入数据的每一行输出两个分数的运算结果. 注意结果应符合书写习惯,没有多余的符号.分子.分母,并且化简至最简分数 样例输入 1/

分数拆分

It is easy to see that for every fraction in the form(k > 0), we can always find two positive integers x and y,x ≥ y, such that: Now our question is: can you write a program that counts how many such pairs of x and y there are for any given k? Input

POJ 1003 Hangover&amp;&amp;NYOJ 156 Hangover【数学题】

计算1+1/2+1/3+++1/n Hangover Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 104558   Accepted: 50926 Description How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a car

例题7-3 分数拆分 UVa10976

1.题目描述:点击打开链接 2.解题思路:根据题目描述,可以解出来y的范围是1≤y≤2k.进而可以求出x=ky/(y-n).注意x要大于0且是整数. 3.代码: #define _CRT_SECURE_NO_WARNINGS #include<iostream> #include<algorithm> #include<string> #include<sstream> #include<set> #include<vector> #

NYOJ 333 mdd的烦恼&amp;&amp;NYOJ 291 LK的数学题

题目链接:http://acm.nyist.net/JudgeOnline/problem.php?pid=291   http://acm.nyist.net/JudgeOnline/problem.php?pid=333 思路:欧拉函数的应用,详解见这里:http://blog.csdn.net/once_hnu/article/details/6302868 好文章 直接贴代码: #include <iostream> #include <cstring> using nam

分数拆分(刘汝佳紫书P183)

枚举,由已知条件推得y大于k,小于等于2K AC代码: #include"iostream"#include"cstring"using namespace std;const int maxn=20002;int a[maxn];int b[maxn];int main(){ int i,y; int x,f,k; while(cin>>k&&k) { memset(a,0,sizeof(a)); memset(b,0,sizeof(b