PAT 甲级 1081 Rational Sum (数据不严谨 点名批评)

https://pintia.cn/problem-sets/994805342720868352/problems/994805386161274880

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

代码:
#include <bits/stdc++.h>
using namespace std;

long long a[111], b[111];
long long sum, m;

long long gcd(long long x, long long y) {
    long long z = x % y;
    while(z) {
        x = y;
        y = z;
        z = x % y;
    }
    return y;
}

long long ad(long long x, long long y) {
    if(x > y)
        swap(x, y);
    if(y % x == 0)
        return y;
    else
        return x * y / gcd(x, y);
}

void display(long long p, long long q) {
    if(q == 0 || p == 0)
        printf("0\n");
    else {
        bool flag = true;
        if(p < 0) {
            flag = false;
            printf("-");
            p = abs(p);
        }

        if(p / q != 0) {
            if(p % q == 0)
                printf("%lld\n", p / q);
            else {
                long long mm = p / q;
                printf("%lld ", mm);
                if(!flag) cout << "-";
                printf("%lld/%lld", (p - mm * q) / gcd(p - mm * q, q), q / gcd(p - mm * q, q));
            }
        } else {
            printf("%lld/%lld", p / gcd(p, q), q / gcd(p, q));
          }

    }
}

void add(long long x, long long y) {
    //  sum / m + x / y
    // = (sum * y + m * x) / (x * y);
    long long xx = sum * y + m * x;
    long long yy = m * y;
    long long g = gcd(abs(xx), abs(yy));
    xx /= g;
    yy /= g;
    sum = xx;
    m = yy;
}

int main() {

    int N;
    scanf("%d", &N);
    for(int i = 1; i <= N; i ++)
        scanf("%lld/%lld", &a[i], &b[i]);

    if(N == 0) {
        printf("0\n");
        return 0;
    }
    if(N ==1) {
        display(a[1], b[1]);
        return 0;
    }

/*
    long long m = ad(b[1], b[2]);
    for(int i = 3; i <= N; i ++) {
        m = ad(m, b[i]);
    }

    long long sum = 0;
    for(int i = 1; i <= N; i ++) {
        sum += a[i] * m / b[i];
    }
*/
    sum = a[1];
    m = b[1];
    for(int i = 2; i <= N; i ++) {
        add(a[i], b[i]);
    }

    if(m < 0) {
        sum = -sum;
        m = -m;
    }
    display(sum, m);

    return 0;
}

  

原文地址:https://www.cnblogs.com/zlrrrr/p/9446173.html

时间: 2024-08-01 21:01:56

PAT 甲级 1081 Rational Sum (数据不严谨 点名批评)的相关文章

PAT:1081. Rational Sum (20) AC(类似math.h中的sqrt(1.0*n),algorithm的abs()用于取绝对值)

#include<stdio.h> #include<algorithm> using namespace std; typedef long long ll; //[skill]重命名 struct num { ll zi,mu; //分子分母 }; ll gcd(ll a,ll b) //求最大公约数 { return b==0 ? a:gcd(b,a%b); } num yuefen(num a) //分数约分 { //printf("%lld/%lld.约分为:&

1081. Rational Sum (20)【模拟】——PAT (Advanced Level) Practise

题目信息 1081. Rational Sum (20) 时间限制400 ms 内存限制65536 kB 代码长度限制16000 B Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum. Input Specification: Each input file contains one test case. Each case star

A.1081 Rational Sum (20)

1081 Rational Sum (20)(20 分) Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum. Input Specification: Each input file contains one test case. Each case starts with a positive integer N (<=100

1081 Rational Sum (20 分)分数加法

1081 Rational Sum (20 分) Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum. Input Specification: Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in

【PAT甲级】1081 Rational Sum (20 分)

题意: 输入一个正整数N(<=100),接着输入N个由两个整数和一个/组成的分数.输出N个分数的和. 代码: #define HAVE_STRUCT_TIMESPEC#include<bits/stdc++.h>using namespace std;int a[107],b[107];int main(){ ios::sync_with_stdio(false); cin.tie(NULL); cout.tie(NULL); int n; cin>>n; for(int i

[PAT] 1081 Rational Sum (20 分)Java

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum. Input Specification: Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational

PAT甲题题解-1081. Rational Sum (20)-模拟分数计算

模拟计算一些分数的和,结果以带分数的形式输出注意一些细节即可 #include <iostream> #include <cstdio> #include <algorithm> #include <cstring> #include <cmath> using namespace std; /* 模拟计算一些分数的和,结果以带分数的形式输出 注意一些细节即可 */ const int maxn=105; const int maxv=50000

PAT (Advanced Level) 1081. Rational Sum (20)

简单模拟题. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<stack> #include<queue> #include<string> #include<algorithm> using namespace std; struct FenShu { long l

PAT 1081. Rational Sum

#include <cstdio> #include <cstdlib> using namespace std; long long gcd(long long a, long long b) { long long r; while (r = (a % b)) { a = b; b = r; } return b; } int main() { int N; scanf("%d", &N); long long sa = 0, sb = 1, a,