hdu3549 Flow Problem(裸最大流)

Flow Problem

Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

 2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1 

Sample Output

 Case 1: 1

Case 2: 2

题目比较简单,入门级最大流问题。

#include<cstdio>
#include<algorithm>
#include<queue>
#include<string.h>
#define MAXN 21
#define INF 1<<28

using namespace std;

int cap[MAXN][MAXN], pre[MAXN], vis[MAXN], maxflow[MAXN];
int Maxflow;
int n, m, i, j;

void init()
{
    int x, y, z;
    memset(cap, 0, sizeof(cap));
    memset(pre, 0, sizeof(pre));

scanf("%d%d", &n, &m);
    for(i=1; i<=m; i++)
    {
        scanf("%d%d%d", &x, &y, &z);
        cap[x][y] += z;//重边
    }
}

int min(int a, int b)
{
    return a>b?b:a;
}

int main()
{
    int T, u, k=1;
    scanf("%d", &T);
    while(T--)
    {

init();
        queue<int>q;
        Maxflow = 0;

while(1)
       {
        memset(maxflow, 0, sizeof(maxflow));
        memset(vis, 0, sizeof(vis));
        maxflow[1] = INF;

q.push(1);
        while(!q.empty())
        {
             u = q.front();
             q.pop();
             for(int v=1; v<=n; v++)
             {
                 if(!vis[v] && cap[u][v]>0)
                    {
                        vis[v] = 1;
                        pre[v] = u;
                        q.push(v);
                        maxflow[v] = maxflow[u]<cap[u][v]?maxflow[u]:cap[u][v];
                    }
             }
        }
        if(maxflow[n]==0) break;

for(int i=n; i!=1; i=pre[i])
        {
            cap[pre[i]][i]-=maxflow[n];
            cap[i][pre[i]]+=maxflow[n];
        }

Maxflow += maxflow[n];
    }
      printf("Case %d: %d\n", k++, Maxflow);
    }
     return 0;
}

hdu3549 Flow Problem(裸最大流),布布扣,bubuko.com

时间: 2024-08-07 04:33:08

hdu3549 Flow Problem(裸最大流)的相关文章

HDU3549 Flow Problem 【最大流】

Flow Problem Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others) Total Submission(s): 8387    Accepted Submission(s): 3908 Problem Description Network flow is a well-known difficult problem for ACMers. Given a graph, y

HDU3549 Flow Problem【最大流】【Edmond-Karp】

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=3549 题目大意: 给你一个N个节点M条边的加权有向图,源点为1,汇点为N,求此图的最大流. 思路: 这道题就是网络流求最大流的裸题.直接用Edmond-Karp算法来做就可以了. AC代码: #include<iostream> #include<algorithm> #include<cstdio> #include<cstring> #include<

hdu 3549 Flow Problem(最大流模板题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3549 Problem Description Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph. Input The first line of input

hdu 3549 Flow Problem (网络最大流)

Flow Problem Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)Total Submission(s): 6674    Accepted Submission(s): 3112 Problem Description Network flow is a well-known difficult problem for ACMers. Given a graph, yo

HDU 3549 Flow Problem (最大流ISAP)

Flow Problem Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)Total Submission(s): 8199    Accepted Submission(s): 3814 Problem Description Network flow is a well-known difficult problem for ACMers. Given a graph, yo

hdoj 3549 Flow Problem 【最大流】

题目:hdoj 3549 Flow Problem 题意:给出一个图,让你求最大流. 分析:这个题目用dinci写的,因为点比较少,而dinci复杂度O(m*n^2),但是还是跑了160ms,不知道15的神牛怎么写的. dinci的写法要注意的地方就是存图的时候要考虑怎么存,因为要更新网络残量,即反向的流量,所以这里要注意一下. 思想就不讲了,很多地方有讲. 代码: #include <cstdio> #include <cstring> #include <iostream

HDU 3549 Flow Problem(最大流)

Flow Problem Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others) Total Submission(s): 12625    Accepted Submission(s): 6004 Problem Description Network flow is a well-known difficult problem for ACMers. Given a graph,

[ACM] hdu 3549 Flow Problem (最大流模板题)

Flow Problem Problem Description Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph. Input The first line of input contains an integer T, denoting the nu

hdu------(3549)Flow Problem(最大流(水体))

Flow Problem Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)Total Submission(s): 8203    Accepted Submission(s): 3817 Problem Description Network flow is a well-known difficult problem for ACMers. Given a graph, yo