HDU 5063 Operation the Sequence(暴力 数学)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5063

Problem Description

You have an array consisting of n integers: a1=1,a2=2,a3=3,…,an=n.
Then give you m operators, you should process all the operators in order. Each operator is one of four types:

Type1: O 1 call fun1();

Type2: O 2 call fun2();

Type3: O 3 call fun3();

Type4: Q i query current value of a[i], this operator will have at most 50.

Global Variables: a[1…n],b[1…n];

fun1() {

index=1;

for(i=1; i<=n; i +=2)

b[index++]=a[i];

for(i=2; i<=n; i +=2)

b[index++]=a[i];

for(i=1; i<=n; ++i)

a[i]=b[i];

}

fun2() {

L = 1;R = n;

while(L<R) {

Swap(a[L], a[R]);

++L;--R;

}

}

fun3() {

for(i=1; i<=n; ++i)

a[i]=a[i]*a[i];

}

Input

The first line in the input file is an integer T(1≤T≤20),
indicating the number of test cases.

The first line of each test case contains two integer n(0<n≤100000), m(0<m≤100000).

Then m lines follow, each line represent an operator above.

Output

For each test case, output the query values, the values may be so large, you just output the values mod 1000000007(1e9+7).

Sample Input

1
3 5
O 1
O 2
Q 1
O 3
Q 1

Sample Output

2
4

Source

BestCoder Round #13

PS:

把所有的操作存下来,每次把操作逆回去算一遍,求出在最初在数列中的位置,输出即可!

操作3是可以最后操作的!

代码如下:

#include <cstdio>
#include <cstring>
const int maxn = 100017;
const int mod = 1000000007;
typedef __int64 LL;
int a[maxn], b[maxn];
int n, m;
int find_pos(int l, int p)
{
    for(int i = l; i > 0; i--)
    {
        if(b[i] == 1)
        {
            if (p > (n + 1) / 2)
                p = (p - (n + 1) / 2) * 2;
            else
                p = (p - 1) * 2 + 1;
        }
        else
            p = n-p+1;
    }
    return p;
}
int main()
{
    int t;
    char s[2];
    int p;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        int k = 0, l = 0;
        for(int i = 1; i <= m; i++)
        {
            scanf("%s%d",s,&p);
            if(s[0] == 'O')
            {
                if(p == 3)
                    k++;
                else
                    b[++l] = p;
            }
            else
            {
                LL ans = find_pos(l,p);
                for(int i = 1; i <= k; i++)
                {
                    ans = ans*ans%mod;
                }
                printf("%I64d\n",ans);
            }
        }
    }
    return 0;
}
时间: 2024-08-10 16:59:35

HDU 5063 Operation the Sequence(暴力 数学)的相关文章

HDU 5063 Operation the Sequence(暴力)

HDU 5063 Operation the Sequence 题目链接 把操作存下来,由于只有50个操作,所以每次把操作逆回去运行一遍,就能求出在原来的数列中的位置,输出即可 代码: #include <cstdio> #include <cstring> #include <algorithm> using namespace std; typedef long long ll; const int N = 100005; const ll MOD = 100000

hdu 5063 Operation the Sequence(Bestcoder Round #13)

Operation the Sequence                                                                     Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 158    Accepted Submission(s): 74 Problem Description

HDU 5063 Operation the Sequence(仔细审题)

http://acm.hdu.edu.cn/showproblem.php?pid=5063 题目大意: 题目意思还是比较简单.所以就不多少了.注意这句话,对解题有帮助. Type4: Q i query current value of a[i], this operator will have at most 50. 解题思路: 因为给定n和m都是100000,我们每一步都做具体的操作,时间将是O(n*m),肯定超时.最开始的时候 我怎么想都不知道怎么解决.以为是线段树.比赛完了以后,看了解

HDU 5063 Operation the Sequence

做题感悟:这题开始以为是找规律,果断悲剧阿,最后才意识到应该逆着退回去. 解题思路: 这题的突破口就是要逆向推回去,这样复杂度为 50 * m 的复杂度.做完这题还学到一点就是如果取模的数为素数,可以让指数先对素数减一取模,取模后指数就比较小了. 代码: #include<iostream> #include<sstream> #include<map> #include<cmath> #include<fstream> #include<

HDU 5063 Operation the Sequence(BestCoder Round #13)

Problem Description: You have an array consisting of n integers: a1=1,a2=2,a3=3,…,an=n. Then give you m operators, you should process all the operators in order. Each operator is one of four types:Type1: O 1 call fun1();Type2: O 2 call fun2();Type3:

HDU 5288 OO’s Sequence (暴力枚举因子)

题目链接:HDU 5288 OO's Sequence 题意:给出一个n,表示n个数的序列,函数f(l,r)定义,在l,r区间中存在多少个数,不能被其他数整除.求累加所有子区间的函数值 思路:从ai的小范围入手 1.a不能被b整除,即a的所有因子中不存在b,所以打表枚举所有的数的因子. 2.找到一个数(位置为i)满足条件时最左端l和最右端r,(i-l)*(r-i)就是对答案的贡献. AC代码: #include <stdio.h> #include <algorithm> #inc

HDOJ 5063 Operation the Sequence

注意到查询次数不超过50次,那么能够从查询位置逆回去操作,就能够发现它在最初序列的位置,再逆回去就可以求得当前查询的值,对于一组数据复杂度约为O(50*n). Operation the Sequence Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 463    Accepted Submission(s): 187 Problem

HDU 5288 OO’s Sequence(数学啊 多校2015)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5288 Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there's no j(l<=j<=r,j<>i) satisfy ai mod aj=0,now OO want to kn

【HDOJ】5063 Operation the Sequence

1 #include <cstdio> 2 #include <cstring> 3 #include <cstdlib> 4 5 #define MAXN 100005 6 #define MOD 1000000007 7 int que[MAXN], front = 0, rear = 0; 8 int n; 9 10 void query(int index) { 11 int r = rear; 12 int square = 0; 13 int half =