杭电 HDU ACM 1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 31900    Accepted Submission(s): 14108

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Source

Asia 1996, Shanghai (Mainland China)

又一个深搜题目!http://rapheal.iteye.com/blog/1526863这个大神 讲的不错。并且这个素数环问题 参考了 人家的优化方案,值得好好吸收。

#include<iostream>
#include<string.h>
#include<list>
using namespace std;

int prime[41],visited[21],step,n;
list<int>cnt;
void Prime()             // 素数打表判定
{
    memset(prime,0,sizeof(prime));
    for(int i=2; i<=41; i++)
    {
        if(!prime[i])
        {
            for(int j=i+i; j<=41; j+=i)
                prime[j]=1;
        }
    }
    prime[1]=1;
}

void dfs(int k)
{

    if(step==n&&!prime[k+1])  //某次搜索结束条件,也即如果出现某条满足题意搜索,输出即可
    {
        cout<<1;
        for(list<int>::iterator it=cnt.begin(); it!=cnt.end(); it++)
            cout<<" "<<(*it);
        cout<<endl;
        return ;
    }
    else if(k&1)         //如果为奇数,那么为了和下一个数的加和为素数,只能在奇数中搜索
    {
        for(int i=2; i<=n; i+=2)
        {
            if(!visited[i]&&!prime[k+i])//如果某个结点未搜索过,且满足和k加和为素数
            {
                cnt.push_back(i);
                visited[i]=1;  //标记已被访问
                step++;
                dfs(i);
                visited[i]=0;//回溯到上次结点处
                step--;
                cnt.pop_back();
            }
        }

    }
    else if(!(k&1))
    {
        for(int p=3; p<=n; p+=2)
        {
            if(!visited[p]&&!prime[p+k])
            {
                cnt.push_back(p);
                visited[p]=1;
                step++;
                dfs(p);
                visited[p]=0;
                step--;
                cnt.pop_back();

            }
        }
    }
    return ;
}

int main()
{
    int t=0;
    while(cin>>n)
    {
        cout<<"Case "<<++t<<":"<<endl;
        memset(visited,0,sizeof(visited));
        Prime();
//        if(n&1)
//            continue;
        visited[1]=1;
        step=1;
        dfs(1);
        cnt.clear();
        cout<<endl;

    }
    return 0;
}
时间: 2024-10-01 06:34:37

杭电 HDU ACM 1016 Prime Ring Problem的相关文章

[ACM] 1016 Prime Ring Problem (深度优先搜索)

Prime Ring Problem Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. Note: the number of first circle

HDU OJ 1016 Prime Ring Problem

#include <iostream> #include <stdio.h> using namespace std; int n,map[30],vis[30]; void dfs(int s[30], int x, int vis[30]) { int i, t, j,flag; if(x==n-1) { flag=0; t=s[x]+1; for(j=2;j<t;j++) { if(t%j==0) { flag=1; break; } } if(flag) return

[HDU 1016]--Prime Ring Problem(回溯)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016 Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1, 2

hdu 1016 Prime Ring Problem (素数环)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016 题目大意:输入一个n,环从一开始到n,相邻两个数相加为素数. 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 int visit[22],q[100],n; 6 int sushu(int n) 7 { 8 int i; 9 for (i=2

HDU 1016 Prime Ring Problem(素数环问题)

传送门: http://acm.hdu.edu.cn/showproblem.php?pid=1016 Prime Ring Problem Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 63806    Accepted Submission(s): 27457 Problem Description A ring is compos

HDU 1016 Prime Ring Problem 题解

Problem Description A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. Note: the number of first circle should always be 1

HDU 1016 Prime Ring Problem --- 经典DFS

思路:第一个数填1,以后每个数判断该数和前一个数想加是否为素数,是则填,然后标记,近一步递归求解. 然后记得回溯,继续判断下一个和前一个数之和为素数的数. /* HDU 1016 Prime Ring Problem --- 经典DFS */ #include <cstdio> #include <cstring> int n; bool primer[45], visit[25]; //primer打素数表,visit标记是否访问 int a[25]; //数组a存储放置的数 /

【dfs】hdu 1016 Prime Ring Problem

[dfs]hdu 1016 Prime Ring Problem 题目链接 刚开始接触搜索,先来一道基本题目练练手. 注意对树的深度进行dfs dfs过程中注意回退!!! 素数提前打表判断快一些 参考代码 /*Author:Hacker_vision*/ #include<bits/stdc++.h> #define clr(k,v) memset(k,v,sizeof(k)) using namespace std; const int _max=1e3+10;//素数打表 int n,pr

HDU 1016 Prime Ring Problem (素数筛+DFS)

题目链接 题意 : 就是把n个数安排在环上,要求每两个相邻的数之和一定是素数,第一个数一定是1.输出所有可能的排列. 思路 : 先打个素数表.然后循环去搜..... 1 //1016 2 #include <cstdio> 3 #include <cstring> 4 #include <iostream> 5 6 using namespace std ; 7 8 bool vis[21]; 9 int prime[42] ,cs[21]; 10 int n ; 11