YTUOJ-The Hardest Problem Ever

题目描述

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure
it out without knowing how it worked. You are a sub captain of Caesar‘s army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right
to create the secure message (i.e., if the letter is ‘A‘, the cipher text would be ‘F‘). Since you are creating plain text out of Caesar‘s messages, you will do the opposite: Cipher text A B C D E F G H I J K L M N O P Q R S T U V W X Y Z Plain text V W X
Y Z A B C D E F G H I J K L M N O P Q R S T U Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

输入

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. A single data
set has 3 components: Start line - A single line, "START" Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar End line - A single line, "END" Following the final data set will be
a single line, "ENDOFINPUT".

输出

For each data set, there will be exactly one line of output. This is the original message by Caesar.

样例输入

START
NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
END
START
N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
END
START
IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
END
ENDOFINPUT

样例输出

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char a[27]= {"ABCDEFGHIJKLMNOPQRSTUVWXYZ"};
char b[27]= {"VWXYZABCDEFGHIJKLMNOPQRSTU"};
char c[11]= {"ENDOFINPUT"};
char e[6]= {"START"};
char f[4]= {"END"};
int main()
{
    char s[100];
    char x[20];
    char y[20];
    while (1)
    {
        gets(x);
        if (strcmp(x,c)==0)
            break;
        else if (strcmp(x,e)==0)
        {
            int i=0,j,len;
            gets(s);
            len=strlen(s);
            while (s[i]!='\0')
            {
                for (j=0;j<27;j++)
                {
                    if (s[i]==a[j])
                    {
                        s[i]=b[j];
                        break;
                    }
                }
                i++;
            }
            gets(y);
            if (strcmp(y,f)==0)
            {
                for (i=0;i<len;i++)
                    cout<<s[i];
            }
            cout<<endl;
        }
    }

    return 0;
}

运行结果:

时间: 2024-08-25 04:36:29

YTUOJ-The Hardest Problem Ever的相关文章

The Hardest Problem Ever(杭电1048)

/*The Hardest Problem Ever Problem Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This c

JAVA HDU 1048 The Hardest Problem Ever

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1048 1 package hdu; 2 3 import java.io.BufferedInputStream; 4 import java.util.Scanner; 5 6 public class hdu_1048 { 7 8 public static void main(String[] args) { 9 Scanner in = new Scanner(new BufferedInp

HDU 1048.The Hardest Problem Ever【字符串处理】【8月25】

The Hardest Problem Ever Problem Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cip

HDU-1048-The Hardest Problem Ever(C++ &amp;&amp; 偶尔一水......)

The Hardest Problem Ever Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 19343    Accepted Submission(s): 9061 Problem Description Julius Caesar lived in a time of danger and intrigue. The hard

HDU1048 The Hardest Problem Ever

The Hardest Problem Ever Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15790    Accepted Submission(s): 7298 Problem Description Julius Caesar lived in a time of danger and intrigue. The hard

(字符串 枚举)The Hardest Problem Ever hdu1048

The Hardest Problem Ever 链接:http://acm.hdu.edu.cn/showproblem.php?pid=1048 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 31307    Accepted Submission(s): 14491 Problem Description Julius Caesa

C - The Hardest Problem Ever

Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that

The Hardest Problem Ever(有史以来最难的题)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 19083    Accepted Submission(s): 8885 Problem Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever

POJ 1298 The Hardest Problem Ever

Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 23668   Accepted: 12945 Description Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he