BZOJ 2818 Gcd (莫比乌斯反演 或 欧拉函数)

2818: Gcd

Time Limit: 10 Sec  Memory Limit:
256 MB

Submit: 2534  Solved: 1129

[Submit][Status][Discuss]

Description

给定整数N,求1<=x,y<=N且Gcd(x,y)为素数的

数对(x,y)有多少对.

Input

一个整数N

Output

如题

Sample Input

4

Sample Output

4

HINT

hint

对于样例(2,2),(2,4),(3,3),(4,2)

1<=N<=10^7

Source

湖北省队互测

题目链接:http://www.lydsy.com/JudgeOnline/problem.php?id=2818

题目分析:两种姿势,莫比乌斯反演或者欧拉函数,先说简单的方法,欧拉函数,因为只有一个上界n,所以变换一下1 <= x / p, y / p <= n / p,GCD(x / p, y / p) == 1,

直接求欧拉函数,令num[i]表示1到i中  1<=x,y<=i 且gcd(x,y) == 1个对数,显然有num[i] = 1 + phi[j] * 2,(1 < j <= i),这个1指的是(1, 1),乘2是因为(1, 2) (2, 1)算两个不同的,那么最后根据我们先前变换的公式,累加num[n / p]的值即可

#include <cstdio>
#include <cstring>
#define ll long long
int const MAX = 1e7 + 5;
int p[MAX], phi[MAX];
bool prime[MAX];
ll num[MAX];
int pnum;

void get_eular(int n)
{
    pnum = 0;
    memset(prime, true, sizeof(prime));
    for(int i = 2; i <= n; i++)
    {
        if(prime[i])
        {
            p[pnum ++] = i;
            phi[i] = i - 1;
        }
        for(int j = 0; j < pnum && i * p[j] <= n; j++)
        {
            prime[i * p[j]] = false;
            if(i % p[j] == 0)
            {
                phi[i * p[j]] = phi[i] * p[j];
                break;
            }
            phi[i * p[j]] = phi[i] * (p[j] - 1);
        }
    }
}

int main()
{
    int n;
    ll ans = 0;
    scanf("%d", &n);
    get_eular(n);
    num[1] = 1;
    for(int i = 2; i <= n; i++)
        num[i] = num[i - 1] + 2 * phi[i];
    for(int i = 0; i < pnum; i++)
        if(n / p[i] > 0)
            ans += num[n / p[i]];
    printf("%lld\n", ans);
}

这题也可以用莫比乌斯反演做,还是做上述变换,1 <= x / p, y / p <= n / p,GCD(x / p, y / p) == 1,这种题真的做烂了,懒得说了直接贴

#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
int const MAX = 1e7 + 5;
int mob[MAX], p[MAX], sum[MAX];
bool prime[MAX];
int pnum;

void Mobius(int n)
{
    pnum = 0;
    memset(prime, true, sizeof(prime));
    memset(sum, 0, sizeof(sum));
    mob[1] = 1;
    sum[1] = 1;
    for(int i = 2; i <= n; i++)
    {
        if(prime[i])
        {
            p[pnum ++] = i;
            mob[i] = -1;
        }
        for(int j = 0; j < pnum && i * p[j] <= n; j++)
        {
            prime[i * p[j]] = false;
            if(i % p[j] == 0)
            {
                mob[i * p[j]] = 0;
                break;
            }
            mob[i * p[j]] = -mob[i];
        }
        sum[i] = sum[i - 1] + mob[i];
    }
}

ll cal(int n)
{
    ll res = 0;
    for(int i = 1, last = 0; i <= n; i = last + 1)
    {
        last = n / (n / i);
        res += (ll) (n / i) * (n / i) * (sum[last] - sum[i - 1]);
    }
    return res;
}

int main()
{
    int n;
    ll ans = 0;
    scanf("%d", &n);
    Mobius(n);
    for(int i = 0; i < pnum; i++)
        if(n / p[i] > 0)
            ans += cal(n / p[i]);
    printf("%lld\n", ans);
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-12-17 16:08:33

BZOJ 2818 Gcd (莫比乌斯反演 或 欧拉函数)的相关文章

UVa 10214 (莫比乌斯反演 or 欧拉函数) Trees in a Wood.

题意: 这道题和POJ 3090很相似,求|x|≤a,|y|≤b 中站在原点可见的整点的个数K,所有的整点个数为N(除去原点),求K/N 分析: 坐标轴上有四个可见的点,因为每个象限可见的点数都是一样的,所以我们只要求出第一象限可见的点数然后×4+4,即是K. 可见的点满足gcd(x, y) = 1,于是将问题转化为x∈[1, a], y∈[1, b],求gcd(x, y) = 1的个数. 类比HDU 1695可以用莫比乌斯反演来做,我还写了普通的和分块加速的两份代码,交上去发现运行时间相差并不

【BZOJ2226】[Spoj 5971] LCMSum 莫比乌斯反演(欧拉函数?)

[BZOJ2226][Spoj 5971] LCMSum Description Given n, calculate the sum LCM(1,n) + LCM(2,n) + .. + LCM(n,n), where LCM(i,n) denotes the Least Common Multiple of the integers i and n. Input The first line contains T the number of test cases. Each of the n

【BZOJ】2190: [SDOI2008]仪仗队(欧拉函数)

http://www.lydsy.com/JudgeOnline/problem.php?id=2190 一开始没想到QAQ看了题解恍然大悟,虽然做法和题解不同.. 因为以1开头或结尾的坐标的比较特殊,所以首先不考虑先. 考虑从2开始的坐标,发现当这个点不在以点(1,1)放出的射线第一个遇到的点时,则不选.意思就是说,不是第一个点的倍数! 因此想到当坐标gcd(x, y)!=1时,这个点看不到!因为d=gcd(x, y)!=1,显然有坐标(x/d, y/d)在这条线上!(可以用斜率来搞搞..但是

[BZOJ2818] Gcd (数论,欧拉函数,线性筛)

题目链接:http://www.lydsy.com/JudgeOnline/problem.php?id=2818 必须用线性筛. 1 #include <bits/stdc++.h> 2 using namespace std; 3 typedef long long LL; 4 const int maxn = 10001001; 5 LL phi[maxn], sum[maxn], n; 6 bool isprime[maxn]; 7 LL prime[maxn]; 8 int tot;

Bzoj 2705: [SDOI2012]Longge的问题 欧拉函数,数论

2705: [SDOI2012]Longge的问题 Time Limit: 3 Sec  Memory Limit: 128 MBSubmit: 1959  Solved: 1229[Submit][Status][Discuss] Description Longge的数学成绩非常好,并且他非常乐于挑战高难度的数学问题.现在问题来了:给定一个整数N,你需要求出∑gcd(i, N)(1<=i <=N). Input 一个整数,为N. Output 一个整数,为所求的答案. Sample Inp

HDOJ GCD Again 1787【欧拉函数】

GCD Again Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2625    Accepted Submission(s): 1099 Problem Description Do you have spent some time to think and try to solve those unsolved problem a

UVA 11426 GCD - Extreme (II) (数论|欧拉函数)

题意:求sum(gcd(i,j),1<=i<j<=n). 思路:首先可以看出可以递推求出ans[n],因为ans[n-1]+f(n),其中f(n)表示小于n的数与n的gcd之和 问题转化为了求f(n),因为小于n的数与n的gcd一定是n的因数, 所以f(n)可以表示为sum(i)*i,其中sum(i)表示所有和n的gcd为i的数的数量,我们要求满足gcd(a, n) = i,的个数,可以转化为求gcd(a/i, n/i) = 1的个数, 于是可以发现sun(i) = phi(n/i),这

UVA - 11426 GCD - Extreme (II) (欧拉函数)

题意:,给定N,求G. 分析: 1.G = f(2) + f(3) + ... + f(n).其中,f(n) = gcd(1, n) + gcd(2, n) + ... + gcd(n - 1, n). 2.设g(n, i)表示gcd(x, n) = i的个数(x < n),则f(n) = sum{i * g(n, i)}. 3.g(n, i)的求法: (1)因为gcd(x, n) = i,可得gcd(x / i, n / i) = 1,且x / i < n / i. (2)因为gcd(x /

bzoj 2818 GCD 数论 欧拉函数

bzoj[2818]Gcd Description 给定整数N,求1<=x,y<=N且Gcd(x,y)为素数的数对(x,y)有多少对. Input 一个整数N Output 如题 Sample Input 4 Sample Output 4 HINT hint对于样例(2,2),(2,4),(3,3),(4,2) 1<=N<=10^7 题解一(自己yy) phi[i]表示与x互质的数的个数 即gcd(x,y)=1 1<=y<x ∴对于x,y 若a为素数 则gcd(xa,