hdoj 1556 Color the ball【线段树区间更新】

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13072    Accepted Submission(s):
6537

Problem Description

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <=
b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1
<= a <= b <= N)。
当N = 0,输入结束。

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input

3

1 1

2 2

3 3

3

1 1

1 2

1 3

0

Sample Output

1 1 1

3 2 1

Author

8600

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#define MAX 100010
#define INF 0x3f3f3f
int n,m;
int sum[MAX<<2];//记录每个区间的值,即每个气球被标记的次数
int add[MAX<<2];//记录每个对应区间的每个数的值
int ans;
void pushup(int o)//向上传递用来更新每一次被标记区间的值  的改变
{
	sum[o]=sum[o<<1]+sum[o<<1|1];
}
void pushdown(int o,int m)//向下传递
{
	if(add[o])
	{
		add[o<<1]+=add[o];
		add[o<<1|1]+=add[o];
		sum[o<<1]+=add[o]*(m-(m>>1));//线段树左分支的区间长度等于右分支或者比右分支大1
		sum[o<<1|1]+=add[o]*(m>>1);
	    add[o]=0;
	}
}
void gettree(int o,int l,int r)//建树
{
	sum[o]=add[o]=0;
	if(l==r)
		return ;
	int mid=(l+r)>>1;
	gettree(o<<1,l,mid);
	gettree(o<<1|1,mid+1,r);
	pushup(o);
}
void update(int o,int l,int r,int L,int R)
{
	if(L<=l&&R>=r)
	{
        add[o]+=1;
        sum[o]+=1*(r-l+1);
		return ;
	}
	pushdown(o,r-l+1);
	int mid=(l+r)>>1;
    if(L <= mid)
    update(o<<1, l, mid, L ,R);
    if(R > mid)
    update(o<<1|1, mid+1, r, L ,R);
    pushup(o);//维护区间的值
}
int find(int o,int l,int r,int L,int R)//查找每个气球被修改次数并输出
{
	if(L<=l&&R>=r)
	{
		return sum[o];
	}
	pushdown(o,r-l+1);
	int ans=0;
	int mid=(r+l)>>1;
	if(L<=mid)
	    ans+=find(o<<1,l,mid,L,R);
	if(R>mid)
	    ans+=find(o<<1|1,mid+1,r,L,R);
	return ans;
}
int main()
{
	int i,j,a,b;
	while(scanf("%d",&n),n)
	{
		gettree(1,1,n);
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&a,&b);
			update(1,1,n,a,b);
		}
		for(i=1;i<=n;i++)
		{
			if(i>1)
			printf(" ");
			printf("%d",find(1,1,n,i,i));
		}
		printf("\n");
	}
	return 0;
}

  

时间: 2024-12-28 12:06:18

hdoj 1556 Color the ball【线段树区间更新】的相关文章

hdu1556 Color the ball(线段树区间更新)

Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 12814    Accepted Submission(s): 6401 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽"

hdu 1556 Color the ball(线段树区间维护+单点求值)

传送门:Color the ball Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 25511    Accepted Submission(s): 12393 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele

Color the ball 线段树 区间更新但点查询

#include<iostream> #include<cstdio> #include<cmath> #include<cstring> #include<sstream> #include<algorithm> #include<queue> #include<deque> #include<iomanip> #include<vector> #include<cmath>

HDU 1556 Color the ball 线段树更新区间查点

点击打开链接 Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9120    Accepted Submission(s): 4665 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽

HDU 1556 Color the ball 线段树

HDU 1556 Color the ball 线段树模版题,存个模板 1 #include <iostream> 2 #include <cstdio> 3 #include <fstream> 4 #include <algorithm> 5 #include <cmath> 6 #include <deque> 7 #include <vector> 8 #include <queue> 9 #inclu

HDU 1556 Color the Ball 线段树 题解

本题使用线段树自然能够,由于区间的问题. 这里比較难想的就是: 1 最后更新须要查询全部叶子节点的值,故此须要使用O(nlgn)时间效率更新全部点. 2 截取区间不能有半点差错.否则答案错误. 这两点卡了我下.看来我的线段树还是不够熟,须要多多练习. 线段树是二分法的高级应用,可是却不是简单应用,要锻炼好并应用好线段树思维还是比二分法难非常多的. static const int SIZE = 100005; static const int TREESIZE = SIZE<<2; int a

hdoj 1556 Color the ball 【树状数组】

Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9769    Accepted Submission(s): 5028 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽"牌

hdoj 1556 Color the ball(树状数组)

Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色.但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗? Input 每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <=

hdu 1556 Color the ball(树状数组)

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1556 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色.但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气

[ACM] Color the ball [线段树水题][数组开大]

Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的"小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色.但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗? Input 每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N).  当N