poj 1469 COURSES(二分匹配模板)

题目链接:http://poj.org/problem?id=1469

COURSES

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17135   Accepted: 6730

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N

Count1 Student1 1 Student1 2 ... Student1 Count1

Count2 Student2 1 Student2 2 ... Student2 Count2

...

CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each
two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

Southeastern Europe 2000

题意:该题给出P门课程,N个学生,问是否能从中选出P个学生,使每一个学生上不同的课,且每一个课程有一个学生。

典型的二分图匹配的问题。我们仅仅要计算最大二分图匹配数。假设和课程数同样就输出YES,否则输出NO。

代码例如以下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

/* **************************************************************************
//二分图匹配(匈牙利算法的DFS实现)
//初始化:g[][]两边顶点的划分情况
//建立g[i][j]表示i->j的有向边就能够了,是左边向右边的匹配
//g没有边相连则初始化为0
//L是匹配左边的顶点数,R是匹配右边的顶点数
//调用:res=hungary();输出最大匹配数
//长处:适用于稠密图,DFS找增广路,实现简洁易于理解
//时间复杂度:O(VE)
//***************************************************************************/
//顶点编号从0開始的
#define MAXN 317
int p,n;//L,R数目
int k;
int g[MAXN][MAXN], linker[MAXN];
bool used[MAXN];
int dfs(int L)//从左边開始找增广路径
{
	int R;
	for(R = 1 ; R <= n; R++ )//这个顶点编号从0開始,若要从1開始须要改动
	{
		if(g[L][R]!=0 && !used[R])
		{//找增广路,反向
			used[R]=true;
			if(linker[R] == -1 || dfs(linker[R]))
			{
				linker[R]=L;
				return 1;
			}
		}
	}
	return 0;//这个不要忘了。常常忘记这句
}
int hungary()
{
	int res = 0 ;
	int L;
	memset(linker,-1,sizeof(linker));
	for( L = 1; L <= p; L++ )
	{
		memset(used,0,sizeof(used));
		if(dfs(L) != 0)
			res++;
	}
	return res;
}
int main()
{
	int i,j,res,R;
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&p,&n);
		memset(g,0,sizeof(g));
		for(i = 1; i <= p; i++)
		{
			scanf("%d",&k);
			for(j = 1 ; j <= k; j++ )
			{
				scanf("%d",&R);
				g[i][R] = 1;
			}
		}
		res = hungary();
		if(res == p)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0 ;
}
时间: 2024-10-17 13:49:41

poj 1469 COURSES(二分匹配模板)的相关文章

poj 1469 COURSES (二分匹配)

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 16877   Accepted: 6627 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

poj 1469 COURSES 解题报告

题目链接:http://poj.org/problem?id=1469 题目意思:略 for 循环中遍历的对象要特别注意,究竟是遍历课程数P 还是 学生数N,不要搞混! 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 6 const int maxn = 300 + 5; 7 int match[maxn], map[maxn][maxn];

POJ 1469 COURSES【二分图最大匹配】

分析:二分图最大匹配 代码: 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 #include <vector> 5 using namespace std; 6 7 const int maxn = 305; 8 9 int n; 10 11 vector<int> G[maxn]; 12 int vis[maxn]; 13 int Link[maxn]; 14

POJ 1469 COURSES 二分图最大匹配

就是判断一下是不是每一个课程都能找到自己的代表人,做一遍最大匹配看看匹配数是否等于p即可 #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> #include <climits> #include <string> #include <iostream> #include <map> #include <cs

POJ 1469 COURSES //简单二分图

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 17211   Accepted: 6769 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

poj 1469 COURSES(匈牙利算法模板)

http://poj.org/problem?id=1469 COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 19419   Accepted: 7642 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is

POJ 1469 -- COURSES (二分匹配)

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 23535   Accepted: 9221 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

poj 1469 COURSES 【二分匹配】

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 18438   Accepted: 7262 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss

POJ 1469 COURSES (二分图最大匹配 匈牙利算法)

COURSES Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 18892   Accepted: 7455 Description Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is poss