HDOJ 1702 ACboy needs your help again!

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1702

ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3512    Accepted Submission(s): 1797

Problem Description

ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can‘t image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster‘s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can‘t solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem‘s first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don‘t have any integer.

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

Source

2007省赛集训队练习赛(1)

题意: 略。

题解: 简单栈和队列只是考查

AC代码:

#include<iostream>
#include<string>
#define maxn 1000000+5
using namespace std;
int vec[maxn],top,rear,t,n;
string str,cstack="FILO",cqueue="FIFO",in="IN",out="OUT",no="None";
int main()
{
	cin.sync_with_stdio(false);
	cin>>t;
	while(t--)
	{
		cin>>n>>str;
		top=rear=0;
		int flag=1,num;
		if(str==cqueue) flag=0;
		while(n--)
		{
			if(flag){   //栈
			cin>>str;
			if(str==in){  //进栈
				cin>>num; vec[top++]=num;
			}
			else {  //出栈
				if(top) //栈不为空
				cout<<vec[--top]<<endl;
				else cout<<no<<endl;
			}
			}
			else {     //队列
				cin>>str;
				if(str==in){//入队
					cin>>num;vec[top++]=num;
				}
				else { //出队
					if(top!=rear)//队列不为空
						cout<<vec[rear++]<<endl;
					else cout<<no<<endl;
				}
			}

		}
	}
	return 0;
}
时间: 2024-10-09 15:06:28

HDOJ 1702 ACboy needs your help again!的相关文章

hdu 1702 ACboy needs your help again!

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1702 题目大意:按照所给要求,输出相应的数.“FIFO”指代先进先出,即队列的概念,“FILO”指代先进后出,即栈的表现形式~这里定义两个函数即可,一个队列,一个栈的调用! 1 #include <iostream> 2 #include <cstdio> 3 #include <queue> 4 #include <stack> 5 #include <

HDU 1702 ACboy needs your help again! (栈和队列的模拟)

ACboy needs your help again! Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3164    Accepted Submission(s): 1655 Problem Description ACboy was kidnapped!! he miss his mother very much and is ve

HDU - 1702 ACboy needs your help again!(栈和队列)

Description ACboy was kidnapped!! he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(. As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the g

HDU 1702 ACboy needs your help again!(附加优先队列)

ACboy was kidnapped!! he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the ma

HDU 1702 ACboy needs your help again! (栈与队列)

ACboy needs your help again! Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3701    Accepted Submission(s): 1885 Problem Description ACboy was kidnapped!! he miss his mother very much and is v

hdu杭电1702 ACboy needs your help again!

Problem Description ACboy was kidnapped!! he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(. As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive

HDU 1702 ACboy needs your help again!(栈 队列 基础)

#include<cstdio> #include<cmath> #include<queue> #include<stack> #include<cstring> #include<iostream> #include<algorithm> using namespace std; int t,n; int main() { int i,j,k; cin>>t; char op[10],io[10]; whi

A - ACboy needs your help again! (HDU - 1702)

- 题目大意 给出了先进先出和先进后出的两种结构,分别对应队列和栈,并且每种均给出In和Out两类操作,如果是In,push进后面的数,如果是Out,输出栈顶(队首). - 解题思路 对于给的命令判断,然后来决定是用队列还是栈. - 代码 #include<iostream> #include<stack> #include<queue> using namespace std; int main() { int n,x,b; char a[5]; char c[5];

HDOJ 题目分类

HDOJ 题目分类 /* * 一:简单题 */ 1000:    入门用:1001:    用高斯求和公式要防溢出1004:1012:1013:    对9取余好了1017:1021:1027:    用STL中的next_permutation()1029:1032:1037:1039:1040:1056:1064:1065:1076:    闰年 1084:1085:1089,1090,1091,1092,1093,1094, 1095, 1096:全是A+B1108:1157:1196:1