hdu 5318 The Goddess Of The Moon 矩阵高速幂

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5318

The Goddess Of The Moon

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 438    Accepted Submission(s): 150

Problem Description

Chang’e (嫦娥) is a well-known character in Chinese ancient mythology. She’s the goddess of the Moon. There are many tales about Chang‘e, but there‘s a well-known story regarding the origin of the Mid-Autumn Moon Festival. In a very distant past, ten suns had
risen together to the heavens, thus causing hardship for the people. The archer Yi shot down nine of them and was given the elixir of immortality as a reward, but he did not consume it as he did not want to gain immortality without his beloved wife Chang‘e.

Yi discovered what had transpired and felt sad, so he displayed the fruits and cakes that his wife Chang‘e had liked, and gave sacrifices to her. Now, let’s help Yi to the moon so that he can see his beloved wife. Imagine the earth is a point and the moon is
also a point, there are n kinds of short chains in the earth, each chain is described as a number, we can also take it as a string, the quantity of each kind of chain is infinite. The only condition that a string A connect another string B is there is a suffix
of A , equals a prefix of B, and the length of the suffix(prefix) must bigger than one(just make the joint more stable for security concern), Yi can connect some of the chains to make a long chain so that he can reach the moon, but before he connect the chains,
he wonders that how many different long chains he can make if he choose m chains from the original chains.

Input

The first line is an integer T represent the number of test cases.

Each of the test case begins with two integers n, m.

(n <= 50, m <= 1e9)

The following line contains n integer numbers describe the n kinds of chains.

All the Integers are less or equal than 1e9.

Output

Output the answer mod 1000000007.

Sample Input

2
10 50
12 1213 1212 1313231 12312413 12312 4123 1231 3 131
5 50
121 123 213 132 321

Sample Output

86814837
797922656

Hint

11 111 is different with 111 11

题意:有n个小楼梯,假设两个楼梯的 前缀等于还有一个的后缀就能够首尾相连,前缀后缀长度要大于等于2。

问m个楼梯组成。有多少种组成方法。

做法:要去重,然后judge  每一个楼梯能不能连,构造出构造矩阵。初始矩阵第一行全为1,然后矩阵高速幂。

#include <cstdio>
#include <algorithm>
#include <stdio.h>
#include <string>
#include <set>
#include <math.h>
#include <string.h>
#include <iostream>
using namespace std;

#define Matr 55 //矩阵大小,注意能小就小   矩阵从1開始   所以Matr 要+1   最大能够100
#define ll __int64
struct mat//矩阵结构体。a表示内容,size大小 矩阵从1開始   但size不用加一
{
    ll a[Matr][Matr];
    mat()//构造函数
    {
        memset(a,0,sizeof(a));
    }
};
int Size=  0 ;
ll mod= 1000000007;

mat multi(mat m1,mat m2)//两个相等矩阵的乘法,对于稀疏矩阵。有0处不用运算的优化
{
    mat ans=mat();
    for(int i=1;i<=Size;i++)
        for(int j=1;j<=Size;j++)
            if(m1.a[i][j])//稀疏矩阵优化
                for(int k=1;k<=Size;k++)
                    ans.a[i][k]=(ans.a[i][k]+m1.a[i][j]*m2.a[j][k])%mod; //i行k列第j项
    return ans;
}

mat quickmulti(mat m,ll n)//二分高速幂
{
    mat ans=mat();
    int i;
    for(i=1;i<=Size;i++)ans.a[i][i]=1;
    while(n)
    {
        if(n&1)ans=multi(m,ans);//奇乘偶子乘 挺好记的.
        m=multi(m,m);
        n>>=1;
    }
    return ans;
}

void print(mat m)//输出矩阵信息,debug用
{
    int i,j;
    printf("%d\n",Size);
    for(i=1;i<=Size;i++)
    {
        for(j=1;j<=Size;j++)
			printf("%d ",m.a[i][j]);
        printf("\n");
    }
}
set<string> my;

string str[60];

int judge(string a,string b)
{
	for(int i=2;i<=a.size()&&i<=b.size();i++)
	{
		int flag=1;
		for(int j=0;j<i;j++)
		{
			if(a[a.size()-i+j]!=b[j])
				flag=0;
		}
		if(flag)
			return 1;
	}
	return 0;
}

int  main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		int kk=0;
		my.clear();
		for(int i=0;i<n;i++)
		{
			string ss;
			cin>>ss;
			if(my.find(ss)==my.end())
			{
				my.insert(ss);
				str[++kk]=ss;
			}
		}
		n=kk;
		if(m==0||n==0)
		{
			printf("0\n");
			continue;
		}
		mat gouzao=mat(),chu=mat();//构造矩阵  初始矩阵  

		for(int i=1;i<=kk;i++)
		{
			for(int j=1;j<=kk;j++)
			{
				if(judge(str[i],str[j]))
				gouzao.a[i][j]=1;
			}
		}

		for(int i=1;i<=kk;i++)
		{
			chu.a[1][i]=1;
		}
		Size=kk;
		chu=multi(chu,quickmulti(gouzao,m-1));

		__int64 ans=0;
		for(int i=1;i<=kk;i++)
		{
			ans=(ans+chu.a[1][i])%mod;
		}

		printf("%I64d\n",ans);
	}
	return 0;
} 
时间: 2024-10-20 07:43:47

hdu 5318 The Goddess Of The Moon 矩阵高速幂的相关文章

HDU 5318 The Goddess Of The Moon (矩阵快速幂)

题目链接:HDU 5318 The Goddess Of The Moon 题意:给出N串字符串,若是一个字符串的后缀与另一个字符串的前缀相同并且长度大于1,就表示这两个字符串是可以相连的,问M个字符串相连不同方案数为多少. 思路: 1.将输入的字符串预处理存入一个矩阵中,mp[i][j]=1说明str[i]与str[j]能相连,反之,则不能相连. 2.str[i]与str[j]能相连 转化为 i点到j点可达,那么就可以得到一个有向图,长度为M的意思就是 两点之间所走的步数为M的不同走法有多少种

HDOJ 5318 The Goddess Of The Moon 矩阵快速幂

The Goddess Of The Moon Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 540    Accepted Submission(s): 215 Problem Description Chang'e (嫦娥) is a well-known character in Chinese ancient mytholog

hdu5318 The Goddess Of The Moon (矩阵高速幂优化dp)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=5318 题意:给定n个数字串和整数m,规定若数字串s1的后缀和数字串s2的前缀同样且长度≥2,则s2能够拼接在s1的后面,每一个串能够反复用,问拼接m个数字串有多少种方法. n<=50,m<=1e9 分析:定义dp[i][j]为拼接了i个串而且这个长串以s[j](输入的第j个数字串)结尾的方案数. 那么有 for(int i=1;i<=n;i++) dp[1][i]=1; for(int i=2;

hdu 5318 The Goddess Of The Moon(矩阵快速幂)

题目链接:hdu 5318 The Goddess Of The Moon 将50个串处理成50*50的矩阵,注意重复串. #include <cstdio> #include <cstring> #include <cstdlib> #include <algorithm> using namespace std; const int maxn = 55; const int mod = 1e9+7; int N, M, A[maxn]; struct M

HDU 5318 The Goddess Of The Moon(矩阵快速幂详解)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5318 题面: The Goddess Of The Moon Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 800    Accepted Submission(s): 349 Problem Description Chang'e (嫦

hdu 5318 The Goddess Of The Moon

The Goddess Of The Moon Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1487    Accepted Submission(s): 650 Problem Description Chang’e (嫦娥) is a well-known character in Chinese ancient mytholog

HDU 5318 The Goddess Of The Moon(递推+矩阵优化)

题目链接:传送门 题意: 相当于有一个长度为m的路,我们有n种砖,每种砖被表示为一个字符串,一个长度大于等于2的后缀等于 另一个字符串的前缀那么那一块砖就可以放在这块砖的后面. 分析: 这个就是常见的铺砖的那个模型变化而来的,但是这题的递推关系需要根据题目给定的字符串的结构来决 定,由于m比较大,我们需要用矩阵来优化,根据题目给定的字符串来确定状态转移矩阵A,初始的矩阵为单 位矩阵I,然后ans = A^(m-1)*I.在确定A的时候注意给字符串去重. 代码如下: #include <iostr

【矩阵快速幂】HDU 5318 The Goddess Of The Moon

通道 题意:n个数,A后缀和B的前缀相同,建边,问长度为m的有多少个. 思路:建图,完了 代码: 1 #include<cstdio> 2 #include<cstring> 3 #include <vector> 4 5 using namespace std; 6 7 typedef long long ll; 8 9 const int MAX_N = 57; 10 const ll MOD = 1000000007; 11 12 typedef vector&l

矩阵快速幂 HDOJ 5318 The Goddess Of The Moon

题目传送门 1 /* 2 DP::dp[i][k] 表示选择i个字符串,最后一次是k类型的字符串,它由sum (dp[i-1][j]) (a[j], a[k] is ok)累加而来 3 矩阵快速幂:将n个字符串看成n*n的矩阵,如果匹配,矩阵对应位置为1.矩阵缩短递推dp时间,然后乘m-1次(dp[m][i])累加即可 4 注意去重 5 详细解释:http://blog.csdn.net/keshuai19940722/article/details/47111215 6 */ 7 #inclu