pat解题报告【1082】

1082. Read Number in Chinese (25)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way.  Output "Fu" first if it is negative.  For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu".  Note:
zero ("ling") must be handled correctly according to the Chinese tradition.  For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number.  The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:

-123456789

Sample Output 1:

Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:

100800

Sample Output 2:

yi Shi Wan ling ba Bai

简单的模拟,只是过程描述有点啰嗦。

首先这句话什么意思  Note: zero ("ling") must be handled correctly according to the Chinese tradition

什么叫Chinese tradition,其实就是对0的特殊处理。

【1】尾部的0不发音

【2】多个连续的0,只发一个音

【3】多个不连续的0,都要发音

【4】大于4位的数肯定要发 Wan 音

【5】大于8位的数一定要发 Yi 音

而且还有个规律: Shi Bai Qian 这三个音循环出现。

Ac代码:

// pat-1082.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"

#include "iostream"
#include "string"
#include "algorithm"
#include "vector"
#include "stack"

using namespace std;
stack<string> ans;
string num[]={"ling", "yi" ,"er" , "san" , "si" ,  "wu",  "liu" , "qi",  "ba",  "jiu"};
string pos[]={ "Shi","Bai","Qian", "Wan","Yi" };
int main()
{
	long int n=0;
	bool firstout=true;
	cin>>n;
	if (n==0)
	{
		cout<<"ling";
		goto end;
	}
	if (n<0)
	{
		cout<<"Fu";
		firstout=false;
		n=-(n);
	}
	int cnt=0;
	bool wan_flag=false;
	bool zero=false;
	bool first=true;
	while(n)
	{
	  int temp=n%10;
	  //0 特殊处理
	  if (temp==0)
	  {
		  if (cnt==3)
		  {
			  wan_flag=true;
		  }
		  n/=10;
		  if (!first)
		  {
			  cnt++;
		  }
	      first=false;
		  if (zero)//第一次遇到0
		  {
			  ans.push(num[0]);
			  zero=false;
			  continue;
		  }
		  else
		  {
			  continue;
		  }
	  }
	  zero=true;
	  if(first)//忽略个位
	  {
		    ans.push(num[temp]);//yi er san si ~~~~~
			 n/=10;
			  first=false;
			 continue;
	  }
	 if(cnt<7)
	 {
		 if (wan_flag)
		 {
			 wan_flag=false;
			 ans.push(pos[3]);
		 }
	     ans.push(pos[cnt%4]);//shi bai qian wan
	  }
	 else
     {
	  ans.push(pos[4]);//yi
	 }

	  ans.push(num[temp]);//yi er san si ~~~~~

	  n/=10;
	  cnt++;

	}
	while (!ans.empty())
	{
		string temp=ans.top();
		ans.pop();
		if (firstout)
		{
			firstout=false;
			cout<<temp;
			continue;
		}
		cout<<" "<<temp;
	}
end:	return 0;
}

pat解题报告【1082】,布布扣,bubuko.com

时间: 2024-10-14 16:19:58

pat解题报告【1082】的相关文章

pat解题报告【1074】

1074. Reversing Linked List (25) 时间限制 300 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L.  For example, given L being 1→2→3→4→5→

pat解题报告【1073】

1073. Scientific Notation (20) 时间限制 100 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 HOU, Qiming Scientific notation is the way that scientists easily handle very large numbers or very small numbers.  The notation matches the regular expression [

pat解题报告【1078】

1078. Hashing (25) 时间限制 100 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers.  The hash fun

2016.8.29 解题报告之我会做的题都是简单题

老规矩,要相关资料联系邮箱: 考试分析: 1.  画图确定性质,其实我开始也打算用二进制判重的,但进制题一般不会使状态无法用longlong表示出来,然后那种确定了某种状态以后就排除了无关变量,直接取最优的思路也很不错: 2.  最早入手的题以及死在上面的题,还想了了很久的复杂度证明和对拍,无话可说,希望这次AK之路被断能让我涨一点记性,以后要抓住脑海里的每一点信息(本来还想了longlong这个问题的): 3.  找性质,把在线决策问题转化为线性判断类问题,排除任务之间有一点橡树的关系的无关干

解题报告 之 POJ3057 Evacuation

解题报告 之 POJ3057 Evacuation Description Fires can be disastrous, especially when a fire breaks out in a room that is completely filled with people. Rooms usually have a couple of exits and emergency exits, but with everyone rushing out at the same time

hdu 1541 Stars 解题报告

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1541 题目意思:有 N 颗星星,每颗星星都有各自的等级.给出每颗星星的坐标(x, y),它的等级由所有比它低层(或者同层)的或者在它左手边的星星数决定.计算出每个等级(0 ~ n-1)的星星各有多少颗. 我只能说,题目换了一下就不会变通了,泪~~~~ 星星的分布是不是很像树状数组呢~~~没错,就是树状数组题来滴! 按照题目输入,当前星星与后面的星星没有关系.所以只要把 x 之前的横坐标加起来就可以了

【百度之星2014~初赛(第二轮)解题报告】Chess

声明 笔者最近意外的发现 笔者的个人网站http://tiankonguse.com/ 的很多文章被其它网站转载,但是转载时未声明文章来源或参考自 http://tiankonguse.com/ 网站,因此,笔者添加此条声明. 郑重声明:这篇记录<[百度之星2014~初赛(第二轮)解题报告]Chess>转载自 http://tiankonguse.com/ 的这条记录:http://tiankonguse.com/record/record.php?id=667 前言 最近要毕业了,有半年没做

2016 第七届蓝桥杯 c/c++ B组省赛真题及解题报告

2016 第七届蓝桥杯 c/c++ B组省赛真题及解题报告 勘误1:第6题第4个 if最后一个条件粗心写错了,答案应为1580. 条件应为abs(a[3]-a[7])!=1,宝宝心理苦啊.!感谢zzh童鞋的提醒. 勘误2:第7题在推断连通的时候条件写错了,后两个if条件中是应该是<=12 落了一个等于号.正确答案应为116. 1.煤球数目 有一堆煤球.堆成三角棱锥形.详细: 第一层放1个, 第二层3个(排列成三角形), 第三层6个(排列成三角形), 第四层10个(排列成三角形). -. 假设一共

[noip2011]铺地毯(carpet)解题报告

最近在写noip2011的题,备战noip,先给自己加个油! 下面是noip2011的试题和自己的解题报告,希望对大家有帮助,题目1如下 1.铺地毯(carpet.cpp/c/pas) [问题描述]为了准备一个独特的颁奖典礼,组织者在会场的一片矩形区域(可看做是平面直角坐标系的第一象限)铺上一些矩形地毯.一共有n 张地毯,编号从1 到n.现在将这些地毯按照编号从小到大的顺序平行于坐标轴先后铺设,后铺的地毯覆盖在前面已经铺好的地毯之上.地毯铺设完成后,组织者想知道覆盖地面某个点的最上面的那张地毯的