07-2. Insert or Merge (25)

07-2. Insert or Merge (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts
it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist
remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed
that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed
that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6


提交代

#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
using namespace std;
#define lson rt<<1,l,MID
#define rson rt<<1|1,MID+1,r
//#define lson root<<1
//#define rson root<<1|1
#define MID ((l+r)>>1)
typedef long long ll;
typedef pair<int,int> P;
const int maxn=105;
const int base=1000;
const int inf=999999;
const double eps=1e-5;
int a[maxn];
int aa[maxn];
int b[maxn];
int n;
bool same(int *a,int *b)//判断相同不
{
    for(int i=1; i<=n; i++)
    {
        if(a[i]!=b[i])
            return false;
    }
    return true;
}

bool insert_sort()//真的插入的排序
{
    int i,j;
    int last=0;
    for(i=2; i<=n; i++)///从i=2 开始 不然第二测试点错了
    {
        a[0]=a[i];
        for(j=i-1; a[j]>a[0]; j--)
        {
            a[j+1]=a[j];
        }
        a[j+1]=a[0];
        if(last)
        {
            return true;
        }
        if(same(a,b))
        {
            last=1;
        }
    }
    return false;
}

void merge_sort()//模拟归并排序
{
    int last=0,i,j;
    for(i=2;i<=n;i*=2)
    {
        for(j=1;j+i<=n+1;j+=i)
        {
            sort(aa+j,aa+j+i);
        }
        sort(aa+j,aa+n+1);
        if(last)return;
        if(same(aa,b))
            last=1;
    }
    sort(aa+1,aa+n+1);
}

int main()
{
    int m,i,j,k,t;
    scanf("%d",&n);
    for(i=1; i<=n; i++)
    {
        scanf("%d",&a[i]);
        aa[i]=a[i];
    }
    for(i=1; i<=n; i++)
    {
        scanf("%d",&b[i]);
    }
    if(insert_sort())
    {
        puts("Insertion Sort");
        printf("%d",a[1]);
        for(i=2; i<=n; i++)
            printf(" %d",a[i]);
        printf("\n");
    }
    else
    {
        puts("Merge Sort");
        merge_sort();
        printf("%d",aa[1]);
        for(i=2; i<=n; i++)
            printf(" %d",aa[i]);
        printf("\n");
    }
    return 0;
}

/*
10
3 1 2 8 7 5 9 4 0 6
1 2 3 4 5 7 8 9 0 6

*/
时间: 2024-08-27 14:13:48

07-2. Insert or Merge (25)的相关文章

pat1089. Insert or Merge (25)

1089. Insert or Merge (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion s

PTA 09-排序2 Insert or Merge (25分)

题目地址 https://pta.patest.cn/pta/test/16/exam/4/question/675 5-13 Insert or Merge   (25分) According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort rem

1089. Insert or Merge (25)【排序】——PAT (Advanced Level) Practise

题目信息 1089. Insert or Merge (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, find

1089. Insert or Merge (25)

1089. Insert or Merge (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion s

A1089. Insert or Merge (25)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted li

PAT (Advanced Level) 1089. Insert or Merge (25)

简单题.模拟一下即可. #include<cstdio> #include<cstring> #include<cmath> #include<vector> #include<map> #include<queue> #include<stack> #include<algorithm> using namespace std; const int maxn=200; int a[maxn],b[maxn],

PAT 1089. Insert or Merge (25)

According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted li

PAT 1088 1089. Insert or Merge (25)(排序啊)

题目链接:http://www.patest.cn/contests/pat-a-practise/1089 According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input d

PAT_A1089#Insert or Merge

Source: PAT A1089 Insert or Merge (25 分) Description: According to Wikipedia: Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input da