hdu1698 Just a Hook (线段树区间更新 懒惰标记)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 22730    Accepted Submission(s): 11366

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.

For each silver stick, the value is 2.

For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.

You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.

For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.

Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents
the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

Source

2008 “Sunline Cup” National Invitational Contest

Recommend

wangye   |   We have carefully selected several similar problems for you:  1542 1394 2795 1255 1828

Statistic | Submit | Discuss | Note
更新的时候不要直接更新到底部,会超时的。不用尝试。。我已经当了小白鼠。。

要用懒惰标记..就是更新的时候只更新到区间,同时lazy[]数组标记一下,如果下次更新的时候用到了上次已经更新的点

在把上次lazy[]数组标记的往下更新

想感叹。。做ACM的 太累了。。你做对还不行  还要不能超时

#include <stdio.h>
struct node
{
	int left,right,val,lazy,tag;
}c[100000*3];
void build_tree(int l,int r,int root)
{
	c[root].left=l;
	c[root].right=r;
	c[root].lazy=0;
	c[root].tag=0;
	if(l==r)
	{
		c[root].val=1;
		return ;
	}
	int mid=(c[root].left+c[root].right)/2;
	build_tree(l,mid,root*2);
	build_tree(mid+1,r,root*2+1);
	c[root].val=c[root*2].val+c[root*2+1].val;
}
void update_tree(int l,int r,int x,int root)
{
	if(c[root].left==l&&r==c[root].right)
	{
		c[root].val=(r-l+1)*x;
		c[root].lazy=1;
		c[root].tag=x;
		return ;
	}
	int mid=(c[root].left+c[root].right)/2;
	if(c[root].lazy==1)
	{
		c[root].lazy=0;
		update_tree(c[root].left,mid,c[root].tag,root*2);
		update_tree(mid+1,c[root].right,c[root].tag,root*2+1);
		c[root].tag=0;
	}
	if(mid<l)
	update_tree(l,r,x,root*2+1);
	else if(mid>=r)
	update_tree(l,r,x,root*2);
	else
	{
		update_tree(l,mid,x,root*2);
		update_tree(mid+1,r,x,root*2+1);
	}
	c[root].val=c[root*2].val+c[root*2+1].val;
}
int main()
{
	int ncase,n,k;
	scanf("%d",&ncase);
	for(int t=1;t<=ncase;t++)
	{
		scanf("%d",&n);
		build_tree(1,n,1);
		scanf("%d",&k);
		while(k--)
		{
			int a,b,x;
			scanf("%d %d %d",&a,&b,&x);
			update_tree(a,b,x,1);
		}
		printf("Case %d: The total value of the hook is %d.\n",t,c[1].val);
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-10-12 00:37:59

hdu1698 Just a Hook (线段树区间更新 懒惰标记)的相关文章

【原创】hdu1698 Just a Hook(线段树→区间更新,区间查询)

学习线段树第二天,这道题属于第二简单的线段树,第一简单是单点更新,这个属于区间更新. 区间更新就是lazy思想,我来按照自己浅薄的理解谈谈lazy思想: 就是在数据结构中,树形结构可以线性存储(线性表)也可以树状存储(链表) 树形typedef struct node { int data; struct node* Lchild; struct node* Rchild; }Btree,*BTree;BTree = (BTree)malloc(Btree);好像是这样吧...大半个暑假过去忘得

【HDU 4614】Vases and Flowers(线段树区间更新懒惰标记)

题目0到n-1的花瓶,操作1在下标a开始插b朵花,输出始末下标.操作2清空[a,b]的花瓶,求清除的花的数量.线段树懒惰标记来更新区间.操作1,先查询0到a-1有num个空瓶子,然后用线段树的性质,或者二分找出第num+1个空瓶子的下标,和第num+b个空瓶子的下标.再区间更新为满.操作2,也相当于区间更新为空. #include<cstdio> #include<cstring> #include<algorithm> #define N 50001 using na

Hdu1698Just a Hook线段树区间更新

区间更新基础..不说了,也是照着notonlysuccess的博客撸的. #include <cstdio> #include <cstring> #include <algorithm> #include <climits> #include <string> #include <iostream> #include <map> #include <cstdlib> #include <list>

HDU 1698 Just a Hook (线段树,区间更新)

Just a Hook Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 17214    Accepted Submission(s): 8600 Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing f

HDU 1689 Just a Hook 线段树区间更新求和

点击打开链接 Just a Hook Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 18894    Accepted Submission(s): 9483 Problem Description In the game of DotA, Pudge's meat hook is actually the most horrible

(简单) HDU 1698 Just a Hook , 线段树+区间更新。

Description: In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. Now Pudge wants to do some operations on the hook

HDU 1698 Just a Hook (线段树 区间更新基础)

Just a Hook Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 21856    Accepted Submission(s): 10963 Problem Description In the game of DotA, Pudge's meat hook is actually the most horrible thing

Just a Hook 线段树 区间更新

Just a Hook In the game of DotA, Pudge's meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. Now Pudge wants to do some operations on the hook.

hdu 1698 Just a Hook 线段树区间更新

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1698 Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks